Subject: Re: Verifying IBIS models

From: Luke Chang <[email-masked]>
Date: Fri, 30 May 1997 15:28:32 -0400 (EDT)

Hi,

When IC vendors create IBIS models for their components, how do they
verify whether they are correct or not, compared to either the original
SPICE models or to physical measurement data?  Do they actually do this
comparison?  Is there a simulation methodology to do this comparison?

I am just a user of IBIS models and will never create them.  So I am
mainly interested in knowing whether I can always (blindly) trust the 
models I get from the vendor Web sites or directly from the vendors.

Thanks.

Luke Chang
Ascom Nexion, Inc.
Acton, MA

---

From: "D. C. Sessions" <[email-masked]>
Date: Fri, 30 May 1997 13:10:57 -0700

> models I get from the vendor Web sites or directly from the vendors.

I suppose the usual disclaimers (I can't, strictly speaking,
speak for VLSI, much less other manufacturers) are in order.
That said, here's a little about our approach:

1) We SPICE the dickens out of I/O designs.
2) We verify the SPICE characteristics in design
   validation and test against them.
3) We generate IBIS models from the SPICE models.
4) We spot-compare SPICE simulations made from
   hand-translating IBIS back to SPICE.

We're in the process of converting the canonical
model for testing purposes from old-fashioned data
sheets to IBIS.  We *intensely* wish we had a
working IBIS-to-SPICE translator that we could use
for closing the loop, but at present there don't
seem to be any around.

-- 
D. C. Sessions
[email-masked]

---

From: Jon Powell <[email-masked]>
Date: Fri, 30 May 1997 16:30:37 -0700

The actual IBIS party line is (well, might be):

All models are always right, however it is astonishing how often they
point to actual design errors in the silicon....

:)

jon