Subject: re IBIS rev 2.1 additons to rev1.2

From: [email-masked] (Bob Ross)
Date: Mon, 24 Nov 1997 16:31:58 -0800 (PST)

Eitan:

You can convert this model to Version 1.1 IBIS by removing
the waveform tables as you suggest.

Also, you need to comment out or remove the [Temperature Range]
keyword and change the [IBIS Ver] to 1.1.  Any of the ibichk
utilities including ibischk2 will validate Version 1.1 models
against the Version 1.1 syntax.  With this process, you can
detect other Version 2.1 keywords and subparameters that
need to be removed for Version 1.1 level parsing.

Best Regards,
Bob Ross
Interconnectix

From: "Eitan Medina" <[email-masked]>
Organization: Galileo Technology Ltd.
To: [email-masked]
Date: Sun, 23 Nov 1997 09:44:20 +0200
Subject: IBIS rev 2.1 additions to rev 1.2

Hi,

I have generated simple rev2.1 models for CMOS device, that includes
the following elements:
	pullup
	pulldown
	ramp
	rising waveform
	falling waveform
	POWER clamp
	GND clamp

I have a client who cannot use this, since he has only rev1.1
simulator, and asks for a rev1.1 model.

The Parsers in the web-site, as well an editor I have (from Hyperlynx)
verify rev2.1 compatability only (no rev1.1 compatability check...)

What should be removed/changed from the model in order to
make it readable by a rev1.1 simulator ?

>From what I have read, only the rising and falling waveforms should be
removed. Am I correct ? Can someone with a rev1.1 simulator try this
out for me ?

Attached:
	Simple rev 2.1 model (with one pad)

Thanks,

	Eitan

Eitan Medina
Email: [email-masked]
Galileo Technology Ltd.
15 Geron st. 
P.O.Box 2786
Yehud 56217
ISRAEL
Tel:   +972-3-6320220
Fax:   +972-3-6320221 
*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
* check out our new web site:   http://www.GalileoT.com *
*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*

---

From: Stephen Peters <[email-masked]>
Date: Tue, 25 Nov 1997 13:39:03 -0800

Hello Eitan:

    I've been following the conversttion and I just want to add
a word of warning.  While you can convert a Ver 2.1 model into
a Ver. 1.1 model by eliminating (among other things) the waveform
tables, you may be deleting information critical to the models proper
operation. Before doing the conversion I would
check with the model creator and see if eliminating the waveform
tables will give bad simulation results.  At the least, run a
before and after simulation and compare the results.

              Regards,
              Stephen Peters
              Intel Corp.