Subject: ecl models in ibis

From: [email-masked]
Date: Fri, 13 Nov 1998 14:26:48 -0800 (PST)

IBIS Gurus, Experst, Inventors, and Developers:

Can anybody clarify the following ECL model related issues in IBIS.
Below is an excerpt from IBIS file (downloaded from internet).
I have 2 questions regasrding these data.

1) Why current in PU/PD tables is always negative? Why
   the buffer "ECL_OBUF3_5" always source current and never sink current?
   Is this something "ECL_OBUF3_5" model specific or it is a typical case for
   Output_ECL buffer?

2) regarding:

   [Voltage Range]            0.0    0.0    0.0
   [Pulldown Reference]       0.0    0.0    0.0
   [Power Clamp Reference]    0.0    0.0    0.0
   [GND Clamp Reference]      -3.3   -3.0   -3.8

   Why [Pulldown Reference] = 0, why not to use [Pulldown Reference] = -3.3V ?
   THis question is more about conventions used.
   It is clear what voltages are applied. Why not to use notations:

   [Voltage Range]            0.0    0.0    0.0
   [Pullup Reference]         0.0    0.0    0.0   (*)
   [Pulldown Reference]       -3.3   -3.0   -3.8
   [Power Clamp Reference]    0.0    0.0    0.0   (*)
   [GND Clamp Reference]      -3.3   -3.0   -3.8

   (*) indicate optional parameter (no need to include it, but no harm if it is
       given)

Thank you

Nik

[email-masked]

[IBIS ver]     2.1
[File name]    mc_lvecl.ibs
[File Rev]     1.2
[Date]         4/28/98
[Source]       Motorola spice models
[Notes]        This ibis package is made for Motorola ECLinPS and ECLinPS Lite
               families, and is particularly for the Low Voltage family. It
               includes

[Model]     ECL_OBUF3_5
Model_type  Output_ECL
Polarity    Non-Inverting
Vmeas = -1.3
Rref  = 50.0
Vref  = -2.0
|
|Variable            typ    min    max
C_comp              2.9p   2.0p   6.0p
|
|Variable            typ    min    max
[Temperature Range]  27      0     85
|
|Variable                  typ    min    max
[Voltage Range]            0.0    0.0    0.0
[Pulldown Reference]       0.0    0.0    0.0
[Power Clamp Reference]    0.0    0.0    0.0
[GND Clamp Reference]      -3.3   -3.0   -3.8
|
[Pulldown]
|Volts    I(typ)    I(min)    I(max)
+3.00  -2.290e-01  -1.623e-01  -2.832e-01
+2.90  -2.152e-01  -1.523e-01  -2.603e-01
+2.80  -2.010e-01  -1.419e-01  -2.422e-01
+2.70  -1.862e-01  -1.312e-01  -2.240e-01
+2.60  -1.707e-01  -1.201e-01  -2.050e-01
+2.50  -1.544e-01  -1.085e-01  -1.850e-01
+2.40  -1.372e-01  -9.633e-02  -1.637e-01
+2.30  -1.189e-01  -8.357e-02  -1.410e-01
+2.20  -9.939e-02  -7.012e-02  -1.166e-01
+2.10  -7.841e-02  -5.592e-02  -9.036e-02
+2.00  -5.586e-02  -4.094e-02  -6.207e-02
+1.90  -3.210e-02  -2.537e-02  -3.272e-02
+1.80  -1.011e-02  -1.036e-02  -8.403e-03
+1.70  -6.249e-04  -1.060e-03  -5.795e-04
+1.60  -1.429e-05  -1.917e-05  -2.407e-05
+1.50  +0.000e+00  +0.000e+00  +0.000e+00
+1.00  +0.000e+00  +0.000e+00  +0.000e+00
+0.50  +0.000e+00  +0.000e+00  +0.000e+00
+0.00  +0.000e+00  +0.000e+00  +0.000e+00
|
|
[Pullup]
|Volts    I(typ)    I(min)    I(max)
+3.00  -2.528e-01  -1.876e-01  -3.089e-01
+2.90  -2.436e-01  -1.790e-01  -2.977e-01
+2.80  -2.346e-01  -1.709e-01  -2.869e-01
+2.70  -2.258e-01  -1.639e-01  -2.761e-01
+2.60  -2.169e-01  -1.571e-01  -2.653e-01
+2.50  -2.081e-01  -1.503e-01  -2.545e-01
+2.40  -1.992e-01  -1.433e-01  -2.437e-01
+2.30  -1.902e-01  -1.361e-01  -2.328e-01
+2.20  -1.812e-01  -1.288e-01  -2.219e-01
+2.10  -1.721e-01  -1.212e-01  -2.110e-01
+2.00  -1.630e-01  -1.135e-01  -2.000e-01
+1.90  -1.536e-01  -1.055e-01  -1.889e-01
+1.80  -1.440e-01  -9.734e-02  -1.777e-01
+1.70  -1.339e-01  -8.885e-02  -1.664e-01
+1.60  -1.229e-01  -8.005e-02  -1.548e-01
+1.50  -1.106e-01  -7.090e-02  -1.426e-01
+1.40  -9.719e-02  -6.136e-02  -1.282e-01
+1.30  -8.285e-02  -5.139e-02  -1.079e-01
+1.20  -6.708e-02  -4.094e-02  -8.326e-02
+1.10  -4.788e-02  -2.997e-02  -5.614e-02
+1.00  -2.591e-02  -1.797e-02  -2.801e-02
+0.90  -6.389e-03  -5.536e-03  -6.124e-03
+0.80  -2.749e-04  -2.551e-04  -3.688e-04
+0.70  -6.068e-06  -3.933e-06  -1.513e-05
+0.60  +0.000e+00  +0.000e+00  +0.000e+00
+0.40  +0.000e+00  +0.000e+00  +0.000e+00
+0.20  +0.000e+00  +0.000e+00  +0.000e+00
+0.00  +0.000e+00  +0.000e+00  +0.000e+00
|
|
[Ramp]
|Variable    typ    min    max
dV/dt_r  0.48/0.32n  0.46/0.34n  0.48/0.26n
dV/dt_f  0.47/0.30n  0.45/0.33n  0.49/0.26n
|

---

From: [email-masked] (Bob Ross)
Date: Fri, 13 Nov 98 18:27:13 PST

Nik:

Answers to your questions are in your text.

Bob Ross
Mentor Graphics

> From: [email-masked]
> Date: Fri, 13 Nov 1998 14:26:48 -0800 (PST)
> Message-Id: <[email-masked]>
> To: [email-masked]
> Subject: ecl models in ibis

>    Is this something "ECL_OBUF3_5" model specific or it is a typical case for

The currents are negative because they follow the polarity convention
that currents are positive when they are flowing into the pin.  Output_ECL
buffers typically source current in both the high and low stages.

>    Why [Pulldown Reference] = 0, why not to use [Pulldown Reference] = -3.3V ?

The IBIS Spec set the reference voltage for BOTH the Pulldown and Pullup
tables to the highest rail - in this case 0 Volts.  So this table follows
the Standard.

>    (*) indicate optional parameter (no need to include it, but no harm if it is

We did treat the ECL case as different.  thus the conventions you suggest
do not work.