Subject: help with ibis

From: "Ahsanullah, Zahid" <[email-masked]>
Date: Thu, 8 Oct 1998 14:54:17 -0700

I am having some difficulty getting ibis to compile. Can anyone explain
the following:

1. how do you specify [pin], the following does not work due to parser
error:
	[pin]
	1	out1	obuf	200.0m	5.0nH	2.0pF

2. how would you specify a tristate output buffer that has an enable
    and an input data pin.

3. this does not work:
	[comment char]		*_char

4. [notes]	blah blah blah
	core dumps

5. [spice command]	hspice filename.hs
	does parse error

6. [model file]	/usr/aaa/bbb/model.hs
	does not read model file

7. [package]	blah
	gives parse error

There are more but this will atleast get me going. I am a new user
and it seems I may have an alpha realease at hand. I am running
dec unix and I got program s2ibis2 from the official ibis website at
http://www.eia.org/eig/ibis/

thanks
Zahid

> -------------------------------------------------------------
> | Zahid Ahsanullah, Intel Austin Design Center	|
> | StrongARM, SA1100, SA1500 design			|
> | Email: [email-masked]			|
> | phone: 512-306-7421						|
> | fax: 512-306-7441						|
> |
> |
> |" One night in the mirror I saw a movie star,		|
> |   so I flew to hollywood in neighbors car."		|
> |                                    --Dada--				|
> -------------------------------------------------------------
> 
> 
>

---

From: Syed Huq <[email-masked]>
Date: Thu, 8 Oct 1998 16:16:30 -0700 (PDT)

Hi,

Most of your syntax is wrong.

> 	1	out1	obuf	200.0m	5.0nH	2.0pF

  You are missing a field in the above line. Below are the fields required.
  pin_name  spice_node  signal_name  model_name

> 2. how would you specify a tristate output buffer that has an enable

See the example in s2ibis2/examples/ex2/tristate.s2i, you need to make use of 
the "->" syntax and create dummy model 

> 5. [spice command]	hspice filename.hs

    Needs to be of this format: hspice %s >%s 2>%s
	
    Extracted from the doc file:		
	It has three "%s" printf conversion
        characters, one each for the spice input file, the spice output
        file and the spice message file (this last is optional), IN THAT
        ORDER. See the string variable defaultSpiceCommand in the file
        src/s2istrng.h
> 6. [model file]	/usr/aaa/bbb/model.hs

    Not familiar with this keyword!!
> 	gives parse error
This keyword does not require a blah but if you want to use [Package model] then
you can specify a blah..

I would suggest that you read up on the /doc/s2ibis2.txt and also try
out the examples before running a translation on your design.

You should also be using the s2ibis2_fix version of the tool.

Hope this helps.

Regards,
Syed.
Cisco Systems, Inc