Subject: Minutes from IBIS User Group held 5/28/98

From: Kathy Breda <[email-masked]>
Date: Wed, 17 Jun 1998 12:54:10 -0400

<excerpt>***Minutes of the IBIS Users Group Meeting

   held at Stratus on Thursday, May 28, 1998***

NEXT Meeting:

	Date:  Thursday, June 25, 1998

	Time:	 3:00 PM

	Place: Stratus, Marlboro, MA

Thanks to Bruce Heilbrunn of Stratus for hosting the

May meeting.  We have decided to simplify and will

be holding our meetings at Stratus since it is

central to most and has good facilities and parking.

Agenda of May 28th meeting:

*  IBIS education curriculum

*  Update on Connector Modeling BIRD

*  Accuracy Specification and Test Board Update

<bold>IBIS Education Curriculum Development Effort</bold>:

This area of the user group needs to be revived. Jow Socha and Ed Sayre
met on 6/16/98 to set new direction.  They will collect existing
educational material and case studies (IBIS Cookbook for instance) to see
where the materials stand.  A curriculum will be attempted from that
material.  We need to revive this committee in the Fall of '98 to give it
purpose and direction. If other IBIS members have training materials they
would like to contribute to the effort, then this will make the effort
that much easier.

</excerpt>

<excerpt>

<bold>Update on Connector Modeling BIRD:

</bold>Goals:

a) Must simulate faster than SPICE

b) Include pin number so partial simulations are possible

c) Match pin numbers inside model to the schematics

d) Allow the inclusion of circuit element matrices created from 2-d field
solver slices or 3-D field modelers.

Go for simple vs. complicated models.

Starting with existing Connector BIRD(31.3).  Working on how

to expand small connector model all the way to full long (large)
connector models.  Also need to address

issue of bookkeeping vs. physics (pin numbering vs. matrix row column
numbering.  Since long connectors create large size of matrices, the
efficient handling of non-zero off diagonal elemenst. Criteria for
setting small non-zero elements to zero not discussed but is a topic to
address.)

<bold>

Accuracy Specification and Test Board Update: </bold>See attached file
for presentation.

Accuracy Board Milestones:

7/98  Finish test board (in routing now)

9/98  Rough draft ready for review

6/98  measurement techniques

7/98  measurement techniques

8/98  correlation metrics

10/98 PCB East

2/99  DesignCon99

IBIS Accuracy Specification Scope:  This is being defined and refined by
the Accuracy Sub-committee.  Bob Haller is leading the dcoumentation
effort. 

Interesting fact:  The IBIS [Waveform] keyword was implemented to account
for variations in 

ramp functions between EDA vendors!

IBIS Accuracy Specification Required Measurements:

Driver test loads are well-defined.

Required IV curve measurements are NOT well-defined.

Required capacitance measurements are NOT well-defined.

IBIS Accuracy Specification Required Measurements

Two possible approaches:

Measure a full set of test loads, full set of IV curves, and capacitance
for each unique I/O circuit design.

Measure a representative of a family of I/O circuit designs.

How do we specify C_pkg and C_pin measurements?

</excerpt>

<<end>

---

From: Chris Rokusek <[email-masked]>
Date: Fri, 19 Jun 1998 12:03:22 -0700

Kathy,

I would like to strongly encourage the IBIS East members involved with
"Accuracy Specification" to read through the latest cookbook.  It
describes (with illustrations!) how to perform many of the ibis
measurement techniques.

    http://www.eia.org/eig/ibis/tools.htm
    
    Click "IBIS Cookbook for V2.1 (Oct 13th '97)"

Please pass my recommendation on the the IBIS East committee at your
next meeting.

Best Regards,

Chris Rokusek

CONTENTS:

1.0 Introduction	
1.1 Quick Overview of an IBIS File	
1.2 Steps to creating an IBIS Model	
2.0 Pre-Modeling Steps	
2.1 Basic Decisions	
      - Model Version and Complexity	
      - Specification Model  vs. Part Model	
      - Fast and Slow Corner Model Limits	
      - Inclusion of SSO Effects	
2.2 Information Checklist	
2.3 Tips For Component Buffer Grouping	
3.0 Extracting the Data	
3.1 Using Spice to IBIS (s2ibis)	
3.2 Extracting I/V and Switching Data via Simulations	
   3.2.1 Extracting the I/V Data	
      - Simulation Setup	
      - 3-state Buffers	
      - Output Only Buffers	
      - Open Drain Buffers	
      - Input Buffers	
      - Sweep Ranges	
      - Making Pullup and Power Clamp Sweeps Vcc Relative	
      - Diode Models	
      - Diode Transient Time Data	
   3.2.2 Extracting the Ramp Rate or V/T Waveform Data	
      - Extracting Data for the [Ramp] Keyword	
      - Extracting Data for the Rising and Falling Waveform Keywords	
      - Minimum Time Step	
      - Multi State Drivers	
3.3 Obtaining I/V and Switching Information via Lab Measurment	
4.0 Putting the Data Into an IBIS File	
4.1 IBIS File Header Information	
4.2 Component and Pin Information	
4.3 The [Model] Keyword	
      - Parameter section	
      - Temperature and Voltage Keywords	
      - I/V data section	
      - Pulldown	
      - Ground Clamp	
      - Pullup	
      - Power Clamp	
      - Extrapolation Errors	
      - [Ramp] and Waveform Tables	
4.4 External Package Models	
4.5 Verifying the IBIS file	
5.0 Validating the Model	
6.0 Correlating the Data	
7.0 Resources