Subject: Bidirectional Pad with 5.0V tolerant input

From: David Makihara <[email-masked]>
Date: Fri, 12 Jun 1998 16:17:21 -0700

IBIS Users:

I had created an IBIS model for one of our devices that have 5 volt tolerant
I/O pads.  This specific I/O pad is capable of driving to 3.3V but can
tolerate input voltages up to 5V.  Voltage sweep ranges (ie. table entries)
are shown in 1) below.  
I  had also set "[Voltage Range]         3.300V      2.9700V      3.6300V"
for this specific pad. However, I'm concerned with using [Voltage Range] for
this pad and feel as though the "Reference" voltage parameters should be
used. However, I'm at a loss on how to use these "Reference" parameters
listed in 2) below.

1) Are the appropriate voltage sweep ranges appropriate?
	[GND_clamp] -5V -> 5V
	[POWER_clamp] -5V -> 0V 
	[Pulldown] -5V -> 10V
	[Pullup] -5V -> 10V
2) What values should be applied to the following?
	[Pullup Reference]
	[Pulldown Reference]
	[POWER Clamp Reference]
	[GND Clamp Reference]   

Thanks for your help

David Makihara
PMC-Sierra Inc.
Burnaby, BC
Canada

---

From: "D. C. Sessions" <[email-masked]>
Date: Fri, 12 Jun 1998 17:14:09 -0700

> 2) What values should be applied to the following?

3.3v

>         [Pulldown Reference]

Ground

>         [POWER Clamp Reference]

5v

>         [GND Clamp Reference]

Ground

---------------------------------------------

Think of it this way: the pullup current must
track changes in the pullup reference, the power
clamp current must track with the power clamp voltage,
etc.  Typically, the V/I curves go to zero current
at 0 volts (the reference potential) and the physical
rail that has the same property is the right one.

-- 
D. C. Sessions
[email-masked]

---

From: Stephen Peters <[email-masked]>
Date: Sun, 14 Jun 1998 17:50:19 -0700

Hello David:

   My comments below, prefixed with  --

            Regards,
            Stephen Peters
            Intel Corp.

> 1) Are the appropriate voltage sweep ranges appropriate?

   -- per the IBIS cookbook the sweep ranges are correct.  Basicly, you
   -- want to cover the entire range of what the pad (input) could see.

> 2) What values should be applied to the following?

    -- if this device drives 3.3v (nominal) and there is no separate 
    -- voltage rail for the clamp diodes, the there is no reason to
    -- use the extra keywords, the [Voltage Range] keyword will do.

> Thanks for your help

   -- no problem :)