Subject: RE: IBIS MOdel Question

From: tomda <[email-masked]>
Date: Fri, 22 Oct 1999 11:10:57 -0700

There is one sanity check that I would like to see done on all models 
produced from SPICE data.  I have seen too many models that are constructed 
correctly fail this check.

Check to make sure the IV characteristics derived from SPICE match the IV 
characteristics of real parts.  The easiest was to do this is to put one of 
the buffers from each strength into both its high and low states.  Us a DC 
current meter and measure the output current to ground for the high state 
and to Vcc for the low state.  Then check to see if the measured current 
falls between the min and max values at the corresponding points on the IV 
curves.

Tom Dagostino

-----Original Message-----
From:	Kim Helliwell [SMTP:[email-masked]]
Sent:	Wednesday, October 20, 1999 11:20 AM
To:	Tony Palmieri
Cc:	[email-masked]
Subject:	Re: IBIS MOdel Question

Make sure that:

1. The curves are continuous
2. The ramps (if any) cover the whole switching range
3. All pins are assigned to models

These are the three worst problems I've run into trying
to use IBIS models supplied by well-known parts vendors.

If you have access to one of the commercially available
signal integrity tools, try actually using the model
with it.  Your customers will thank you if you actually
make your model work in the simulators they are going
to use!

Kim Helliwell

Tony Palmieri wrote:
>
> Hello,
>
> I have a question about an IBIS model. I have created a chip level model
> that is composed  numerous IBIS models. After I completed the model I
> ran the ibischk program and it passed.  I will be providing this model
> to our customers, but want to make sure that it is filly tested.
>
> Are there any other tests that I should run to insure that it is
> correct. I have reviewed the pin assignments, and that everything is
> properly referenced.
>
> Please reply to [email-masked]
>
> Thanks for your help,
>
> Tony Palmieri
>
> AMCC
> Applications, IC Test and Verification Manager
>
>   --------------------------------------------------------------------  
----
>   Applications Manager
>   AMCC
>   Applications Manager 
                                <[email-masked]>
>   AMCC
>   200 Brickstone Square ;Andover;Massachusetts;01810;  Fax: 978-623-0024
>                                                        Work: 978-623-0009 
x3063
>   Additional Information:
>   Last Name    Palmieri
>   First Name   Anthony
>   Version      2.1

--
Kim Helliwell
Senior CAE Engineer
Acuson Corporation
Phone: 650 694 5030  FAX: 650 943 7260

---

From: "D. C. Sessions" <[email-masked]>
Date: Fri, 22 Oct 1999 13:52:32 -0700

> falls between the min and max values at the corresponding points on the IV

Maybe I'm just a hard case, but why should this be a one-time exercise?
IBIS is perfectly suited to the job of specifying I/O characteristics to
manufacturing test.  They have to do drive-strength tests anyway to make
sure that there aren't any open output device legs, so instead of silly
stuff like "8.0 mA at 330 mV" or whatever just give them the IBIS model
and let them pick the best test points.

-- 
D. C. Sessions
[email-masked]