Subject: Spectre to create IBIS

From: Roy Gao <[email-masked]>
Date: Tue, 7 Sep 1999 12:23:23 -0700

Dear IBIS users,

When I try to use spectre to create IBIS models, I met a problem:

If there are current curves like Power-clamp or Pull-down, when I check model file, it always said like:
pull-down has Decreasing Current or so.

I observed the testbench created for that curve and found that in Spectre testbench, it will record all terminal currents of a component, so in output file there will be two set of currents values of voltage source, one is positive and one is negetive or vice versa. Unfortunately, IBIS creation will use the wrong set of current values and so the curve will be wrong. Since IBIS command file will create the test bench automatically, I can't control it.

I wonder if you have ever used spectre for IBIS model or have some good idea. 

Thank you for your time.

Roy

---

From: Mike LaBonte <[email-masked]>
Date: Tue, 07 Sep 1999 23:34:35 -0400

Roy,

It sounds like you are using s2ibis. I use s2ibis with Spectre and have not
seen this problem. However, I see that half of the simulations run by s2ibis 
save current values with a a statement like:

VOUTS2I pad 0 vsource type=dc dc=0
...
save VOUTS2I:currents

and this generates plot data like:

Plotname: DC Analysis `DCsweep': VOUTS2I:dc = (5.5 V -> 10.5 V)
Flags: real
No. Variables:        3
No. Points:       51
Variables:      0       dc      V
                1       VOUTS2I:n       A plot=0 grid=0
                2       VOUTS2I:p       A plot=0 grid=0
...

So conceivably the positive terminal of VOUTS2I might be reported first,
causing s2ibis to get reversed data. Is this happening in your case? And
I wonder why it might happen only sometimes?

Mike