Subject: RE: Paper on IBIS simulation algorithm

From: Raymond Chen <[email-masked]>
Date: Wed, 1 Sep 1999 15:30:38 -0700 (PDT)

Andy and Larry,
  We did some studies on IBIS simulation techniques
and algorithms back to 1996, and we did publish a
pretty detailed paper on that topic at 1996 ECTC
conference. You can download that file from our web
page at http://www.sigrity.com/support.htm, which is
the 11th paper titled as "Extraction of Transient
Behavioral Model of Digital I/O Buffers from IBIS".
That paper pointed out how to implement a simulation
algorithm to extract the transient behavior of ibis
model from the static I-V curve and V-T curve so you
can later simulate different load situations without
knowing the transistor level details. Hope that will
help.

Raymond Chen

--- "Ingraham, Andrew" <[email-masked]>
wrote:
> Larry Forsythe wrote:
> 
> >I'm confused about how IBIS is used in actual
> simulations. I haven't seen
> >any articles about this (please indicate if there
> are some).
> 
> And you might not find any that go into much detail.
>  The actual algorithm
> used by each simulator, especially as to how it
> handles the V-T data, might
> be a guarded secret.
> 
> > What I'm
> >confused about is how can a few static I-V curves
> and some V-T curves done
> >at specific loads be used to simulate other loads.
> The I-V curves involve
> >fully on transistors. The V-T curves involve
> partially turned-on
> transistors
> >driving a specific load.
> 
> Typically, an output buffer interacts with its load
> over a period of several
> nanoseconds while the signal rattles around and
> eventually settles.  Yet the
> time it spends actually changing -- the time for the
> drive to its output
> transistors to switch -- is much less, perhaps a few
> hundred picoseconds.
> It is a fair approximation to treat the output
> buffer as if it were static
> (defined by one I-V curve or the other) almost all
> of the time.  In between
> the two, it makes some sort of transition from one
> I-V curve to another, in
> a relatively short interval, the effects of which
> might be swamped by the
> interaction with the load.
> 
> > Is it valid to scale the I-V curves using the V-T
> >curves in order to derive the response to driving
> other loads?
> 
> Here's where you get into the proprietary details of
> each simulator's
> vendor.
> 
> If you're lucky, the load for the V-T curves is
> close to the trace
> characteristic impedance.
> 
> > Can the I-V
> >curves and V-T curves be used to determine the
> characteristics of a
> >partially turned on transistor driving a different
> load-I guess that is the
> >source of my confusion.
> 
> To varying degrees, apparently yes.
> 
> Regards,
> Andy Ingraham
> 
> 
> 

===
-------- Currently on leave for Intel projects --------
Office Phone: 253.371.4261  Mobile Phone: 408.718.3080
-------------------------------------------------------
Sigrity, Inc.                     Tel: 408.377.2180
2105 Hamilton Ave. Suite 310      Fax: 408.377.2565
Santa Clara, CA 95125             Web: www.sigrity.com
__________________________________________________
Do You Yahoo!?
Bid and sell for free at http://auctions.yahoo.com

---

From: "Richard A. Schumacher" <[email-masked]>
Date: Thu, 02 Sep 1999 9:25:49 CDT

> knowing the transistor level details. Hope that will

Which vendors have implemented this algorithm?
Who has tested such implementations with measurements
of real devices in real circuits?

regards,
Richard Schumacher
Hewlett Packard Company