Subject: LVDS HSPICE-to-IBIS

From: "Richard I. Dressman" <[email-masked]>
Date: Sat, 11 Dec 1999 08:13:04 -0600 (CST)

Hi.

My name is Richard Dressman. I work at Alcatel USA in Richardson
TX. I have been using Spice-to-IBIS conversion for several years.
I have had a devil of a time getting dV/dT info when attempting
to convert LVDS differential input-to-differential output models. The
converter will spit out Pull-up and Pull-down info fine, but the
dV/dT info will read like 0.00/0.00. HEEEELP!!!

Richard Dressman
Alcatel USA
Ph:972-996-7177
Fax:972-996-7362

---

From: Syed Huq <[email-masked]>
Date: Sat, 11 Dec 1999 17:47:40 -0800 (PST)

Richard,

You need to look at the intermediate files(eg, .spi, .out)to understand what
may have gone wrong. It seems that the transient analysis failed to switch the
device from low-to-high or high-to-low and the resultant dV/dT in the IBIS model
had zero entries.

You may see files with naming such as:

rut5.spi : Ramp Up Typical Pin#5 Spice Input File
rdt5.out : Ramp Down Typical Pin#5 Spice Output File
run5.spi : Ramp Up Min ...
rux5.spi : Ramp Up Max ...

An example of a rut5.spi file is(partial):
------------------------------------------
RLOADS2I PAD GND 50	<--- 50 Ohms to GND Rload
VCCS2I VDD 0 DC 3.3
VGNDS2I GND 0 DC 0
VENAS2I TS 0 DC 3.3
VINS2I A 0 PULSE(0 3.3 0 3e-11 3e-11 6e-09 1.212e-08)
.TEMP 27
.OPTIONS INGOLD=2
.TRAN 3e-11 3e-09
.PRINT TRAN V(PAD)

Check to see if your specific .spi makes sense. If it does not, then the
header file(.s2i)was not setup properly and you need to fix that.
Check the RLOADS2I, PULSE statements, any enable/disable pin setup, .TRAN
statement etc..

You could run Spice in a stand alone mode(not using s2ibis2)and perform
a transient analysis to make sure the device is switching properly. Then
it's a matter of tweaking the s2i file to generate a similiar .spi file
such that the translator(s2ibis2)can perform the correct transient anaylysis.

Most s2ibis2 users do not setup the header information(.s2i)correctly
and Spice fails to generate the proper file.

Hope this helps..
Regards,
Syed