Subject: ecl

From: [email-masked]
Date: Mon, 15 Mar 1999 16:41:20 -0800 (PST)

Hi IbiS Gurus

I am wondering if anybody can point me at a site(s) where I can
find ibis files with ECL models of all 4 ECL types.

If there is an expert in ECL-syntax could you please spend a minute
looking at this:

this is legal:
--------------
|Variable                  typ    min    max
[Voltage Range]            0.0    0.0    0.0
[Pulldown Reference]       0.0    0.0    0.0
[Power Clamp Reference]    0.0    0.0    0.0
[GND Clamp Reference]      -3.3   -3.0   -3.8

this is legal:
--------------
|Variable                   typ    min    max
[Voltage Range]             3.3    3.0    3.8
[Pulldown Reference]        3.3    3.0    3.8
[Power Clamp Reference]     3.3    3.0    3.8
[Gnd Clamp Reference]       0.0    0.0    0.0

howabout this?
-------------
|Variable                   typ    min    max
[Voltage Range]             3.3    3.0    3.8
[Pullup Reference]          3.3    3.0    3.8
[Power Clamp Reference]     3.3    3.0    3.8
[Gnd Clamp Reference]       0.0    0.0    0.0

I changed [Pulldown Reference] -> [Pullup Reference],
[Pulldown Reference] is omitted, so it defaults to zero.

ibischk3 does not complain, no warnings, no errors

what specs say:
|               When tabulating data for ECL models, the data in the
|               [Pulldown] table is measured with the output in the 'logic
|               low' state.  In other words, the data in the table represents
|               the V/I characteristics of the output when the output is at
|               the most negative of its two logic levels.  Likewise, the data
|               in the [Pullup] table is measured with the output in the
|               'logic one' state and represents the V/I characteristics when
|               the output is at the most positive logic level.  Note that in
|               BOTH of these cases, the data is referenced to the Vcc supply
|               voltage, using the equation:  Vtable = Vcc - Voutput.
|

It's ambiguous, because we have [Pullup Reference], [Pulldown Reference], [Voltage Range]
but not Vcc

If my example is legal, there is no use for [Pulldown Reference], and it should be
always discarded. If my example is illegal, then specs and parser should
be corrected.

Any comments?

Thanks a lot

Nik
[email-masked]

---

From: Stephen Peters <[email-masked]>
Date: Tue, 16 Mar 1999 09:36:00 -0800

Hello Nik:

   Very briefly, the examples below are 'legal' in that they are valid syntax.
This is why they pass the parser. The question is -- are they correct?
Here is how I would describe traditional (positive supply = 0v) 10K or
100K ECL logic.

ECL logic has no active pulldown transistor, and it's logic
levels are referenced to the most positive supply.  Also, remember
that if the [Pullup Reference] keyword is not explicitly used, [Voltage
Range] becomes the pullup reference.  Therefore, the simplest way
to set the references would be*:

|Variable                  typ    min    max
[Voltage Range]            0.0    0.0    0.0  | sets the references for both
                                              | logic levles
[Power Clamp Reference]    0.0    0.0    0.0  | included assuming the device
                                              | has an input clamp to VCC

  The important thing to note is that you do NOT need a pulldown reference. 
A [Pulldown Reference] is required only when the devices output has an active
pulldowns structure (i.e. can sink current), AND the reference for that 
pulldown
device is something other than 0v (traditional ground).  With an open-emitter
logic family like ECL, the pulldown simply does not apply.

(*Alternatively, you may want to use the [Voltage Range] keyword to document
the VEE supply conditions.  In this case use the [Pullup Reference] keyword
as follows:

|Variable                   typ    min    max
[Voltage Range]             -4.5  -4.0    -5.0  | 100k ECL
[Pullup Reference]          0.0    0.0    0.0   | overrides [Voltage Range]
[Power Clamp Reference]     0.0    0.0    0.0
)

Finally, for completeness, a 3.3v PECL device is shown.

|Variable                   typ    min    max
[Voltage Range]             3.3    3.0    3.6
[Power Clamp Reference]     0.0    0.0    0.0

Again, all that needs to be specified is the most positive logic rail, and
both the [Pullup] and [Pulldown] curves are referenced against it.

Hope this helps.

    Regards,
    Stephen Peers
    Intel Corp.