Subject: IBIS from HSPICE models using s2ibis2

From: Kim Helliwell <[email-masked]>
Date: Fri, 14 May 1999 16:08:05 -0700

I have 2 questions about the process of creating an
IBIS model from an HSPICE model using s2ibis2:

1. The HSPICE model I have uses different libraries to model
   effects of process variations.  As far as I can
   tell, s2ibis2 does not make it possible to switch
   libraries when sweeping through the "min, typ, max"
   sequence.  s2ibis2 appears to only vary supply 
   voltage and temperature to obtain the min, typ
   and max curves, implying that one must run s2ibis2
   3 times and pick the correct voltage/temp variations
   from each run to put together the full set with
   process variations included.  Do I have this right?

2. The HSPICE model I have also includes package parasitics.
   Would I have to remove these for the s2ibis2 run and
   add them in by hand?  Otherwise, I would assume that they
   would affect the rising and falling curves and would
   therefore implicitly be included.

Thanks to anyone who can help.

-- 
Kim Helliwell
Senior CAE Engineer
Acuson Corporation
Phone: 650 694 5030  FAX: 650 943 7260

---

From: Arthur Wong <[email-masked]>
Date: Fri, 14 May 1999 16:58:49 -0700

Kim,
1.  s2ibis2 can model process variations by defining
different transistor models for typ/min/max.

Use the keyword "[Model File]" in your s2ibis2 command file
to define the various models.

2.  Yes, remove the package parasitics from your Hspice models
so that your simulation results won't include these effects.
However, define the parasitics in the s2ibis2 command file
so that they will get transferred to the resulting *.ibs file.

Hope this helps.
Arthur Wong
IDT

> From [email-masked] Fri May 14 16:14:29 1999
> Sender: "Kim Helliwell" <[email-masked]>
> Date: Fri, 14 May 1999 16:08:05 -0700
> From: Kim Helliwell <[email-masked]>
> Organization: Acuson
> X-Mailer: Mozilla 4.04 [en] (X11; U; SunOS 5.5.1 sun4u)
> MIME-Version: 1.0
> To: [email-masked]
> Subject: IBIS from HSPICE models using s2ibis2
> Content-Type> : > text/plain> ; > charset=us-ascii> 
> Content-Transfer-Encoding: 7bit
> Content-Length: 1039
>