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Introductory Lab

Objective:
The following two sections are designed to provide an introduction on some of the BASICS regarding the XILINX implementation software.  The skills and techniques developed in this lab will be the building blocks for later labs in this course.

Process overview:

Lab:  One Design – Two Implementations:

1. Non Timing Driven.

2. Timing Driven.

The files for this lab are located in the \eng_labs\ximpl\intro_lab directory.

Procedure:

Implementation 1 – Non Timing Driven

1. Create a New Project in the Design Manager using “introlab.edn” as the source file.

Invoke the Xilinx Design Manager.  Select File -> New Project….  In the New Project dialog box select the Browse… button next to the Input Design: edit box.  In the Browse dialog box navigate to the file \eng_labs\ximpl\intro_lab\introlab.edn.  Press the OK button and the New Project is automatically created.

2. Next we want to begin the implementation of the design into a part.

There are two ways to begin implementation.  The first method is the Automatic implementation and is usually preferred.  The second method is to work within the Interactive Flow Engine, and will be explained later. Each method has its own advantages that will be demonstrated in later labs.

Method 1 – Automatic implementation

Select Design -> Implement… from the main menu or select the leftmost toolbar icon.  The Implement dialog box appears. 

To modify the option settings and/or selected targets press the Options… button.  The Options dialog box appears.  At the bottom of the Options dialog box is the Optional Targets group.   Press the Help button and read through the information regarding this entire dialog box. 

 Options for the individual implementation programs (i.e. NGDBUILD, MAP, PAR, TRCE) are available by pressing the Edit Template… button next to the Implementation: list box.  

Options for BITGEN can be set by pressing the Edit Template… button next to the Configuration: list box. 

Options for SIMULATION can be set by pressing the Edit Template…button next to the Simulation: list box.  Notice that new in 1.5 is a set of  predefined templates to help customers set the appropriate options to interface with their preferred simulator.

Press the Cancel button as necessary to return to the Implement dialog box.

3. In the Implement dialog box confirm the XC4002XL-09-PC84 is displayed in the Part: text box.  To demonstrate the process of changing to a different part press the Select… button next to the Part: text box.  The Part Selector dialog box appears.  The four drop down boxes; Family:, Device:, Package: and Speed Grade: allow the user to target the different Xilinx families.

4. From the Part Selector dialog box press the Cancel button to return to the Implement dialog box.  Press the Run button.  By pressing the Run button the Flow Engine appears and automatically begins implementation.  Allow the Flow Engine to process the design through the Configure step.  When the Flow Engine has completed running it closes and the Implement Status dialog box appears.  

5. Press the Reports button to open the Report Browser.  The Report Browser can be opened from the Design Manager by selecting Utilities -> Report Browser or by pressing the seventh toolbar button from the left.  There should be seven reports shown in the Report Browser.  Notice the yellow highlight in the upper left corner of each report icon.  The yellow highlight indicates the report has not been opened previously. 

6. Three of the reports listed, Place & Route Report, Pad Report and Asynchronous Delay Report were created in the Place and Route step of the Flow Engine.

7. Open each report and BRIEFLY examine the information contained inside.  Close all reports and close the Report Browser.  If the Implement Status dialog box is still displayed press the OK button.

Design Manager Versions and Revisions

Before proceeding to the next portion of this lab an understanding of the Design Manager’s directory structure including Versions and Revisions is necessary.  When we created a new project in step 1 of this lab we first had to point to a source netlist file as the Input Design.  The xproj directory was then automatically created in the same directory as the source netlist file.

You then implemented the design, creating ver1 and rev1.  If you had changed the implementation options and again implemented the design you would have seen rev2 under ver1 be produced.  A new version is created only when the design netlist changes or the user manually creates a new version.  The Design Manager detects if the design netlist has changed by checking the date stamp on the netlist.  If the date stamp is different than the original design netlist the Design Manager will automatically create a new version.

The Design Manager (DM) also tries to automatically detect and set the .ucf file, or user constraints file.  The DM looks for the .ucf in the same directory as the source netlist file.  The DM also expects the .ucf file to have the same name as the source netlist file.  If these two conditions are met it will automatically set the .ucf in the DM.  Note the .ucf can have a different name and location but it will need to be set manually.  Setting the .ucf manually will be shown later in this lab.

Summary:

C:\directory


<design name>.edn  ( or .edf, .xtf, .xnf, .sxnf, .pld)


<design name>.ucf


\xproj



\ver1




\rev1
-  Some implementation options




\rev2
-  Different implementation options



\ver2
-  Design netlist has changed




\rev1
-  Design implementation

Implementation – 2 Timing Driven

8. Open Windows Explorer.  Go to the \eng_labs\ximpl\intro_lab directory.  Execute the overwrite.bat file by double clicking the left mouse button on it.  This batch file copies a .ucf file containing a timespec over the introlab.ucf file and copies a newer source netlist over the introlab.edn file.

For this run we will bring up the Interactive Flow Engine.

9. In the Design Manager select Design->New Version….  In the New Version dialog box enter ver2 in the Name: edit box.  Press the OK button.   Select Design -> New Revision….  In the New Revision dialog box enter rev1in the Name: edit box.  Press the OK button.  With the newly created revision highlighted select either the Tools -> Flow Engine menu item or use the top tool box button on the right hand side of the Design Manager screen.  

10. In the Flow Engine, bring up the Options dialog box by selecting Setup -> Options… or by pressing the leftmost tool bar button.  In the Options dialog box examine the User Constraints: edit box.  This should point to \eng_labs\ximpl\intro_lab\introlab.ucf (User Constraints File).  If a different .ucf is required for implementation it must be changed here.

11. You will now change the Place & Route Effort Level to Best Results.  From the Options dialog box press the Edit Template… button next to the Implementation: edit box.  When the XC4000 Implementation Options: Default dialog box appears select the Place and Route tab.  At the top of the Place and Route tab is the Place & Route Effort Level slide bar.  Slide the setting all the way to the right stop.

Start the Flow Engine by selecting Flow -> Run or by pressing the leftmost button at the bottom of the Flow Engine screen.  

12. In the Post Layout Timing Report.  What is the Maximum Frequency for CLOCK? 126 MHz.

13. Since we have met our timing for the design we now want to do timing simulation.

In the Flow Engine press the Step Back button until the word Completed disappears from below the Timing icon in the Flow Engine.  Select Setup -> Options….  In the Optional Targets sections of the Options dialog box enable the Produce Timing Simulation Data option.  Press the OK button.  In the Flow Engine press the Run button.  When Completed again appears below the Timing icon in the Flow Engine the timing simulation data has been produced.

Discussion:

You have learned/reviewed how to:

1. How to use the XILINX Design Manager and Flow Engine.

2. How to run the implementation tools directly from the Design Manager or by first displaying the Flow Engine. 

3. How to do timing driven and non-timing driven design implementation.

4. Understand what versions and revisions represent.

5. Change the type of timing report created.

6. Create timing simulation data.

Constraint Editor Lab

This lab is designed to help the student understand several new features and flows brought about with the new M1 Constraints Editor.  The lab will present how to constrain designs with the Constraints Editor (CE) and how it fits in the flow of the Design Manager/Flow Engine (DM/FE).  The schematic and constraints were chosen to present different constraining situations.

· Use the DM default settings with the exceptions mentioned in the lab.

CE - LAB1: Constraining a new Design and running through the DM flow

Objective:
In this lab you will take a new design through the flow of constraining with the CE.  You will also learn how to preserve versions of the design files by using the DM revision list feature and use the new Lock Pins options from a previous revision.  

Procedure:

1. Start the Xilinx DM, create a new project and browse for “ce798fae.edn” in the eng_labs\ximpl\conedit directory.

Specify to the DM that we would like to keep a copy of the UCF in the revision directory to accompany the NGD that it is associated with.

2. Select the top design file (probably already selected).  Use the right mouse button and select Properties.

3. Click on the Revision List… button.

4. Browse for the design UCF file in the “ce798fae” directory, select and click Open.

5. Select the Set button then press OK to close the two dialog windows.

Note: this will save a copy of the UCF used for each revision in the revision directory to correlate with the NGD in the revision directory.

6. Implement the design with the following instructions:

7. Select Part type XC4002XL-09-PC84 

8. Select the Options… button on the Implement dialog and uncheck Produce Configuration Data.

9. Press OK to close the window.

10. Press the Run button on the Implement dialog to start the FE.  When the FE is invoked, set the STOP AFTER point to the TRANSLATE step or just Abort after the TRANSLATE step is complete.

Note: To set the STOP AFTER point, when the Flow Engine opens, click on the “STOP SIGN” in the tool bar or select the Stop After menu item from the Setup menu.

Note: To Abort the Flow Engine run, click on the black square button at the bottom of the FE window or use the Flow menu Abort option and close the FE window.

11. When the translation is finished, select the Constraints Editor from the DM Utilities menu.

Note: The design clocks are automatically filled into the Global tab clock table.

Let's put some global constraints on the design and see if we meet timing.  Assume for this lab design that the two clocks have a 20 ns period, but are out of phase by 5 ns (CLKB rising edge is 5 ns after CLKA rising edge).

12. Double click in the “CLKA_IN” Period field to bring up the clock period dialog.  Enter 20 ns for the period,  HIGH 50% for the duty cycle, and press OK.  This sets the period for the clock.

Question(s):

What constraint(s) were created in the Editable Constraints window?

______________________________________________________________________________________

______________________________________________________________________________________

NET “CLKA_IN” TNM_NET = “CLKA_IN” ;

TIMESPEC “TS_CLKA_IN” = PERIOD “CLKA_IN” 20.000000 ns HIGH 50.000000%;

13. Double click in the “CLKB_IN” Period field and define it as a “1x” function of “TS_CLKA_IN” (select Relative to other PERIOD Time Spec radio button) and close.

14. Specify 10 ns Pad to Setup and 20 ns Clock to Pad for BOTH of the clocks.

15. Enter a Pad to Pad constraint of 20 ns.

16. Save the UCF and exit.

17. Implement a new revision in the DM and run the FE through PAR and Timing.  Remove the Stop After point if you previously set it.

Let’s keep the pinout from this PAR run to lock down all further placements.

18. Lock the pins down by making sure that the rev2 (Timed, OK) revision is selected and pick the Lock Pins… menu item under Design in the DM menu.

Note: This will annotate the UCF with all of the pin placements from that revision.  These will show up in the Ports tab of the CE when we open it again.  You may view the Lock Pins Report if you like.

19. Open the Place & Route Report from the report browser and look at the end of the report at the table of timing constraints.   Look for constraints that have a “*” in front of them.  These constraints have paths that fail.  For further details on these paths look at the Post Layout Timing Report and note some of the failed paths.  There will be constraints with timing errors detected in the constraint headers.

20. Open the CE with the rev2 icon selected.

Let’s look at the Ports tab first.  You will notice that all of the pads have pin location specifications.  Let’s go ahead and speed up the paths that pass through the output pad “OPAD_AND4_Y”.  This “SLOW” output pad is causing some paths to fail.

21. Select the I/O Configuration Options checkbox at the bottom of the Ports tab, then go to the “OPAD_AND4_Y” row and FAST/SLOW column and right click the mouse on that cell, set to FAST.

Question(s):

What constraint was created in the Editable Constraints window?

______________________________________________________________________________________

NET “OPAD_AND4_Y” FAST ;

Now let’s define the phase difference between the two clocks.  We are only concerned about the paths from CLKB to CLKA, so we only need constrain those paths.  

22. Goto the Advanced tab and click on the Specify… Slow/Fast Path Exceptions (FROM TO) button.

23. Specify the Time Spec Name as TS_CLKB2CLKA.

24. Select CLKB_IN from the From Group: pulldown and CLKA_IN from the To Group: pulldown and set time to 15 ns.

25. Close the dialog using the OK button.

Question(s):

What constraint was created in the Editable Constraints window?

______________________________________________________________________________________

TIMESPEC "TS_CLKB2CLKA" = FROM "CLKB_IN" TO "CLKA_IN" 15.000000 ns;

Let’s assume that the paths through the CLR signal are asynchronous and not critical, so we will remove the paths from the design. This will remove some asynchronous paths that PAR doesn’t need to spend time on.

26. Select the Specify… False Paths by Nets (NET TIG) button on the Advanced tab.

Note: to ignore this net for all paths, by default all timespecs are ignored so we will not move any of the timespecs into the Ignored TIMESPECs window.

27. Pull down the net selection and select the “CLR” signal and OK the dialog.

Question(s):

What constraint was created in the Editable Constraints window?

______________________________________________________________________________________

NET “CLR” TIG ;

Let’s assume that the paths from “SPO” (a Ram on CLKB) to some flops (FFS on CLKA) are multi-cycle paths.  There is a clock enable signal, “SPO_CE”, that controls the FFS with those paths.

28. Press the Create… Groups by Nets (TNM) button in the Advanced tab.

29. Specify a Time Name of “SPO_MC”.

30. Select “Clock Enable Nets” in the Design Element Type pulldown.

31. Select the “SPO_CE” signal from the list and move it to the Time Name Targets side using the “>” button.  

32. Close the dialog using OK.

33. Press the Specify… Multi-cycle Paths (FROM TO) button on the Advanced tab.

34. Specify a Time Spec Name of “TS_SPO_MC”.

35. Select All RAMS in the FROM Group pulldown and “SPO_MC” in the TO Group pulldown.

Note: the value Type is already defaulted to Relative to other path specification.

36. Set the Reference TIMESPEC to “TS_CLKA_IN” and select the Multiply by radio button.

37. Set the Factor to “2” and OK the dialog.

Question(s):

What constraint(s) were created in the Editable Constraints window?

______________________________________________________________________________________

______________________________________________________________________________________

NET "SPO_CE" TNM_NET = "SPO_MC";
TIMESPEC "TS_SPO_MC" = FROM "RAMS" TO "SPO_MC" "TS_CLKA_IN" * 2.000000;
Now let us specify the Pad to Setup requirement for the negative clocked flop to be half of the positive Pad to Setup requirement.

38. Select the Create… Groups by Elements (TIMEGRP) button on the Advanced tab, call the group “DATA_PAD”, create a Design Element Type group of Pads, move the pad “IPAD_DATA” to the Time Group Members window.  OK the dialog.

39. Select the Create… Groups by Elements (TIMEGRP) button on the Advanced tab, call the group “FFS_1”, create a Design Element Type group of FFs, move the FFS “FD1_1_Q” to the Time Group Members window. OK the dialog.

40. Select the Specify… Pad to Setup Requirement(s) (OFFSET IN BEFORE) button on the Advanced tab.  Select “DATA_PAD” in the PAD Group pulldown and the “FFS_1” in the Register Timegroup.

41. Set the Time Requirement to 8 ns and OK the dialog.

Question(s):

What constraint(s) were created in the Editable Constraints window?

______________________________________________________________________________________

______________________________________________________________________________________

______________________________________________________________________________________

TIMEGRP "DATA_PAD" = PADS( "IPAD_DATA" );

TIMEGRP "FFS_1" = FFS( "FD1_1_Q" );

TIMEGRP "DATA_PAD" OFFSET = IN 8.000000 ns BEFORE "CLKA_IN" TIMEGRP  "FFS_1";

42. If time permits, re-IMPLEMENT, verify that timing errors have been reduced, if they have not, try running Place & Route Effort Level “Best Results”.

Map Lab

The purpose of this lab is to introduce you to the Map options available in the Design Manager / Flow Engine and familiarize you with the Map report.

Introduction:

In a normal synthesis flow, adjusting the Map options will usually not be necessary.  Synthesis vendors perform much of the mapping and optimization before creating the design netlist.

The Design Manager / Flow Engine options that control Map are located in the Implementation Template on the “Optimize and Map” tab.   The function of each option listed will be explained. 

The Map report will also be examined to show you what information can be found inside.

Lab:

1.  Bring up the Design Manager.  Select File->Open Project….  Press the Browse… button and go to c:\eng_lab\ximpl\map_lab\xproj\, select the map_lab.xpj file.  Add the project to the project list then press the Open button.  

2.  To specify the location of the input design, browse up one level to the map_lab directory and select map_lab.edn file.

3.  Select Design->Implement….  In the Implement dialog box verify that the Part: edit box has a XC4002XL-09-PC84 selected.  If not, use the Select… button then select the right part.  

4.  Press the Options… button.  This brings up the Options dialog box.  In the Program Option Templates group, press the Edit Template… button next to the Implementation: drop down box.  This brings up the XC4000 Implementation Options: Default dialog box with the Optimize and Map tab in view.

The Map options are divided into two groups: Logic Optimization Options and Map Options.  The only generally recommended map option is Pack I/O Registers/Latches into IOBs..

Pack I/O Registers/Latches into IOBs for: Off is default.

The “Pack I/O Registers/Latches into IOBs for:” option is the most likely Map setting a synthesis user would change.

This option controls the packing of flip-flops or latches within an I/O cell. By default the mapper packs flip-flops or latches within an I/O cell only if such packing is specified by your design entry method. This option allows you to control packing after the design entry phase.

- Inputs Only
“Inputs Only” will pack flip-flops or latches into input I/O cells.

- Outputs Only
“Outputs Only” will pack flip-flops or latches into output I/O cells.

- Inputs and Outputs
“Inputs and Outputs” will pack flip-flops or latches into both input and output I/O cells.

- Off

“Off”, the default, packs flip-flops or latches as specified by your design entry method.

Note: For synthesis based designs this option is useful only if the synthesis tool did not place registers into the IOBs.

Questions: 

1. The default value for  “Pack I/O Registers/Latches into IOBs for:” is ___________________.

2. The three other values for  “Pack I/O Registers/Latches into IOBs for:” are ___________________

_____________________________________________________________________________.

Additional Map options:

Trim Unconnected Logic.  The default is on.

This option trims unconnected components and nets from the design before mapping occurs. Deselect this option to map unconnected components and nets. Deselecting this option is useful for estimating the logic resources required for a design and for obtaining timing information on partially finished designs. When implementing an unfinished design, deselect this option to prevent partial logic from being trimmed.

Replicate Logic to Allow Logic Level Reduction.  The default is on.

Use this option to replicate logic that drives multiple loads and map it as separate components that drive individual loads.  Registers will not be replicated.  This option is useful for creating a mapping strategy that may more readily meet your timing constraints. It reduces the number of logic levels, through which a signal must pass, thereby eliminating path delays.

It is typically not useful to deselect this option.

Generate 5-Input Functions.  The default is off.

Select this option to map each five-input logic function to a single CLB. This option can sometimes reduce the number of cell-to-cell delays at the expense of increased CLB count

For synthesis based designs this must be done by the synthesis tools.

CLB Packing Strategy: Fit Device is default

By default the mapper partitions logic to maximize signal sharing within CLBs and to minimize routing congestion. The CLB Packing Strategy option optimizes density by relaxing signal sharing requirements between logic elements in a CLB, allowing additional elements to be combined in a CLB. The default is Fit Device.

- Fit Device
Selecting “Fit Device” can prevent over mapping by allowing the packing of logic elements that do not share common signals into CLBs until the design fits into the device. The mapper continues packing until the design fits or no further packing is possible and the design over maps. 

- Off

Selecting  “Off” will disable the CLB Packing Strategy option. Disabling this option causes only related logic (logic with common inputs) to be packed together. This is useful for increasing speed and improving routability in high-speed designs. However, the design may overflow the selected part due to the increase in CLBs used.  Using “Off” may require you to use a larger part to fit your design.

Pack CLB Registers for: Structure is default

This option controls register ordering. When you map a design containing registers, the mapper can optimize the way the registers are grouped into CLBs. This optimized mapping is called register ordering. For more information on register ordering, see the Development System Reference Guide. 

- Minimum Area
Selecting “Minimum Area” will disable register ordering for a denser design. Register bit names will be ignored when registers are mapped in favor of packing based on common LUT input signals to the LUTs driving the registers.

- Structure

Selecting  “Structure” will enable register ordering. The mapper will look at the register bit names for similarities and try to packing register bits into CLBs in an ordered manner.

Use Generic Clock Buffers (BUFGs) in place of BUFGPs and BUFGSs.  The default is off

Selecting this option will replace primary and secondary clock buffers with generic clock buffers before mapping occurs. This option is useful when working with design entry tools that generate only BUFGPs or BUFGSs.

The Map report

Open the Map report (map.mrp) for rev1 using the Report Browser.  In the Design Manager select Utilities->Report Browser.  When the Report Browser appears, open the “Map Report” by double clicking the left mouse button on the “Map Report” icon.  

Notice the information about the map command line and part used is listed under Design Information.  Listed under Design Summary is information detailing device resource utilization.  

Under Table of Contents is a listing of the twelve sections that make up the Map report.  Briefly review each section of the Map report and note where different information is placed.  The key sections are typically the Design Summary at the top of the report, the Errors and Warnings sections 1 & 2, the Removed Logic Summary section 4 and the IOB Properties section 10

Scroll down to Section 7, the “Expanded Logic” section.  This section and the two sections following are blank except of the message explaining how to they can be enabled.  These three sections of the Map report can be very long, are mostly used for debugging purposes and therefore, by default, are not reported.

In section 10 any registers or latches that have been placed into IOBs are reported in the “IOB Properties” section.  This is the best place to verify which registers/latches have been placed into IOBs, since the timing tools do not identify them.

Question:

3. This design uses how many IOB Flip-Flops? __________________________.

Place and Route Lab Introduction

Introduction

This section provides an overview of how the Multi-Pass Place and Route tools and other router Options can deliver the best design performance.

· The Multi-Pass Place and Route (MPPR) command is used to run multiple place and route iterations on a selected version of a design.  The number of place and route iterations that the software should run and the number of iterations to save can be specified (see Figure 2).  Each iteration that is saved is added as an implementation revision in the M1 Design Manager. Since proper placement is very important to getting the best performance and utilization, it is best to run MPPR through multiple iterations.

· The Place and Route Options section of the Implementation Options dialog box 
(see Figure 1) is the push-button method of improving the Flow Engine’s place 
and route.

· The Re-entrant Route capability is used to further route designs that have trouble meeting timing constraints, or for designs that do not completely place and route. It is recommended that customers utilize the Re-entrant Route feature only if their design has not placed and routed sufficiently to meet their timing specifications.  It is not usually necessary to use this feature to get a project to place and route completely.

The advanced tools described above are designed to help customers get peak utilization and peak performance out of their FPGAs.

About the Place and Route Push-Button Tab

The following options are available on the Place and Route Tab of the Implementation Options dialog box (refer to Figure 1).

· Place & Route Effort Level

Use this option to specify the relative effort levels used to place and route a design.  Use the slider bar to select an effort level setting of 1, 2, 3, 4, or 5.  Higher effort provides better results at the expense of longer run times.  The default setting is 2.

· Run_Routing Passes

Use this option to set the maximum number of routing passes that the router runs in a design.  The router attempts to completely route a placement with each pass.  Users can set the number of passes to a value from 1 to 1000 or to Auto.  Auto runs the router until it routes to 100% completion, which includes meeting the specified timing constraints, or it intelligently determines it cannot complete the routing.  A higher number of iterations provide better routing results at the expense of longer run times.  The default is Auto.

· Run_Delay Based Clean-up Passes

Use this option to further improve routing of an already routed design.  The router makes routing decisions based on computed delay times between sources and loads on the routed nets, and reroutes to minimize the delays. Set the number of delay-based cleanup passes to run by choosing a number from 1 to 5.  This option is especially useful to improve the timing results of those designs that have been run without timing constraints. Xilinx recommends running one delay-based cleanup pass, though running two may give slightly better results.  The default is 0.

· Use Timing Constraints During Place and Route

Select this option if there are user-specified timing constraints in the source design.  The router uses timing constraints in the design file to place and route the design within the specified constraints.  By default, this option is on.
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Figure 1.  The Place and Route Options in the Implementation Options dialog box.

About Multi-Pass Place and Route

The following options are available in the MPPAR dialog box (see Figure 2).

· Initial Placement Seed (Cost Table)

Specify a starting point (1 to100) with which to begin the place and route attempts.  This number corresponds to a cost table index and different starting strategies result in different place and routes.

· Place & Route Iterations to Attempt

Specify the number of place and route iterations to attempt.  It is important to note that each iteration will generate the identical results if the design files, constraints, implementation options, and placement seed are all the same. Having the original netlist, constraints file, implementation options and  placement seed are essential if one needs to reproduce any of the iterations.  MPPAR will use a different placement seed for each iteration.

·  Save N Best Passes

Specify the number of place and route iterations to save.  This option compares every result to every other result and saves the best iteration attempts.  A score assigned to each revision determines those design iterations with the best results.  This score takes into account such factors as the number of unrouted nets, the delays on nets and the conformance to the timing constraints.  The lower the score, the better the implementation.

[image: image6.png][XC4000 Implementation Options: Default

Optinizet Map Place & Aoue | Tiing | Interfce |

Place & Route Effort Level

Eostest | Bt
Rurtime { Resuls

P s
Fun [ 2] Roueg s

Run [ =] Delay Bssed Clesnup Passes

¥ Lise Timing Conslrairts During Place and Route.

[ Cancel Default Help





Figure 2.  The MPPR dialog box.

About the MPPR Report

After implementation, the Flow Engine creates a Multi-Pass Place and Route (MPPR) report that can be opened through the report browser.  To enter the Report Browser, click on Utilities>Report Browser.  The MPPR report contains a table with the following information:

· Level/Cost

Level corresponds to the revision number for this project.  Cost refers to the placement seed or “cost table” chosen for this revision.

· Design Score

The design score is a weighted value given to each revision created by the MPPAR function.  The lower the score the better the placement, and the closer the Place and Route tools came to meeting the timing specifications.  The Design Score is only relative to the revisions generated by the MPPAR tool in a single iteration.  In other words, you do not compare the design scores to a different multi-pass implementation.

· Timing Score

This score is an indicator of how close the MPPAR function came to meeting all the timing constraints with each revision.  The lower the number, the better the tool came to meeting the timing specifications.  If the timing score is zero, all timing specifications were met.

· Number Unrouted

This is the number of unrouted nets for each revision.

· Run Time

The total run time and the run time for each revision can be estimated by reviewing these statistics.

About Re-entrant Routing

Re-entrant routing is selectable from the Setup/FPGA Re-entrant Route command in the Flow Engine.  The following options are available in the FPGA Re-entrant Routing dialog box (refer to 
figure 3 below).  The Re-entrant Routing option is recommended for designs that have trouble meeting timing constraints, or designs that do not completely place and route.
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Figure 3.  Advanced Options dialog box.
· Allow Re-entrant Routing

Use this option to further route an already routed design.  This activates the Re-entrant Route Options section, and allows modifications to its contents.

· Cost-based Cleanup Passes

Cost-based cleanup makes routing decisions by minimizing the relative “cost” associated with the types of routing resources used to route a given net.  This can have the effect of cleaning up congested routing areas and sometimes can improve the timing of individual nets in the design. Set the number of cost-based cleanup passes desired by choosing a number from 1 to 5.  Xilinx recommends running only one cost-based cleanup on each pass, since running extra cost-based cleanup passes usually provides only minor improvement.
· Delay-based Cleanup Passes

Delay-based cleanup makes routing decisions based on computed delay times between sources and loads on the routed nets, and re-routes to minimize the delays.  Set the number of delay-based cleanup passes desired by choosing a number from 1 to 5.  Xilinx recommends running one or two delay-based cleanups on each pass.

· Re-entrant Routing Passes

Xilinx recommends running Re-entrant routing passes on designs that have been routed to completion and not met timing constraints, or on designs that have not completely routed.  This number specifies how many normal (i.e. “non-cleanup” router iterations to attempt.  During this operation, the router will work to route unrouted nets, as well as continue to re-route signals towards the goal of meeting the timing constraints.

· Use Timespecs During Re-entrant Route

The Flow Engine uses timing constraints in the design file to route the design within the specified constraints.  If the design is using timing constraints, assert this option during re-entrant routing.  Usually, this option is only turned off if the design cannot route with timing constraints.

Summary

Multi-Pass Place and Route and the other router options described above offer an effective way to improve the utilization and performance of a design.  For example, the MPPR capability enables one to quickly arrive at a better placement. Better placement can deliver huge pay off in routability. The tools can then route a well-placed design much more easily. In general, time invested in improving placement yields better pay off than time invested in improving routing.
Design Improvement - PAR

The PAR lab exercises will consist of four sections:

1. Improving Timing by increasing the PAR effort level

2. Improving Timing through Multi-Pass Place and Route (MPPR)

3. How and When to use Re-entrant routing

4. Cleanup routing (optional)

Section 4 is an optional assignment for this training session.

Section 1: Improving Timing by increasing the Effort Level for PAR
Objective: 

Learn how to improve design results with two strategies for PAR: increasing the effort level, and by running multiple cost tables (MPPR).  Learn to what degree increasing the effort level for PAR above its default of 2 improves timing for a design, and to what degree running multiple cost tables can improve timing of a design. 

When PAR is run with default settings, it runs at effort level 2, and generates a solution based on a starting placement determined by cost table number 1.  If more performance is needed, the effort level for PAR may be increased, or different placement implementations may be tried.  PAR provides a simple means to automatically generate many different placements – Multi Pass Place and Route (MPPR). 

Prior to beginning this lab, you should have installed the lab materials onto your computer from the CD-ROM.  You may install the lab directories into any directory that is convenient.  

In this section, you will inspect the reports generated from a few different PAR runs, subsequent sections will lead you through actually running the implementation tools.

· Invoke the Design  Manager: 
Start -> Programs -> Xilinx Foundation Series -> Accessories -> Design Manager.
· Open a project using the pulldown menu: File -> Open Project
· Push the Browse button, a browser window will appear.

· Browse to C: -> {your directory path} -> ximpl -> bdes2 -> xproj -> bdes.xpj.  Push the Open button in the Browse window to open bdes.xpj.  Push the Yes button when asked if you want to add this project to the project list.  Push the Open button in the Open Project window to open the project.   The Design Manager may complain about not being able to find the source file (bdes.xtf) for this project.  When asked to specify this source file, use the browser to specify c:\{your directory path}\ximpl\bdes2\bdes.xtf.  (HINT: change the files of type (.xnf)  to be read).  

· Expand the design hierarchy view for ver1_proto.
The Design Manager for this project displays many revisions.  Be sure to select the correct revisions for the different parts of this lab.

· Using the Report Browser, review the Post Layout Timing Reports for the following revisions:

· rev2 (Timed, OK) Effort Level 2
· rev3 (Timed, OK) Effort Level 1  

· rev4 (Timed, OK) Effort Level 4.   

The Report Browser can be activated by selecting the desired revision, and using the Utilities -> Report Browser pulldown menu item.  Using the data found in the report files, fill in the performance numbers in the following table:

Revision
Clock Frequency

rev2 Effort Level 2 (def)
            38.776 MHz

rev3 Effort Level 1
            33.652 MHz

rev4 Effort Level 4
            43.457 MHz

Which effort level produces the highest clock frequency? (4)

Discussion
The default effort level for PAR is level two.  This is because it typically provides the best trade-off between runtime and clock performance across a range of designs.  Each successively higher level above two will typically provide performance improvements, but at progressively lower increments, and progressively larger runtimes.  If you are looking for a larger performance improvement than can be achieved by effort level alone, the best strategy is to use multiple placements or cost tables, through Multi-Pass Place and Route (MPPR).

Section 2 - Improving Timing through Multi-Pass Place and Route (MPPR)

Process overview:

Before we explore the effects MPPR can have on circuit performance, we will have you learn how to setup a MPPR run, and learn a few techniques for how to manage a MPPR job that has been stopped before all cost-tables have been run.

In the second phase of this section, you will inspect various report files from a more realistic MPPR run to gain an understanding of how the use of MPPR can affect the realized circuit performance.

2A: Starting and Stopping MPPR jobs within the DM/FE

· In the Design Manager, open a project: File -> Open Project
· Push the Browse button, a browser window will appear.

· Browse to C: -> {your design directory} -> ximpl -> quick_mppr -> xproj -> dummy.xpj.  Push the Open button in the Browse window to open dummy.xpj.  Push the Yes button when asked if you want to add this project to the project list.  Push the Open button in the Open Project window to open the project.   The Design Manager may complain about not being able to find the source file (dummy.edn) for this project.  When asked to specify this source file, use the browser to specify:

c:\{your design directory }\ximpl\quick_mppr\dummy.edn
· Select ver1 from the design hierarchy.



· Use the pull-down menu: Design -> FPGA Multi-Pass Place & Route
· Set the FPGA Part to be a XC4005XL-1-PC84

· Set Initial Placement Seed (Cost Table) to 1

· Set Place and Route Passes to Execute to 10

· Set Save N Best Passes to 5

· Press “Run” to invoke the DM/FE to run this job

The DM/FE will begin processing this design. After NGDBUILD and MAP, PAR will begin executing.  For each cost table that is run a message will be printed that looks like “Placer cost table entry (-t): 1” 

If you were to allow this to run to completion, PAR would run 10 cost tables, and saved the best 5 results. 

· Allow PAR to complete placing and routing for three or four cost-tables, then push the “Abort” button to terminate the run.  Do not allow the entire MPPR run to complete automatically.  After aborting the run, Push OK in the FPGA Multi-Pass Place & Route Status Window

The Design Manager will show individual revisions for each cost table that was run.  However, because we terminated the MPPR job before the 10th and final iteration, the Implementation State for each revision is set to “Mapped”.  When the Implementation State is set to “Mapped” users are unable to review the log files for those cost-tables that were in fact completed.    We will address this problem in a future release of the software, but for now we will show you how to work around this situation.

· In the expanded hierarchy for ver1, select one of the newly created revisions and invoke the Flow Engine (i.e. Tools -> Flow Engine) for that revision.  Note how the Implementation State shown in the Flow Engine is still “Mapped” .

· From the Utilities -> Report Browser, note that only the Translation and Map reports are available and no PAR report files are shown (even though PAR did in fact complete for this cost-table attempt).

· From the Setup -> Advanced pull-down menu, set the implementation state to “Routed”, and click on “OK”

· You should now see additional reports detailing the PAR runs in the report browser.  Of particular interest is the MPPR Report File, which shows summary information (to be discussed in greater detail below) for each cost-table that was completed, as well as the individual Place & Route Report File which details the PAR run for the particular revision selected.

2B: Reviewing Actual MPPR Results

NOTE: In this lab, you’ll be looking at the report files from the revisions of the “bdes2” design generated during a previously run MPPR job.

· In the Design Manager window, select the pulldown menu: File -> Open Project
· Select the path that points to the project file : bdes.xpj  Since you used this project in Section 1, this should be near the top of the “Most Recently Used (MRU)” list in the Open Project dialog box.
· Select  version ver1_proto, revision p4_rev_4_4_1
(p4 indicates this is the fourth MPPR run within this project.  The first digit in rev_#_#_# indicates the placer effort, the second indicates the router effort, and the last indicates the cost table.)

· Using the report browser, inspect the contents of the MPPR Report

Approximately how long did each placement take?

____Min (18-20)
Which design had the lowest design score?


_______ (4_4_3)
Which design had the lowest timing score?


_______ (4_4_3)
How is the MPPR table sorted?



_______ (design score)
(Note:  The MPPR Report file is the same for each revision generated during a given MPPR run).

The timing score represents the total amount of negative slack for all path endpoints relative to the path constraints.  In contrast, the design score is a function of this timing score, plus other factors such as average net delays, worst-case net delays, and the number of timing errors in a design.  While it is generally true that the designs with the lower design scores will also tend to have the lower timing scores, it is not always the case that the lowest design score implies the lowest timing score.  For detailed information on the design score and how it is calculated, refer to the online documentation: Development System Reference Guide (CH. 10, output from PAR->Scoring the Routed Design).

· Using the report browser, review the Post Layout Timing Reports and MPPR Report for each of the revisions generated in the effort level 4 MPPR run (p4_rev_4_4_*).  From those reports, fill in the following table:

Revision
Clock Frequency
Runtime

p4_rev_4_4_1



p4_rev_4_4_2



p4_rev_4_4_3



p4_rev_4_4_4



p4_rev_4_4_5




Average: 
Average: 

Exploring the effect of different placer effort levels

In the ver1 design tree, there are results from MPPR runs done at placer effort levels 1, 3 and 4.  You’ve already looked at results for level 4, now let’s explore how changing the effort levels affect runtime and circuit performance.

· Inspect the reports for the MPPR run done at placer effort level 1 (p3_rev_1_1_*)

Fill in the following table:

Revision
Clock Frequency
Runtime

p3_rev_1_1_1



p3_rev_1_1_2



p3_rev_1_1_3



p3_rev_1_1_4



p3_rev_1_1_5




Average 
Average: 

On average, how much faster were the runtimes compared to level 4?
_____ min 
On average, how much difference in performance was seen?

_____ % 

· Inspect the reports for the MPPR run done at placer effort level 3 (p2_rev_3_3_*)

Fill in the following table:

Revision
Clock Frequency
Runtime

p2_rev_3_3_1



p2_rev_3_3_2



p2_rev_3_3_3



p2_rev_3_3_4



p2_rev_3_3_5




Average:  
Average:  

On average, how much faster were the runtimes compared to level 4?
_____ min  
On average, how much difference in performance was seen?

_____ %  

Were some individual results actually better in placer effort level 3

 than in placer effort level 4?



____ YES ____ NO (Y)
Now that you’ve seen results from different cost-tables, as well as different placer effort levels, is it possible to say which cost-table is always “best” for this design? (No)
MPPR is a good way to characterize the effect of the placer effort levels.  Due to the random nature of the placement tables, there will be overlap in the realized performance across the different placer effort levels (e.g. a given cost table in placer effort level 2 may yield a better performing design than obtained with placer effort level 4, using the same cost table.  Averaged over a set of cost tables, however, we see that higher effort levels produce better results)  

Discussion:

MPPR is a feature of the M1 tools provided to automate the process of exploiting multiple cost-tables towards the goal of obtaining better circuit performance.  

The cost-tables are in fact a set of 100 randomly generated seeds to determine different initial placement of the comps within a design.  The resulting performance spread obtained by using multiple cost-tables is sometimes in excess of 20%, with 10-15% being very common.   Designs which tax the routing resource availability will be more dependant on the quality of placement than those designs which are relatively easy to route.  

Running many cost-tables on very large designs is often impractical – especially when engineers are in a hurry to get the design into the board-level debug phase.  It’s often best to accept a quick result (we’ll explore the methods for obtaining results more quickly in the next PAR lab) for lab/debug purposes, and use MPPR in a “background” job to obtain the final result.   

Characterization of PAR runs across many (>50) cost tables shows a random distribution (bell-shaped curve – see presentation material).  Running even a few extra cost-tables (4-5) will often show a performance spread that will help in judging a reasonable upper limit a user can expect to obtain for a given design.

Once again, if more performance gain is required, some strategies to follow are:

1) Change source design to reduce levels of logic

2) Use a faster speed grade

3) Run a different set of cost tables to help find a “better” result.

Summary of MPPR Concepts:

1. Initial placement affects final placement and therefore the limit on achievable performance.

2. There is no way to predict which cost table will be “best” for any given design – even changing the placer effort level can change which cost-table is “best”.

3. View MPPR as a technique to extract an extra 15-20% gain in performance. 

Section 3 – Re-Entrant Routing

Process overview:

In this first part of this section, what you will learn is to how to setup the Flow Engine to do re-entrant routing on a design.

In part B of this section, you will only be required to inspect various report files of designs that have used re-entrant routing.  This will illustrate how re-entrant routing can be used to improve the final results of a given design.

Section 3A: Setting Up the Flow Engine to do Re-entrant Routing

· Expand the hierarchy tree for ver1_proto (bdes.xpj design)

· Check that rev1 (Timed, OK) Effort Level 2 is selected.   





The revision rev1 has already been routed for you.  This revision was run against a timing constraint that specified a 20ns clock period.    Suppose that the timing-analysis shows that this design didn’t quite meet this 20ns target, and actually achieved a 21.5ns clock period.  Re-entrant routing may be a good way to spend additional router effort to achieve the 20ns goal.

We will now setup the tools to use the re-entrant routing capability to run an additional 5 router passes on this design.  

As this exercise is meant to illustrate how to setup (but not run) the tools for re-entrant routing, you will omit the final step of pressing the “Play” button.

· Using the Design -> Copy Revision  facility, make a copy of rev1 and call it “my_test”
· Invoke the Flow Engine for my_test (i.e. Tools -> Flow Engine)
· Under the Setup -> FPGA Re-entrant Route dialog box, check the box to Allow Re-entrant Routing.

· Specify 0 Cost Based Clean-up Passes, 0 Delay Based Clean-up Passes and 5 Re-entrant Route Passes.

· Set the Implementation State back to “Map Completed” by clicking on the 
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 button twice.

At this point, you have setup the Flow engine to run 5 re-entrant routing passes on this design.  Note how the Flow engine window indicates that re-entrant routing is setup to run.  Normally, you would then proceed to press the “Play” button to invoke PAR.  To save time, we will omit the actual running of PAR in this step.

· Close the Flow Engine window.
Section 3B: Understanding the Effect of Re-entrant Routing

The next phase of this section will be to inspect actual report files from re-entrant routing runs.
· In the same project used for the previous section, expand the hierarchy tree for ver1 (the hierarchy tree may already be expanded from the last step.)

This design has already been routed for you.  This revision was run against a timing constraint that specified a 20ns clock period (50MHz clock frequency).  

· Select revision rev1 (Timed, OK) Effort Level 2.

· Using the report browser, inspect the contents of the Post Layout Timing Report for rev1
Does the design meet timing? 



YES____ NO____ N
What is the Maximum frequency obtained?


_____MHz (35.193)
· Now inspect the contents of the Place & Route Report

How many router iterations were run?


_____ (2) 

How many cleanup passes were run?


_____cost-based ____ delay-based (1,0) 


How much runtime did this run take?


_____ minutes (10:44)
2) Inspect results from re-entrant PAR run

· Now open the revision rev1_re-entrant (Timed, OK) Effort Level 2
How many additional router iterations were run?

_____ (10)
How many more cleanup passes were run?


_____(1)
How much more runtime was spent?


_____ minutes (33:59)
What is the Maximum frequency obtained?


_____ MHz (38.776)
How much is this  improved over rev1?

_____ % (10%)
Discussion:
Re-entrant routing can improve the timing of a design if there is enough routing “slack” available to re-distribute on the constrained timing paths. If a design is already routed to a level such that there is no more available slack, little or no improvement can be expected.  If the original number of router iterations was explicitly limited to achieve faster runtimes, it is likely that there is considerable timing slack available and therefore running more iterations will significantly improve performance.

Re-entrant routing is often a good technique to use if only a few (3-8%) percentage points in performance need to be gained (more if the original number of router iterations was clamped down to limit runtimes.)  If more performance gain is required, it’s often best to explore other options:

4) Change source design to reduce levels of logic

5) Use a faster speed grade

6) Use MPPR to exploit different placement cost tables (the prior lab)

CLB placement is not affected during re-entrant routing, though it is possible for pin swapping within CLBs to take place.  

The main portion of this lab is now complete.  If you have additional time, you may wish to explore the effect of the cleanup routers in the next section.

Section 4 – Cleanup Routing (OPTIONAL)

Objective : 

Learn how cost-based and delay-based cleanup routing passes affect a design’s score and timing.

Cleanup routing passes consider each connection in the design and works to minimize delays on those connections.  Two types of cleanup routing are available:

Cost-based: decisions to choose faster routes are based on pre-calculated data which quantify the relative speeds of the routing resources available.

Delay-based: decisions to choose faster routes are based on actually calculating the delays of the potential re-routes.

Process overview:
· Run PAR cleanup passes on pre-routed design.

· Review the files generated by PAR to understand how to evaluate the quality of  a design by comparing scores and timing results of one or many designs

Procedure: 

Prior to beginning this lab, you should have installed the lab materials onto your computer from the CD-ROM.  You may install the lab directories into any directory that is convenient.  

· Invoke the Design  Manager: 
Start -> Programs -> Xilinx Foundation Series -> Accessories -> Design Manager.
· Open the project using the pulldown menu: File -> Open Project
· Push the Browse button, a browser window will appear.

· Browse to C: -> {your directory path} -> ximpl -> bdes2 -> xproj -> bdes.xpj.  Push the Open button in the Browse window to open bdes.xpj.  Push the Yes button when asked if you want to add this project to the project list.  Push the Open button in the Open Project window to open the project.  If the DM/FE complains about not being able to find the source files, select OK then Cancel, which effectively tells the tools to ignore this problem.

· Expland the design hierarchy for ver2 Cleanup Routing Labs
The revision rev1 has already been routed for you.  This revision was run against a timing constraint that specified a 30ns clock period.  

· Using the report browser, inspect the contents of the Post Layout Timing Report

Does the design meet timing? 




YES____ (Y)
NO____

What is the Maximum frequency obtained?



_____MHz (35.79)
What percentage of connections are covered by the period constraint?  
_____% (83.7)
· Again, using the report browser, inspect the contents of the Place & Route Report

What is the Average Connection Delay for this design?

_____ns (4.120)
What is the Average Connection Delay for the 10 Worst Nets?

_____ns (14.404)
We will now setup the tools to use the re-entrant routing capability to run additional cleanup passes on this design.   We will then analyze the resulting report files to learn the effect (if any) the cleanup passes had on this design.

Test case 1: Effect of additional cost-based cleanup passes

· Using the Design -> Copy Revision  facility, make a copy of rev1 and call it “rev2”

· Invoke the Flow Engine for rev2 (i.e. Tools -> Flow Engine)
· Under the Setup -> FPGA Re-entrant Route dialog box, check the box to Allow Re-entrant Routing.

· Specify 1 Cost Based Clean-up Passes, 0 Delay Based Clean-up Passes and 0 Re-entrant Route Passes.

· Set the Implementation State back to “Mapped” by clicking on the 
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 button twice.

· Press the “Play” button at the bottom of the Flow Engine window to invoke the PAR run.

· Using the report browser, inspect the contents of the Post Layout Timing Report for rev2

Was Maximum frequency obtained affected?



_____MHz  (35.79)

Is this result any different from the previous result?


___ YES  ___NO NO

· Again, using the report browser, inspect the contents of the Place & Route Report

What is the Average Connection Delay for this design?

_____ns (4.073)
What is the Average Connection Delay for the 10 Worst Nets?

_____ns (13.934)
In general, did net delays improve?




___ YES  ___NO Y
How long did it take to run this additional cost-based cleanup pass?
_____minutes (2:08)

Test case 2: Effect of additional delay-based cleanup passes

· Using the Design -> Copy Revision  facility, make a copy of rev1 and call it “rev3”

· Invoke the Flow Engine for rev3 (i.e. Tools -> Flow Engine)
· Under the Setup -> FPGA Re-entrant Route dialog box, check the box to Allow Re-entrant Routing.

· Specify 0 Cost Based Clean-up Passes, 1 Delay Based Clean-up Passes and 0 Re-entrant Route Passes.

· Set the Implementation State back to “Mapped” by clicking on the 
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 button twice.

· Press the “Play” button at the bottom of the Flow Engine window to invoke the PAR run.

· Using the report browser, inspect the contents of the Post Layout Timing Report for rev3

Was Maximum frequency obtained affected?



_____MHz (40.183)

Is this a better result than was obtained in the previous two runs?
___ YES  ___NO Y
· Again, using the report browser, inspect the contents of the Place & Route Report

What is the Average Connection Delay for this design?

_____ns (3.462)
What is the Average Connection Delay for the 10 Worst Nets?

_____ns (9.231)
In general, did net delays improve?




___ YES  ___NO Y
How long did it take to run this additional delay-based cleanup pass?
_____minutes (3:03)

Discussion:

In general, the effect of the cleanup routers may not necessarily improve the timing of a design against a particular set of timing constraints.  Typically, the nets most affected by the cleanup routers are those that are not covered by timing constraints.  However, if the timing goals are relatively loose for the paths they do cover, one can reasonably expect that some nets already covered by timing constraints will also show speed improvements as a result of cleanup passes.
Floorplanner Lab

Objective : 

Learn how the floorplanner works within the M1 flow.  Study examples of  various floorplanning techniques, learn where the floorplanner is useful, understand some of the limitations of the current floorplanner.

Process overview:
The main objective of this lab is to teach you the  basics of the floorplanner design flow.

Additionally, for those of you that wish to learn more about the floorplanning process, there are two optional sections that can be covered on your own time.

Learning the basics of the floorplanner design flow

In this section, you will learn the steps to integrate the floorplanner into an M1-based design.  You will also learn the basic principles of operation of the Floorplanner GUI, and how to manipulate the design on at the “BEL-level”.  You will also learn how to use the Floorplanner as a means to view a placed and routed design.

As shown in the introductory presentation slides, the floorplanner uses design.ngd and design.ncd (mapped) as its input files.  After the user completes manipulation of the design elements within the GUI, the save operation outputs design.fnf and design.mfp. design.mfp contains BEL placement and CLB packing information and is then used as an input file to a second run of the mapper. PAR can then be run as normal.  The important point to remember is that MAP needs to be run twice for each design iteration involving the floorplanner.

To floorplan a design, the design needs to first be processed as normal through the translation (ngdbuild) and mapping (map) steps.  After mapping, if you are familiar with the design’s “structure”, you  can immediately start floorplanning,  It is often easier to first place and route the design (PAR) and then use the floorplanner to modify the placement – this is the flow that will be shown here.

The design calc_r.ncd has already been placed and routed.  You will use the floorplanner to modify this design.   

Start of lab:

· Invoke the Design  Manager: 
Start -> Programs -> Xilinx Foundation Series -> Accessories -> Design Manager.
· Open a project using the pulldown menu: File -> Open Project
· Push the Browse button, a browser window will appear.

· Browse to:
C: -> {your directory path} -> ximpl -> fplanlabs_d -> calc_fp -> xproj -> calc.xpj.  Push the Open button in the Browse window to open calc.xpj.  Push the Yes button when asked if you want to add this project to the project list.  Push the Open button in the Open Project window to open the project. 
· Expand the design hierarchy view for ver1.
· Select rev1, and invoke the floorplanner from the Tools -> Floorplanner pulldown menu item.  The floorplanner will read in the .ngd and .ncd files.

The Floorplanner will present you with four windows:

1. Design Hierarchy

2. Design Nets

3. Floorplan View

4. Placement View (this is “cascaded” behind the Floorplan View)

If the input .ncd was not a placed version, there would be no Placement view.  To best see all the windows, you should use the “Tile Compare” view.

· Use the Window->Tile Compare pulldown menu selection.  The placement view and floorplan view are now displayed side-by-side.

Note that the floorplan view already has some placed components – though we have not yet done any manual floorplanning

Questions: 

· What types of components are “pre-placed” in the floorplan view of the design?   IOBs
· Given that this design has not been previously “floorplanned”, how do you suppose these components came to exist in the floorplan view?  User entered constraints (netlist or UCF).
Manipulation of the floorplan is quite easy.  You can select BELs, groups of BELs, or RPMs from the Design Hierarchy window and drag them to sites within the Floorplan window. 

· To illustrate this process, select the icon-stack group LIFO/16X4 “RAM16X4S” (shown below) from the Design Hierarchy window and “drag” it to the Floorplan window.  Note how the ratsnests automatically show the connectivity of this block of logic to the I/Os.  

[image: image4.wmf]“Icon Stack”


· Drag the group back to the Design Hierarchy window – this effectively removes it from the floorplan window.  Expand the hierarchy for this logical group by clicking on the “+” symbol  for this group (similar to the hierarchy display of Windows Explorer).  This will expose the individual RAM elements. Select one of these, say LIFO/16X4/03 “RAM16”, again by clicking on the icon.  Place it in the Floorplan window as an independent BEL.  

· RPMs behave differently.  Scroll down the Design Hierarchy window until you find the block labeled ARITH/ADDSUB/hset “RPM”.  Expand this block.  Note how the individual BELs are not selectable for this RPM.  The RPM can only be floorplanned as an entire unit as the floorplanner will recognize and preserve the RLOC information of all RPMs and carry chain configurations.  Try moving the whole RPM to the floorplan.  This illustrates how you can use the floorplan to visualize the shape of an RPM.

Since this design has already been placed and routed, as is shown in the Placement Window, we can use this as our starting point.  To do this:

· Select the Floorplan->Replace all with Placement pulldown menu item.  Note how the actual placement information is now “imposed” on the floorplan.

· Modify the floorplan by moving some of the BELs, I/Os or RPMs.  (Don’t do too much, we need you to get through this lab as quickly as possible).  

· Select the Floorplan->Check Floorplan to verify that the moves you have made are legal (this checks for things like broken carry chains, illegal CLB packs, etc…)

· Save the floorplan by doing a File->Save.  This will write out calc.fnf and calc.mfp.  Leave the Floorplanner window open.

We now need to re-run the mapping and place/route phases of the implementation tools to incorporate the floorplan.

· In the Design Manager window, make sure rev1 is still selected.  Invoke the Flow Engine on this revision.  Set the implementation state back two steps by clicking on the [image: image5.png]


 button twice.  Only the Translate state should be marked now as Completed.

· Use the Utilities -> Command Preview pulldown menu item to see the command line that will be issued when Map is re-run. 

Question: 

· Compared to the previous invocation of Map, what is different about this command line? -fp calc.mfp
You can now verify how the floorplan has affected the placement

· Press the “Play” button to run the design through MAP and PAR.

· When the PAR job has finished, back in the Floorplanner window, you can now view the placement by doing a File->Update.  Specify calc.ncd and calc.ngd.  The Placement window should now reflect the changes you made in the Floorplan window.

· Exit the Floorplanner and Design Manager  (File->Exit).

Part 2: Understanding Floorplanning  of a “structured” Design (PCI core)

You will now look at a design that contains the PCI LogiCore.  The timing constraint for this design is a single 30ns clock period.  

In the c:\{your directory path}\ximpl\fplanlabs_d\struct_nofp directory, this design was run without any (floorplanner created) placement constraints. 

· Using a text editor such as WordPad, inspect the PAR output file, pci_top_r.par. 

Questions: 

· What is the target device for this design? xcs40-pq240-4
· What was the PAR effort level? 4
· How much CPU runtime was used?1:41:09 (h:m:s)
· What was the final timing score? 1340
· How much (negative) timing slack was there? –1.34ns
As you can see, this design fell just short of  meeting timing, even after a comparatively “high effort” PAR run.  It is possible to invoke other cost tables which will in fact lead to a design that does meet timing, but at a cost of some relatively long runtimes.

We know this design has logic which can be considered to be quite “structured” in its nature.  Datapath alignment and I/O placement are critical to obtaining a good result when the timing constraints are difficult to meet.  We can take advantage of the floorplanner to layout the critical portions of this design.

In the c:\{your directory path}\ximpl\fplanlabs_d\struct_fp directory, we have created a floorplanned version of this design.

· Invoke the floorplanner directly:

Start -> Programs -> Xilinx Foundation Series -> Accessories -> Floorplanner

· Use File->Open to open c:\{your directory path}\ximpl\fplanlabs_d\struct_fp\pci_top.fnf.   The floorplanner will ask you if you wish to update the floorplan  with  a new set of design files – click on the No button. When the floorplanner comes up, you may wish to resize the window to a larger size to ease viewing the design.

· Select a portion of the logic in the Floorplan window by dragging the mouse pointer over a region of the design while holding the left mouse button down.   For example, select an area that roughly corresponds to the lower-right “quadrant” of the chip.  It should produce a result that looks like:
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By looking at the ratsnest displayed, you can see quite clearly how the user of  floorplanner has laid out the datapath structures in perfect alignment.  Moreover, it is easy to see in this view that the I/Os associated with this datapath are also positioned in close proximity to the CLB to which they are connected.

· Select other pieces of the logic to see how things have been structured in this floorplan.  In addition to the datapath structures, the left-center region of the chip contains the PCI control logic.

· Again using an editor such as WordPad, inspect the PAR report file, pci_top_fpr.par.  

Questions:

· Which file contains the constraints that tell PAR where to place the floorplanned logic? pci_top.pcf
· How much CPU runtime was used?18:58 (m:s)
· What was the final timing score? 0
· How much (positive) timing slack was there? ~0.56ns
As you can see from the results of the PAR run that included floorplanning information, runtime was dramatically reduced and timing was easily met.  

· Back in the Floorplanner, view the placement by doing a File->Update.  Specify c:\{your directory path}\ximpl\fplanlabs_d\struct_fp\pci_top_fpr.ncd and pci_top.ngd. 

· Use the Window->Tile Compare pulldown menu selection.  You can now view how the remainder of the logic was placed (automatically by PAR) within the framework established during floorplanning.
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This is an example of a design that has some characteristics that make it a good candidate for floorplanning:

1.  The designer had detailed knowledge of the specifics of the target architecture/part.

2.  The designer had detailed knowledge of the specifics of the design being implemented. 

3.  It was a design that had structures that were well suited to this sort of detailed, BEL-level floorplanning.

4.  The designer was willing and capable of iterating over the floorplan multiple times to achieve the desired results.

5.  Performance and density goals that are realistic.

It is important to note here that not all designs will benefit from floorplanning.  It should be the case that the vast majority of designs will not need to be floorplanned in this manner, as the normal tool flows are be adequate the vast majority of the time.  It will take experience to develop the skills required to know if floorplanning is an appropriate tool  to use for any given design.

· Exit the floorplanner.

EPIC LAB 

OBJECTIVE - To learn some of the basics and some other really cool things about Epic.

1. Open the EPICLAB project from Design Manager

2. Select Rev 1

3. Press the Epic icon

Section 1: Viewing the Design
On workstations (running some window managers) the "focus" area follows the cursor, but on PCs, you must click in the window or on the header to get focus to that window.

4. Click in the main editing window to make the window active. 

5. Press the "s" key on the keyboard

The "s" key is a hotkey that is defined in the epic.ini file to toggle sites on and off.  So the first time you press "s", the sites in the device will become invisible.  Pressing the "s" key again will make them visible.

6. Press the "r" key

The "r" hotkey toggles visibility of routed nets on and off.

7. Point at one of the CLBs and press the "w" key

This zooms in to a working zoom level and turns visibility on for pips and routing resources.

8. Press the right mouse button to zoom in

9. Hold the shift key while pressing the right mouse button to zoom out

10. Press the "o" key to zoom all the way out and turn off the routing resources

This gets you to a view that allows easy viewing of the entire design and specific nets.

11a.  In the Epic List window, select CANCEL.  The list window will close.

11b.  To restore the display of the List Window, select Post List from the VIEW menu.

11. In the Epic List window, select the CLK net

Selected objects are highlighted in red.  Most operations within Epic happen on selected objects.  Another way to select a net is to hold the shift key down while clicking on a segment of the net.  If you do not use the shift key, Epic will only select the segment.

12. Push the "attrib" button on the right side of the main editing area

13. Select Show Pin List
This shows you the source and all loads (including delay) for the CLK net.  You can also see this same info in the history window on the bottom by pushing the "delay" button from the main editing area.

14. Cancel from the pin list form

15. Cancel from the net attributes form

The "a" hotkey brings up the dialog box that allows for command line entry.  The command line form can also be accessed through the View pull-down menu.  Highlighting different hierarchical blocks with different colors make viewing the placement much easier.

16. Change the Epic List window to look at Comps All

17. Select the $I1/Q<0> and $I1/T4 CLBs

18. Click in the main editing area to gain focus

19. Press the "a" key for command line entry

20. Type in the command line: hilite -c white
21. Type in the command line: select comp ADDR*
22. Type in the command line: hilite -c green
23. Press Cancel to exit the command entry form

Section 2: Timing Analysis

24. Change the Epic List window to look at Constraints

25. Select the NET "CLK" PERIOD constraint

26. Select Trace from the Tools pulldown menu

This will run the trce timing analyzer on the period constraint.  Once trce has completed, a window will pop up showing how many paths were analyzed and how many errors were detected.

27. Click on the line that displays the number of paths and errors

28. In the Trace Errors dialog box, click on the 3rd item
The number shown next to each item is the amount of slack, which is the difference between the constraint and the path delay.  Timing errors will show up as a negative slack.  We are choosing the 3rd item because the first two are paths on 1/2 clock edges and are not as interesting.

29. Press the hilite button on the Trace Errors dialog box

30. Press the report button

31. Cancel from both the Trace Errors dialog box and the Trace Summary dialog box

The highlighted path shows the components and nets in the specified path.  The report, which is shown in the history window on the bottom, lists each delay along the path.  The history window can be resized to make viewing easier.

(Optional) - Advanced Section 3: Editing a Design 

32. Press the clear button to make sure nothing is selected

33. Press the attrib button to bring up the main attributes form

34. Change the Edit Mode to Read-Write to allow changes within the Epic session

35. Press OK to exit the main attributes form

The main attributes form also allows you to change the speed grade and change whether you want automatic routing turned on or not.  You should turn automatic routing off if you are placing comps.

For now, keep automatic routing ON.

36. Make sure the Epic List window is set to Comps All
37. Select the $I1/Q<0> CLB

38. Press the editblock button

The block editor allows full programmability of the CLBs and IOBs.  You can change connectivity by clicking on the triangular pins.  You can view long net names by clicking on the pad type pins that the nets are associated with.

39. Push the Attr button in the LBE (Logic Block Editor)

40. Cancel from the attributes form of the LBE

41. Cancel from the LBE

The LBE attributes form can be used to view logic equations or even to change them for quick tests.  Remember that these changes will be saved to the .ncd, but will not be annotated to the original shcematic or HDL design.

(Optional) - Advanced Section 4: Adding a Probe Pin

42. Select the IOB site at pin P38.  NOTE: This can be done in several ways.  One way is to use the find button to find the P38 site (make sure you are finding a 'site' and not a 'pin').  Another is to zoom in to the bottom center of the device (you can use the "w" key), make sure the text layer is on ("t" hotkey), then pan around until you find the P38 IOB.

43. Press the add button

This will create an IOB in the site you have selected.  It will also bring up an attribute box that will allow you to name the IOB.  You may also keep the name assigned by Epic.

44. Press OK to exit the Component attributes form

45. Select the new IOB
46. Press the editblock button

47. Select the 3rd pin up on the output mux (the one from the O pin)

48. Press OK to exit the LBE

49. Select the "O" pin on the newly created IOB

The "O" pin is on the top right of the IOB.  If you want to check which pin is which, you can hold the cursor over a pin and press the "q" key.  You will have to be zoomed in to select this pin.

50. Change the Epic List window to look at Nets All
51. Select the ADDR<0> net

52. Press the add button

You have just added a probe!  The net will be automatically routed as long as you have not turned off automatic routing in the main attributes form.
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EPIC Hotkeys - Upper or lower case will work:

A
Post command entry window

C
Toggle component visibility

N
Toggle rastNest visibility

O
Zoom Out and turn most visibility off

Q
Query what cursor is pointing to

R
Toggle routes

S
Toggle sites

T
Toggle text

W
Zoom into working level

X
Post command entry window that disappears after one command

Z
Zoom toggle

Ctrl U
Undo

Ctrl E
Set mode to read-write

Ctrl R
Set mode to read-only

Ctrl N
Set mode to no-logic-changes

Arrow
Pan in direction of arrow

Shift-arrow
Pan to edge of device in direction of arrow

Customization options can be found in epic.ini, which can be found in $XILINX/xc4000/data.
Timing Improvement Lab 

Objective - To learn how to identify why a design does not meet its timing constraints, and what strategies can be used to improve timing.

This lab is in time_impr_1.  It is set up as a Design Manager project with 3 revisions.

Browse for and open the existing time_impr_1 project.  The Design Manager will output a message saying it cannot find the input design.  Dismiss this message, change the input design file type to .xtf, and open the design_1.xtf file in the time_impr_1 directory.  You will then see the 3 revision time_impr_1 project.

1.Look at ver1, rev1.  This design has two constraints that are failing.  What are they, and how much are they failing by?

Constraint


Req'd
Actual
Diff.

FCLK PERIOD 


25 ns
28.428
3.428ns

Offset in Before


12 ns
13.791
0.451ns

2. For the Period constraint, is the worst case path delay dominated by logic delays or routing delays?

The worst case path is almost 70% logic delay.

3. For the Period constraint, how many logic levels does the timing analyzer report?

7 logic levels

4.  If you need to achieve 25ns for the PERIOD constraint, should the customer expect to have to reduce a logic level to achieve it, or just have PAR work harder?  Why?

The customer should reduce a logic level.  There is only 8.7 ns of total routing delay spread out across 6 nets, and expecting this to be reduced by the 3.4 ns needed to meet the spec is not reasonable, considering that the routing delays only make up 30% of the total path delay.  

5.  What is the worst case path delay for the Offset constraint?  What is the total routing delay for this path?

13.794ns worst case Offset, with a total routing delay of 8.555ns.

6.  Is there a singe net that accounts for most of this delay?  What net and what is its fanout?

CTLWR has a fanout of 10.

When a single net like CTLWR accounts for most of the routing delay in a path, it deserves a look to see why before asking the tools to work harder - and thus longer - to reduce it.  For example, is the fanout high enough that if it were split timing might be improved?  Has the customer manually placed logic, either IO pins or CLBs, in such a way that is causing the long delay?  We will take a look at this design next in EPIC to examine this.
7. Look at the design in EPIC.  A toolbar icon to call EPIC is available on the right hand side of the Design Manager.  Make sure you have rev1 highlighted, then select the EPIC icon.  Display the slowest path for the Offset constraint. (The EPIC lab taught you to select the constraint in the LIST window, then run TRACE from the TOOLS menu, select the failing constraint and finally HILITE the worst case path.)  On what side of the device does this path start?  On what side does it end?  Where does the second worst path start and end?  Since the user has defined the pinout, has he made it easier or harder for the tools to meet this OFFSET constraint?  

The worst path starts on the bottom of the device, and ends on the left side, and the second worst path ends all the way at the top of the device.  The user has clearly made it more difficult for the tools to meet the required performance with his choice of pinout.

8.  What could have been done to improve this?

Lock the source pins closer to the driving pins.

9.  Rev2 shows the same design implemented with the CTLWR source duplicated and another net created to decrease the fanout.  Close EPIC and take a look at the timing report for rev2 in the Report Browser.  Does the design now meet the OFFSET constraint?  What is the fanout and max delay of CTLWR now?

Yes, the design now meets the constraint. CTLWR now has a fanout of 6, and a max delay of 4.1ns.

10.  Rev3 shows the design implemented after making changes to reduce the number of logic levels.  What is the slowest path now for PERIOD?  Is it the same 7 logic level path? 

The slowest path is now 24.889 ns. The worst path now has 5 logic levels instead of 7. 

Overview:

This lab expected the user to be able to read a Post Layout Timing Report to identify what constraints were not meeting timing.  The user should be able to understand the timing of a detailed path, and identify whether a timing miss was caused by too many logic levels or long routing delays.  

Designs which have long routing delays should be analyzed to see if the long delays are because of high fanout, user restrictions like preassigned pins, or suboptimal placement due to lower PAR effort levels or a poor cost table.  General placement or routing issues can usually be addressed through re-entrant routing, higher effort levels, or additional cost tables, but user or design restrictions like bad pin preassignment or too many logic levels need to fixed by modifying the design source. 

For this design, we improved timing on the PERIOD constraint by reducing the number of logic levels in the period constraint, since asking for a 70/30 logic-to-routing ratio is too great an expectation.  Once designs exceed about 50/50 (and lower for very large designs), designers should expect to reduce logic levels to meet timing.

For the Offset constraint we also improved timing by changing the design.  In this case we duplicated the driver of the CTWLR net, which allowed the tools to meet the constraint.   
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