Using Model Technology ModelSim with Xilinx Foundation
Series Software

2

e Programmable Logle Company -

Model Technology

A MENTOR GRAPHICS COMPANY

Xilinx Library Setup

Because the ModelSm VHDL and Verilog simulators use compiled HDL libraries, each of the Xilinx HDL
simulation libraries must be compiled before simulating any HDL descriptions containing Xilinx specific
parts. Thisisatask that should only be done once, and then updated only if new Xilinx libraries are
required.

The following sections describe how to set up Xilinx libraries for use in ModelSm simulations. The first
three sections describe the step-by-step instructions for compiling the Xilinx simulation model libraries.
The forth section describes how to setup and run an automated script to accomplish the same task.

Section 1. Compiling the LogiBLOX library

1. Using the Windows Explorer, make an MTI directory in $XI LI NX\ vhdl \ dat a. If you have
installed the Foundation Series software in the default location, thiswill resolve to
C. \ FNDTM vhdl \ dat a\ MTI

2. After starting ModelSm, select File -> Directory and browse over to SMODELSIM.

3. InModelSm, select Library -> New.

4. Type $XI LI NX/ vhdl / dat a/ MT1 /| ogi bl ox.

Enter name of the Library to create:
|$><|L|le".\-'hdhdata"\MT|"'.|I:Igi|:l|l:l:-:

Cancel |

5. Select Library -> Mapping and press New.
6. For Library, enter LogiBLOX. For Directory, enter $XI LI NX/ vhdl / dat a/ MTl /| ogi bl ox.

fLivrary Mapping
I Library Directory

std SMODEL_TECH{std

ieee SMODEL_TECH{ieee

verilog SMODEL_TECH}verilog

arithmetic SMODEL_TECH{arith

mgc_portable SMODEL_TECH{mgc_port

std_developerskit SMODEL_TECH/stdevkit
SYnopsy Frym Library Entry

Library: [LogiBLOX

Directory: ISXILINX‘\VhdI\data\MTI\,Ingihlux

M 0K I Cancel |




7. From the Model Sm application window, pressthe VCOM button on the toolbar.
8. Inthe Compile VHDL Source dialog window, set the Target Library to LogiBLOX.
9. Inthe Directories window, changeto $XI LI NX\ vhdl \ sr c\ | ogi bl ox.

Compile YHDL Source Ed |

File Mame:; Directaries: -m
Im'.,-'lutil_-.,.-hd d:sndtnteehdls ez logiblos
]
logiblo. vhd B Er =] &l
rnlarith. whd [E= FNDTN :
bl whd = b Optionz. .. |
[= =
E= |ngiblox
List Files of Type: Drives: ¥ Compile Moare
WHOL sources [* vhd) j I = d: D Drive j M etwark... |
T arget Library: ILDEIiB L0 Start compiling on line; I1

10. Usethe Compileto compile the VHDL filesin the order they are shown:
mvlutil.vhd
mvlarith.vhd
logiblox.vhd

Section 2. Compiling the Unisim library:

As you may have noticed, atranscript of the work you have been doing has appeared in the Model Sm
Transcript window. The transcript window records the commands used to accomplish the sametasks. To
accomplish the remainder of the Xilinx library setup, type the following commands into the Model Sm
Transcript window:

i Transchnipt

cd SMODEL_TECH :I
vlib SXILIN:Ywhdl\data\MTNunisim
vmap unisim SXILIN:Yvhdl\data\MTlunisim
# Modifying D:f3rdpartyfmodelsimfmodelsim.ini
wvocom -work unisim SXILINAwhdlisrclunisimsiunisim_VPKG.vhd
# — Loading package standard
# — Loading package std_logic_1164
# — Loading package vital_timing
# — Loading package vital_primitives
# — Compiling package vpkg
# — Compiling package body vpkg
# — Loading package vpkg
|Mudt:l5im>| ~|

[ Bl




cd $MODEL_TECH

vlib $XI LI NX/vhdl/data/nti/unisim

vhap uni sim $XI LI NX/ vhdl /data/nti/unisim

vcom -wor k uni si m $XI LI NX/ vhdl / src/ uni si ms/ uni si m VPKG. vhd
vcom -wor k uni si m $XI LI NX/ vhdl / src/ uni si ns/ uni si m_ VCOWP. vhd
vcom -wor k uni si m $XI LI NX/ vhdl / src/ uni si ns/ uni si m VI TAL. vhd
vcom -wor Kk uni si m $XI LI NX/ vhdl / src/ uni si s/ uni si m VCFAK. vhd

Section 3. Compiling the Simprimslibrary:
The following commands are those used to compile the Xilinx simprim VHDL libraries.

cd $MODEL_TECH

vlib $XILINX vhdl/data/ MIl/sinmprim

viap sinmprim $XILINX/ vhdl /data/nti/sinprim

vcom -work sinmprim $XI LI NX/ vhdl / src/ sinprims/sinprimVpackage. vhd
vcom -wor k sinmprim $XI LI NX/ vhdl / src/ sinprinms/sinprimVconponents. vhd
vcom -wor k sinprim $XILINX/ vhdl/src/sinprins/sinprimVlITAL. vhd

Section 4. Using a macro file

If you place all the above Model Sim commands into afile (i.e. foundation_setup.do), it can then be used to
automatically setup and compile each of the libraries as demonstrated above. This script could then be
used to recompile the libraries should any of them be updated. To run this script, perform the following:

1. Using the Windows Explorer, make an MTI directory in $XI LI NX\ vhdl \ dat a. If you have
installed the Foundation Series software in the default location, this will resolve to
C: \ FNDTMN\ vhdl \ dat a\ MrI

2. From the Model Sm main window, chose File >> Execute Macro...and browse to the
foundation_setup.do file.

Execute Macro EE

Laok in: I 4 temp j gl E%

File: name: Ifoundatiun_setup.do Open I
Files of type: IMacro Files [*.da) ﬂ Cancel |

Exporting Foundation Schematics for VHDL Simulation

The following section describes the steps necessary for exporting and simulating a Foundation Schematic.
Exporting the Foundation Project
1. Start Xilinx Foundation Project Manager

2. Fromthe Program Manger Filestab, double click on the top level schematic file. Thiswill open the
top level of the design in the schematic editor.



Files * Yersions
B £3 watch_sc
0 watch_sc.uct

-1 §hB - outs?
-1 §h7 - outs1
I $ha - outs3
@11 - tenths
H-& ul - cnté0
R 12 - stmach_y
- Blru3 - hexZled
- Elrud - hexZled
- & watch_sc

- B simprims

- 3 spartanx

3. Fromthe Options menu of the schematic editor, select Export Netlist...

Create Metlist Shift+F2
Create Metlist fram Current Sheet
Inteqrity Test Clrl+F2

Esport Metlst

Wipdate Eimul atier
Simulate Eurrent Mecra

LogiBLO.
Import LogiBLO. ..

Annotate . Clrl+k.
Syrnbal Editor Ctr+E
Replace Symbal

Rename Met

Bepaort ...

4. Inthe Export Netlist dialog box, change the Files of type selection to VHDL
5. Browseto the schematic project file (.ab extension), and select Open

Export Hetlist EHE
Lok ir: I _ 4 watch_sc j gl E

|| dprncomp. tmp

| |lib

| lxproj
i

File name: Iwatch_sc.alb Qpen I
Files of type:  [vhdl [~¥HD] | Carcel |

Each sheet of schematic will be exported asaVHDL structural netlist to the project directory. Each
structural netlist will be given a name identical to that of the schematic block from which it was created.

Simulating the design



oo

Open ModelSm

Use File >> Directory... to change to the project directory where the VHDL structural netslist files
were exported

Create anew local modelsim.ini file by selecting Project >> Newand entering modelsim.ini asthe
name of the project to create.

If you have correctly set up the Xilinx libraries previously, selecting Libraries >> Mapping... should
reveal that the Xilinx libraries are mapped to the previously compiled libraries. Thiswould look
similar to the following:

Loy Mapping

Library Directory
std SMODEL_TECH{std
iege SMODEL_TECH{ieee
verilog SMODEL_TECHMverilog
arithmetic SMODEL_TECH/{arith

mgc_portable SMODEL_TECH/mgc_port
std_developerskit SMODEL_TECH/stdevkit

SYNOPSYS SMODEL_TECH{synopsys
LogiBLOX SHILINXMhdldatafMTIlogiBLOX
unisim SxILINXfvhdl{datafMTlfunisim
simprim SHILINXMhdl}datafM T simprim

Nt:wl Editl Df:letf:l Cancell ma:|

Create aworking library using Library >> New... and typing WORK as the library name.

(If your design has a global signals) Compile the global signal support package pack.vhd
(automatically generated by the Foundation tools) using File >> Compile VHDL... Itisnecessary to
first compile this package into the working library to support any global signals that may have been
used in the schematic.

Beginning from the leaf models of the design, compile each of the modules until the entire design has
been compiled into library work.

If there are LogiBLOX modules referenced in the schematic, the VHDL simulation models may not
have been copied to the Export VHDL command. Use Explorer to copy each of the simulation
models to the local directory. If you did not generate VHDL simulation models for your logiBLOX
modules, run LogiBLOX again to generate the simulation models for each module.

From the File >> Simulate .. dialog window, choose the top level entity/architecture or module for

simulation. If you have included a VHDL testbench, this will be the top level module.

Simulate a Design EHE
Desian | HDL | Veriog | SDF |
Simulator FResolution: Iw vl
Libwary: Iwork 'l Browse... | ey |
Simulate:l Add
design unit name
tl_simnulation
Entity chdce
Entity cddce
Entity chitel j

Ok I Cancel Lpply




10. Set up the simulation debugging windows by first resizing the Model Sm window to take up most (if
not all) of your screen and then selecting View->All and Window->Tile Horizontally. Find the
Transcript window and type in the following commands to set up the Wave and List windows:

VSIM> list /*
VSIM> wave /*
Thiswill add all the signals or nets at the top level of the design to the Wave and List windows.

] ModelSim PE/Plus [_[7]x]
File Wiew Library Project Bun  Signals Options ‘window Help

WCOM VLDEI WSk I ﬂlm BREAK STERP DVEHI
I e

imulate File Edit Options

Fapply_stim

[] clk_pulse = 5 ns ns delta clk rst_n a b

rst_n b i =
u 0608 [] data_apply time 1 ns

clk a | 11ttle_ll.:_c1k =8 ns
u ooae —— apply_stinm
[] flag - @

a +8 u U AB8d Aesd UUU;

q
uuvuuuuy

»

o Wave [ Source ol =]
File Edit Zoom Cursor Options <Ready> apply stim / 583 A <= "@aea"; |

q B <= "@888";
<Ready> line 41 it until RST N = *1°;
<Ready> line_ 36
<Ready> line_ 68 until CLK'event and CLK = | |

i 63 wait for DATA_APPLY_TIHE;
<Ready> line_ 65 ™ A <= "@aeer; -
<Ready> line_ 53 65 B <= "8801";
. 66 wait for LITTLE_LT_CLK;
<Ready> lfnef‘ﬂ 67 if /= "80088088" then
<Ready> line 42 68 assert false report "0 is not
<Ready> line_ 36 60 flag := "1'; =
LI oz
i Transcript [_ O] =]

B
¥ Loading D:\EVAL_MODELSIM/std.textio[body]
¥ Loading DA\EVAL_MODELSIM/ieee.std_logic_
PACKAGE standard ¥ Loading D:\EVAL_MODELSIM}ieee.std_logic_:
PACKAGE textio # Loading D:AEVAL_MODELSIM/ieee.std_logic_»
q # Loading work.tmult[simulate]
PACKAGE 5td_lug?c_11|?!| # Loading work.mult[synthesize]
PACKAGE std_logic_arith view *
PACKAGE std_logic_unsigned list*

dut: mult{synthesize)

[ [Now: 0 ns Delta; 0 ILine 25 of 34 |

Take alook at each of the 9 windows within ModelSim to familiarize yourself with them.
Transcript — The command-line window; displays a transcript of all command activity.
Sour ce — Displays the HDL source code for the design.

Structure — Displays the hierarchy of structural elements such as VHDL component instances, packages,
blocks, generate statements, and Verilog model instances, names blocks, tasks and functions.

Wave — Displays waveforms and current values for the VHDL signals, and Verilog nets and register
variables you have selected.

List — Shows the simulation values of selected VHDL signals, and Verilog nets and register variables in
tabular format.

Dataflow — Allows you to trace VHDL signals or Verilog nets through your design.

Signals — Shows the names and current values of VHDL signals, and Verilog nets and register variables in
the region currently selected in the Structure window.



Variables— Displays VHDL constants, generics, variables, and Verilog register variables in the current
process and their current values.

Process — Displays a list of processes that are scheduled to run during the current simulation cycle.

Many of these windows are dynamically linked with each other. If you click on a signal or process in one
window, the other windows will update to display or highlight that object.

11. Run the simulation. Press the “RUN” button or type “run 100” at the VSIM> prompt. Below is an
example of setting a cursor in the Wave window and of hitting a breakpoint in the Source window.

%/ ModelSim PE /Plus

File  “iew Library Project Bun Signalz  Optionz Window  Help
weoM | wvioc | wsim | [RUn] cowt]  eReak|  sTER| OvER|

File Edit Zoom Cursor Options

[] fclk = @
[ #rst.n =1

=] /q = 86 |

l— No File  “iew Library Project Bun Signalz  Optionz:  Window  Help
wooM | wioc | wsm | Run|cont|  ereak|  sTER| OvER|

1 B 1oK==

ha —-- Create the clock 'J

1 process {(RST_HM, CLK})

42 begin |

43 if (RST_H = '8') then

Ly CLK <= '@8"';

Lt else
[ el CLE <= not CLK after CLK_PULSE;

W7 end if;

L1 end process; -
A A=
y | - I

ns Delta: 0 Line 40 of 175

12. Quit ModelSim. Select “File->Exit ModelSim” from the Mo&eh menus.



Simulation of Post Place and Route Designs

The Xilinx implementation tools will produce atiming simulation netlist after the design has been placed
and routed. The ModelSm simulator HDL can perform afully back annotated timing simulation using this
netlist and SDF timing information.

Creating a back annotated timing netlist

1.
2.

3.

Select Implement >> I mplementation Options from the Foundation Project Manager

Ensure that the Produce Timing Smulation Data option is selected in the Options dialog, and that the
Program Option Template has the Smulation template set to Modelsim VHDL or Modelsim Verilog
(depending on the desired HDL language)

Options

— User File

Uszer Constraints: IF:\><I LIN=NActivehprojectshwtut_schawtut_sc. uck Browse... |

— Program Option Template:

Irnplermentatior: IDefauIt j Edit Template... |
Simulation: IFDundation EDIF j Edit Template... |
LConfiguration: IDefauIt j Edit Template. .. |

— Optional Target

W Produce Timing Simulation D ata

ok I Cancel I Help

Click OK and complete the implementation of the design.

Simulating the full timing netlist

1
2.

From the M odel Sm window, browse to the specific design revision in the project directory
Using File >> Compile VHDL ... (or Verilog...) compile the timing simulation netlist produced by
the Xilinx implementation tools. This file will be named eithee sim.vhd ortime_sim.v

Note: If you have symbols which require configuration before simulation, such as OSC, ROC, or
TOC, configure those before compiling the timing simulation netlist.

Compile the HDL test bench. There is a template test bench file created by the Xilinx implementation
tools. The file will be named eithéme_sim.tvhd ortime_sim.tv

From theFile >> Simulate dialog, choose the top level of the design (including any test bench you

have created).

From theSimulate a Design dialog, under th&DF tab, include the SDF back annotation timing file
created by the Xilinx implementation tools. This file will be narieg_sim.sdf. In theApply to

region field, enter the hierarchical path to the region that the time_sim.sdf file applies to. For

example, for a testbench called “tb” that instantiates a design called “my_design” that the time_sim.sdf
was created for, the region to apply the SDF file to would be “/tb/my_design”. Press “OK".



Simulate a Design

|

-
et =
[ ok ]| _ Corcdl |

6. After the simulationisloaded, you can use the Model Sim debugging windows described above to
simulate and debug the full timing netlist.



