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Preface

About This Manual
This manual describes Xilinx’s Timing Analyzer program, a graphical
user interface tool that performs static timing analysis of an FPGA or
CPLD design. The mapped FPGA design can be partially or
completely placed, routed or both. The CPLD design must be
completely placed and routed.

Before using this manual, you should be familiar with the operations
that are common to all Xilinx’s software tools: how to bring up the
system, select a tool for use, specify operations, and manage design
data. These topics are covered in the Development System Reference
Guide. Another publication that you can consult for related informa-
tion is the XILINX Software Conversion Guide from XACTstep v5.x.x to
XACTstep vM1.x.x. In addition, familiarity with the Microsoft
Windows operating system is helpful.

Manual Contents
This manual covers the following topics.

• Chapter 1, Introduction describes the Timing Analyzer’s func-
tion, place in the Xilinx design flow, key features, inputs and
outputs, and the architectures with which it works. It also
outlines the basic procedure for using the tool.

• Chapter 2, Timing Analysis describes the basic path types and
explains how the Timing Analyzer solves some basic design anal-
ysis problems.

• Chapter 3, Getting Started describes how to access and exit the
Timing Analyzer; how to use its menus, icons, Console window,
dialog boxes, and filters; and how to use its online help facility.
Timing Analyzer Reference/User Guide — October 1997 iii
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• Chapter 4, How to Use the Timing Analyzer explains how to
perform most of the Timing Analyzer’s major functions.

• Chapter 5, Menu Commands lists and describes all the menu
commands available in the graphical interface.

• Chapter 6, Keyboard Commands lists and describes all
commands that you can enter in the Console window.

• Appendix A, Glossary defines all the terms that you must under-
stand to use the Timing Analyzer effectively.
iv Xilinx Development System



Conventions

Typographical
This manual uses the following conventions. An example illustrates
each convention.

• Courier font  indicates messages, prompts, and program files
that the system displays.

speed grade: -100

• Courier bold  indicates literal commands that you enter in a
syntactical statement.

rpt_del_net=

Courier bold  also indicates commands that you select from a
menu.

File → Open

• Italic font denotes the following items.

• Variables in a syntax statement for which you must supply
values

edif2ngd design_name

• References to other manuals

See the Development System Reference Guide for more informa-
tion.

• Emphasis in text

If a wire is drawn so that it overlaps the pin of a symbol, the
two nets are not connected.
Timing Analyzer Reference/User Guide — October 1997 v
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• Square brackets “[ ]” indicate an optional entry or parameter.
However, in bus specifications, such as bus [7:0], they are
required.

edif2ngd  [option_name] design_name

Square brackets also enclose footnotes in tables that are printed
out as hardcopy in DynaText.

• Braces “{ }” enclose a list of items from which you choose one or
more.

lowpwr ={on|off}

• A vertical bar “|” separates items in a list of choices.

symbol editor_name [bus|pins]

• A vertical ellipsis indicates repetitive material that has been
omitted.

IOB #1: Name = QOUT’
IOB #2: Name = CLKIN’
.
.
.

• A horizontal ellipsis “. . .” indicates that an item can be repeated
one or more times.

allow block block_name loc1 loc2 ... locn;

Online Document
Xilinx has created several conventions for use within the DynaText
online documents.

• Red-underlined text indicates an interbook link, which is a cross-
reference to another book. Click on the red-underlined text to
open the specified cross-reference.

• Blue-underlined text indicates an intrabook link, which is a cross-
reference within a book. Click on the blue-underlined text to
open the specified cross-reference.

• There are several types of icons.

Iconized figures are identified by the figure icon.
vi Xilinx Development System



Iconized tables are identified by the table icon.

The Copyright icon displays in the upper left corner on the first
page of every Xilinx online document.

The DynaText footnote icon displays next to the footnoted text.

Double-click on these icons to display figures, tables, copyright
information, or footnotes in a separate window.

• Inline figures display within the text of a document. You can
display these figures in a separate window by clicking on the
figure.
Timing Analyzer Reference/User Guide vii
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Chapter 1

Introduction

This chapter briefly describes the Timing Analyzer’s function, place
in the design flow, major features, inputs and outputs, and the archi-
tectures with which it works. It also outlines the basic procedure for
using the tool. This chapter contains these sections.

• “Function” section

• “Design Flow” section

• “Inputs and Outputs” section

• “Architectures” section

• “Features” section

• “Online Help” section

Function
The Timing Analyzer performs static timing analysis of an FPGA or
CPLD design. The FPGA design must be mapped and can be
partially or completely placed, routed or both. The CPLD design
must be completely placed and routed. A static timing analysis is a
point-to-point analysis of a design network. It does not include inser-
tion of stimulus vectors.

The Timing Analyzer verifies that the delay along a given path or
paths meets your specified timing requirements. It organizes and
displays data that allows you to analyze the critical paths in your
circuit, the cycle time of the circuit, the delay along any specified
paths, and the paths with the greatest delay. It also provides a quick
analysis of the effect of different speed grades on the same design.

The Timing Analyzer works with synchronous systems composed of
flip-flops and combinatorial logic. In synchronous design, the Timing
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Analyzer takes into account all path delays, including clock-to-Q and
setup requirements, while calculating the worst-case timing of the
design. However, the Timing Analyzer does not perform setup and
hold checks; you must use a simulation tool to perform these checks.

Design Flow
You use the Timing Analyzer after mapping, placing, and routing, as
shown in the following figure.
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Introduction
Figure 1-1 Timing Analyzer in the Design Flow

Inputs and Outputs
The Timing Analyzer accepts NCD design files and physical
constraints files (PCF) output by the mapper for FPGAs. It also
accepts VM6 (CPLD) design files output by the fitting software. The
Timing Analyzer also loads macro files (XTM) as input and creates
timing report (TWR) files as output. It can also create macro (XTM)
files.
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Note: The Timing Analyzer loads the default PCF file, which is the
physical constraints file with the same name and located in the same
directory as the NCD file. The order of the timing constraints in the
PCF file is reflected by the Timing Analyzer. CPLD physical
constraints information is contained in the VM6 file itself.

Architectures
You can use the Timing Analyzer with Xilinx XC3000A, XC3000L,
XC3100A, XC3100L, XC4000L, XC4000XL, XC4000E, XC4000EX,
XC5200, and XC9000 devices.

Features
The Timing Analyzer offers the following interface, report, filters,
macro, and analysis interrupt features.

Interface
You can issue Timing Analyzer commands from the menus, toolbar,
or Console window. You can also activate commands by running
macros. The instructions in this user guide use only the menu
commands or toolbar buttons, but the equivalent command-line
syntax is given in the “Keyboard Commands” chapter.

Reports
The Timing Analyzer creates the following seven reports.

• Timing Analysis report compares design performance to the
timing constraints.

• Design Performance report displays the results of analyzing the
constraints specified in the constraints file for FPGAs. If no
constraints are specified, this report displays the maximum clock
frequencies for all clocks in the design and the worst-case timing
for all clock paths. For CPLDs, it displays all external synchro-
nous path delays which include: pad-to-pad (tPD), clock pad-to-
output pad (tCO), setup-to-clock-at-the-pad (tSU), and internal
clock-to-setup (tCYC) paths.

• All Paths report contains a detailed analysis of all specified paths
and includes the worst-case path delays for all paths in the
design. You can filter this report.
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• Clocks report lists the names of all clocks in the design.

• Settings report lists the current settings set with commands in the
Path Filters and Options menus.

• Query Nets report displays net delay information. (FPGA only)

• Query TimeGroups displays time group information. (FPGA
only)

The content of these reports is described in the “How to Use the
Timing Analyzer” chapter.

Path Filtering Commands
You can customize the Timing Analyzer reports by selecting certain
commands in the Path Filters menu and its submenus. Additional
customizing is achieved by applying filters to these commands. The
Path Filters menu contains the Timing Constraint Filters, Path Anal-
ysis Filters, and Common Filters submenus.

• Timing Constraint Filters commands affect only those paths that
deal with timing constraints. These commands affect the Timing
Analysis and Design Performance reports.

• Path Analysis Filters commands deal with specific paths whose
starting points, ending points, and types you can define. These
commands apply to the All Paths reports.

• Common Filters commands exclude or include specific paths
with nets and control path tracing. These commands apply to the
Timing Analysis, Design Performance, and All Paths reports.

Macros
You can create macros that execute multiple Timing Analyzer
commands in one step. Macros are script files for running Timing
Analyzer commands and options. The Console window records all
the commands that you execute in any Timing Analyzer session.
After entering the desired series of commands in this window, you
can copy and paste the sequence into a macro document, save the
macro document, and run it.
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Analysis Interrupt
The commands in the Analyze menu have an interrupt function
when analyzing FPGA designs. A Timing Analysis in Progress dialog
box with an Abort button appears. Clicking the button, the Esc key, or
the Enter/Return key stops analysis. A report is not generated or
displayed.

Online Help
The Timing Analyzer offers both context-sensitive help and a Help
menu. See the “Obtaining Help” section of the “Getting Started”
chapter for more information on the online help available and
instructions for accessing it.
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Chapter 2

Timing Analysis

This chapter explains some of the concepts involved in static timing
analysis and how to use the Timing Analyzer to resolve key analysis
issues.

Xilinx software tools support two different methodologies of imple-
menting timing analysis. For FPGAs, timing is analyzed through
user-defined constraints specified with Timing Analyzer commands
and filters. The commands in the Timing Constraints Filters submenu
help you customize your analysis. See the “Timing Constraint Filters
Submenu (Path Filters Menu)” section of the “Menu Commands”
chapter and the XILINX Software Conversion Guide from XACTstep
v5.x.x to XACTstep vM1.x.x for more information. CPLDs use system-
defined paths for timing analysis. These paths are selected with
commands in the Path Analysis Filters submenu. See the “Path Anal-
ysis Filters Submenu (Path Filters Menu)” section of the “Menu
Commands” chapter for more information on these commands.

This chapter contains these main sections.

• “Basic Path Types” section

• “Design Analysis Issues” section

Basic Path Types
After you implement your design, you can use the Timing Analyzer
to calculate your design’s system performance, which is limited by
seven basic types of timing paths. Each of these paths goes through a
sequence of routing and logic. Because these path delays are affected
by the results of the placement and routing that implement the design
connectivity, these sequences can vary.

To prepare you to read the Timing Analyzer reports, the following
sections describe the basic path types in a design.
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Clock to Setup
A clock-to-setup path starts at flip-flop clock inputs, propagates
through the flip-flop Q output and any number of levels of combina-
torial logic, and ends at non-clock flip-flop register inputs, D or T, or
the receiving flip-flop’s tSU, where that pin has a setup requirement
before a clocking signal. It includes the clock-to-Q delay of a flip-flop,
the path delay from that flip-flop to the next flip-flop, and the setup
requirement of the next flip-flop. The clock-to-setup path time is the
maximum time required for the data to propagate through the source
flip-flop, travel through the logic and routing, and arrive at the desti-
nation before the next clock edge occurs. When these flip-flops are
clocked by the same clock, the delay on this path is equivalent to the
cycle time of the clock. The following figures show a clock-to-setup
path which uses the same clock. The “Clock-to-Setup Path (Same
Clock) with Timing Diagram” figure also shows a timing diagram
describing the path.

Figure 2-1 Clock-to-Setup Path
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Figure 2-2 Clock-to-Setup Path (Same Clock) with Timing
Diagram

Source and destination flip-flops can be clocked by the same clock on
different clock edges. In these cases, the path delay limits the
minimum clock high or clock low time as shown in the following two
figures.

interconnect
and
logic

X6185

D QD

clock

clock

valid valid

Q

clock
to

output

logic and routing
delay

flip-flop
setup

path delay
minimum clock period
Timing Analyzer Reference/User Guide 2-3



Timing Analyzer Reference/User Guide
Figure 2-3 Clock-to-Setup Path (Rising to Falling Edge)
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Figure 2-4 Clock-to-Setup Path (Falling to Rising Edge)

If the source and destination are clocked by different clock nets, both
clock nets must have a clock period greater than the path delay. The
PERIOD constraints allow the Timing Analyzer to use the target flip-
flop period for the delay path value. The following figure shows a
path of this type.
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Figure 2-5 Clock-to-Setup Path (Different Clocks)

Clock-to-setup paths do not propagate from the flip-flop Q output
through another flip-flop clock or asynchronous Set and Reset input
as shown in the next figure. These paths are also broken at bidirec-
tional pins.
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Figure 2-6 Not Propagating Through Asynchronous Set/Reset

Clock to Pad
A clock-to-pad path starts at a clock input of a flip-flop, propagates
through the flip-flop Q output and any number of levels of combina-
torial logic, and ends at an output pad. It includes the clock-to-Q
delay of the flip-flop and the path delay from that flip-flop to the chip
output. The clock-to-pad path time is the maximum time required for
the data to leave the source flip-flop, travel through logic and routing,
and leave the chip. When using the OFFSET constraint, the clock path
is also used in the path delay. The following figure illustrates a clock-
to-pad path, along with a timing diagram describing the path.
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Figure 2-7 Clock-to-Pad Path

Clock-to-pad paths also trace through the enable inputs of tristate
controlled pads, as shown in the next figure.
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Figure 2-8 Through Tristate Controlled Pads

Clock-to-pad paths do not propagate from the Q output of a flip-flop
through the clock of another flip-flop or asynchronous Set and Reset
input as shown in the following figure. These paths are also broken at
bidirectional pins.

Figure 2-9 Clock-to-Pad Path Broken Through Set/Reset Inputs
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Paths Ending at Clock Pin of Flip-Flops
A clock input path starts at either an input or an output of the chip. It
propagates through any number of levels of combinatorial logic and
ends at any clock pin on a flip-flip or latch enable. These paths do not
propagate through flip-flops. The clock input path time is the
maximum time required for the signal to arrive at the flip-flop clock
input. Clock input paths help to determine system-level design
timing. The next figure shows a clock input path.

The clock input time is the maximum time only; the Timing Analyzer
does not currently calculate minimum clock times.

Figure 2-10 Paths Ending at Clock Pin of Flip-Flops

Setup to Clock at the Pad
A setup-to-clock-at-the-pad path starts at an input pad, propagates
through input buffers and any number of levels of combinatorial
logic, and ends at a flip-flop D/T input, which includes the receiving
flip-flop’s tSU. This path does not propagate through flip-flops and is
also broken at bidirectional pins.

This delay reports tSU for data inputs relative to global or product
term clock inputs. It is calculated according to the following formula
for global and product term clocks.
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tSU = Pad to Setup - Path Ending at Clock Pin of Flip-
Flop

Global clock paths start at global clock pads, propagate through
global clock buffers and end at a flip-flop clock pin. Product term
clock paths start at input pads, propagate through a single level of
logic implemented in a clock product term, and end at the flip-flop
clock pin. All three clock-at-the-pad paths are shown in the next
figure.

Figure 2-11 Setup-to-Clock-at-the-Pad Path

Clock Pad to Output Pad
A clock-pad-to-output-pad path starts at input pads and trace
through all paths that include a flip-flop clock input (except when
that path includes a flip-flop asynchronous Set/Reset input) before
ending at an output pad. Clock-pad-to-output-pad paths trace
through tristate controlled pad enable inputs.

Pad to Pad
A pad-to-pad path starts at an input pad of the chip, propagates
through one or more levels of combinatorial logic, and ends at an
output pad of the chip. Combinatorial paths also trace through the
enable inputs of tristate controlled pads. The pad-to-pad path time is
the maximum time required for the data to enter the chip, travel
through logic and routing, and leave the chip. It is not controlled or
affected by any clock signal. A pad-to-pad path, along with a timing
diagram describing the path is displayed in the following figure.
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Figure 2-12 Pad-to-Pad Delay

Combinatorial paths are not traced through flip-flops. These paths
are also broken at bidirectional pins. A second representation is
shown in the next figure.

Figure 2-13 Pad-to-Pad Path
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A pad-to-setup path starts at an input pad of the chip, propagates
through input buffers and any number of combinatorial logic levels,
and ends at a D/T input to a flip-flop, latch, RAM, or the receiving
flip-flop’s tSU—wherever there is a setup time against a control
signal. Pad-to-setup paths do not propagate through flip-flops and
are broken at bidirectional pins. The pad-to-setup path time is the
maximum time required for the data to enter the chip, travel through
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logic and routing, and arrive at the output before the clock or control
signal arrives. A pad-to-setup path and timing diagram is shown in
the following figure.

Figure 2-14 Pad-to-Setup Path

Design Analysis Issues
The Timing Analyzer can help you resolve some of the most
frequently encountered design problems. This section describes these
solutions.
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Asynchronous feedback paths in a design can cause many paths to be
reported that may not actually be timing problems. The most
common cases are feedback paths through asynchronous Set or Reset
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To exclude specific nets that create feedback paths, such as an illegal-
state Reset logic loop for a state machine, you can use the Exclude
Paths with Nets command. It can exclude any paths that contain
those nets from the timing report.

With the Control Path Tracing command, you can control some asyn-
chronous points through logic; for example, you can exclude the
asynchronous Reset of a flip-flop or TBUF input to output.

Timing Constraints
If you entered timing constraints before compiling your design with
the mapper, you can use the Timing Analyzer to verify whether your
constraints were met. The following example of portions of a Design
Performance report shows how the Timing Analyzer finds paths that
did not meet timing constraints; five errors occurred and three
constraints were not met.

=========================================================================
Timing constraint: TS01 = MAXDELAY FROM TIMEGRP "FFS" TO TIMEGRP "FFS"
2000.000000 pS PRIORITY 0 ;
 1 item analyzed, 1 timing error detected.
 Maximum delay is   3.340ns.
-------------------------------------------------------------------------
Slack:    -1.340ns path $1N11 to $1N11 relative to
           2.000ns delay constraint

Path $1N11 to $1N11 contains 2 levels of logic:
Path starting from Comp: CLB.K (from $1N19)
To                   Delay type         Delay(ns)  Physical Resource
                                                   Logical Resource(s)
-------------------------------------------------  --------
CLB.XQ               Tcko                  1.830R  $1N11
                                                   $1N11
CLB.F2               net (fanout=2)     e  0.380R  $1N11
CLB.K                Tick                  1.130R  $1N11
                                                   $1N15
                                                   $1N11
-------------------------------------------------
Total (2.960ns logic, 0.380ns route)       3.340ns (to $1N19)
      (88.6% logic, 11.4% route)
.
.
.
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3 constraints not met.

Table of Timegroups:
-------------------
TimeGroup PADS:
BELs:
 OUT  D    C    CLR

TimeGroup FFS:
BELs:
 $1N11

Timing summary:
---------------

Timing errors: 5  Score: 15874

Constraints cover 5 paths, 0 nets, and 5 connections (100.0% coverage)

Design statistics:
   Maximum path delay from/to any node:  10.716ns

Analysis completed Wed Aug 27 14:29:35 1997
-------------------------------------------------------------------------

Clock Skew
The Timing Analyzer can report clock skew, which is the difference
between the time a clock signal arrives at the source flip-flop in a path
and the time it arrives at the destination flip-flop on the same clock
net. Clock skew occurs most often when global routing is not used to
route clock nets, because other routing is less predictable. The arrival
of clock signals at different times can affect the required clock period.
This section describes negative and positive clock skew and how the
Timing Analyzer reports clock skew.
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Negative Clock Skew

When the destination is clocked before the source, the clock skew is
called negative clock skew. Negative clock skew means that the clock
period must be longer than the path delay plus the amount of clock
skew between the flip-flops. Negative clock skew is illustrated in the
next figure.

Figure 2-15 Negative Clock Skew

Positive Clock Skew

When the source is clocked first, the clock skew is called positive
clock skew. Positive clock skew means that the clock period could be
shorter than the path delay by the minimum amount of clock skew.
Because the Timing Analyzer does not produce minimum numbers,
this shortened clock period is unreliable; do not depend on it. Posi-
tive clock skew is illustrated in the following figure.
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Figure 2-16 Positive Clock Skew

In Timing Analysis

The Timing Analyzer uses the timing constraints specified in the
Physical Constraints File (FPGAs) or the VM6 design file (CPLD); it
does not infer extra timing constraints. The Timing Analyzer
accounts for clock skew for all register to register paths. The
following example shows the clock skew portion of a Timing
Constraints report.

Slack: 12.667ns path SOURCE to DEST relative to
4.633ns total path delay

-2.300ns clock skew
15.000ns delay constraint

Path SOURCE to DEST contains 2 levels of logic:
Path starting from Comp: CLB_R14C13.K (from SIG_CLK)
To Delay type Delay(ns) Physical Resource

Logical Resource(s)
------------------------------------------------- --------
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CLB_R14C13.YQ Tcko 2.090R SOURCE
BEL_SOURCE.FFY

CLB_R14C14.C4 net (fanout=1) 1.533R DATA_SRC_DST
CLB_R14C14.K Tdick 1.010R DEST

BEL_DEST.FFY
-------------------------------------------------
Total (3.100ns logic, 1.533ns route) 4.633ns (to SIG_CLK)

(66.9% logic, 33.1% route)

You can use the Analyze → Query → Nets  command sequence to
generate a Query Nets report to display the clock skew across specific
clock nets. See the “Querying for Information” section of the “How to
Use the Timing Analyzer” chapter for the procedure to generate a
Query Nets Report, an example of a Query Nets Report, and informa-
tion on the report format.

Off-Chip Delay
To determine system-level clock speed, you must add any external
delay to paths that travel off-chip. This way, the Timing Analyzer
includes this external delay when calculating the delay for the path.
There is no default delay; the Timing Analyzer does not add off-chip
delay unless you specify it. See the XILINX Software Conversion Guide
from XACTstep v5.x.x to XACTstep vM1.x.x for information on how to
specify these delays with the OFFSET constraint in the UCF (User
Constraints File) file.
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Chapter 3

Getting Started

This chapter describes how to access and exit the Timing Analyzer;
how to use its menus, buttons, Console window, dialog boxes, and
filters within those dialog boxes; and how to use its online help
facility. It contains these sections.

• “Starting the Timing Analyzer” section

• “Timing Analyzer Window” section

• “Console Window” section

• “Dialog Boxes” section

• “Basic Timing Analysis Procedure” section

• “Obtaining Help” section

• “Exiting the Timing Analyzer” section

Starting the Timing Analyzer
The Timing Analyzer runs on PCs and workstations. On the PC, the
graphical user interface is based on Microsoft Windows. On the
workstation, the interface is based on OSF Motif.

You can start the Timing Analyzer from the Windows Program
Manager, the Xilinx Design Manager, or the command line.

From the Design Manager
To start the Timing Analyzer from the Design Manager window (PC
or workstation), click on the Timing Analyzer icon, shown in the
following figure. Or select the Tools → Timing Analyzer  menu
command.
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Stand-Alone Tool
If you installed the Timing Analyzer as a stand-alone tool on a PC,
click on the Timing Analyzer icon (shown in the previous figure) on
the Windows desktop or select timingan.exe from the Windows 95 or
Windows NT Start button.

From the Command Line
To start the Timing Analyzer from a UNIX command line, type the
following command.

timingan

These are three variations for starting the Timing Analyzer from the
command line.

• To run the tool as a background process, type the following.

timingan &

• To start the Timing Analyzer and open an existing FPGA or
CPLD design, type the following.

timingan { design_name.ncd| design_name.vm6} &

For FPGA designs, if a physical constraints file (PCF) exists in the
same directory as the design and has the same name, except for
the extension, that design_name.pcf  file is automatically opened.

• To start the tool, open an existing FPGA design and the corre-
sponding physical constraints file, type the following. Physical
constraints files only apply to FPGAs.

timingan design_name.ncd -pcf pcf_file_name.pcf &

Timing Analyzer Window
This section describes the Timing Analyzer’s main window, its
menus, toolbar, and status bar. You can execute Timing Analyzer
commands from the menus, toolbar, or the Console Window.
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When you start the application, the Timing Analyzer window
appears. The window contains pull-down menus and the toolbar at
the top, and the status bar at the bottom of the window. The menus
are described in the “Menus” section.

Note: When a design, report, or macro file is open and the active
window, the Edit menu is enabled; it is not visible otherwise. Also,
most of the toolbar buttons are not enabled unless a file is open and
active.

Figure 3-1 Timing Analyzer Window

The toolbar and status bar appear by default when you start the
Timing Analyzer. You can hide them from view by selecting the
Toolbar or the Status Bar commands, respectively, from the View
menu.

Menus
Most of the Timing Analyzer commands are available in the pull-
down menus. However, unless a design is loaded, most of the
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commands are disabled and therefore unavailable. Certain
commands and some command options are disabled and not avail-
able, depending whether the open design is an FPGA or a CPLD
design.

You can select menu commands with the mouse or the keyboard.
With the mouse, click the left mouse button on the desired command.
With the keyboard, press the Alt key and type in the letter underlined
in the menu for that command. When you select a menu command
with either method, a brief description of the command’s function
appears in the Status Bar at the bottom of the Timing Analyzer
window.

For complete command descriptions, select Help → Contents  or
see the “Menu Commands” chapter of this manual.

Toolbar
The toolbar appears at the top of the window, just below the menu
bar. The toolbar provides button access to frequently used commands
in the menus. Textual labels for the buttons appear when you move
the cursor arrow over a button. This feature is called a tool tip. Every
button has a tool tip. A longer description also appears in the status
bar. These buttons are shown and described in the “Toolbar” section
of the “Menu Commands” chapter.

Status Bar
By default, the status bar appears at the bottom of the window. When
you select a menu command, a brief description of the command’s
function appears in the status bar. As the Timing Analyzer processes,
status messages are dynamically updated and displayed.

To hide or show the status bar, select View → Status Bar .

Console Window
The Console window displays the sequence of commands that you
have used in a Timing Analyzer session. It is primarily used for
creating macros, but it has a command line field, in which you can
type and execute keyboard commands. The Console window also
contains a Show Command Status box that you can click on to
display or hide status messages. For information on creating and
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using macros, see the “Creating a Macro” section of the “How to Use
the Timing Analyzer” chapter.

Commands and their syntax that you can enter in the Console
window are described in the “Keyboard Commands” chapter.

You can open the Console window by selecting the Console
command from the View menu.

Dialog Boxes
Many Timing Analyzer menu commands display dialog boxes in
which you can enter information and set options. This section
describes dialog box common fields, how to move items in list boxes,
and how to use filters.

Common Fields
The following fields are common to many of the Timing Analyzer
dialog boxes.

• OK closes the dialog box and implements the intended action
according to the settings in the dialog box.

• Cancel closes the dialog box without effecting any action.

• Help displays information on that particular dialog box.

Moving Items in List Boxes
Many of the dialog boxes in the Timing Analyzer feature list boxes,
such as those shown below Nets Not Selected and Selected Nets in
the next figure. You can select and move items from one list box to
another using either the mouse or the keyboard, or a combination of
these methods.
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Figure 3-2 List Boxes Within a Dialog Box

Using the Mouse

Using the mouse, you can select items in list boxes with the following
methods.

• To move an item to a list box on the right, select it with the left
mouse button. Click the Add (>) button. To move an item to a list
box on the left, select it, then click the Remove (<) button.

• To move all items to a list box on the right, click the Add All (>>)
button. To move all items to a list box on the left, click the
Remove All (<<) button.

• To move sequential items, select the first one with the left mouse
button. Hold down the Shift key. Select the last item and release
the Shift key. Click the Add (>) or Remove (<) button to move the
selected items to the right or left list box, respectively.
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You can also select the first item then drag the mouse up or down
until all the desired items are highlighted and then click the Add
(>) or Remove (<) button.

• To move multiple items in any order, hold down the Control key
while clicking individual items. When finished selecting, release
the Control key and click the Add (>) or Remove (<) button.

Using the Keyboard

To navigate within dialog boxes using the keyboard, use these
methods.

• Use the Tab key to move to fields within dialog boxes.

• To move to previous fields within dialog boxes, press and hold
the Shift key, then press the Tab key.

• To scroll down the list box to select items that are not visible in
the list box, tab to the list box and hold down the down arrow
key until the item is highlighted.

• Pressing the Escape key closes the dialog box without effecting
any action (equivalent to clicking the Cancel button).

Using the keyboard, you can select items in list boxes with the
following methods.

Note: The Return (workstation)/Enter (PC) key is equivalent to the
OK button in the following procedures.

• To move an item in a list box, press the Tab key until the first item
in the list box is highlighted. Press the down arrow key to select
the desired item. Tab to the Add (>) or Remove (<) button to
move it to the right or left list box, respectively. Press Return.

• To move all items to a list box on the right, tab to the Add All (>>)
arrow and press Return. To move all items to a list box on the left,
tab to the Remove All (<<) button and press Return.

• To move consecutive items, tab to the first item in the list box.
Use the down arrow key to highlight the first desired item. Press
and hold the Shift key while using the down arrow key to select
the other items in the sequence. Tab to the Add (>) button. Press
Return.

• To move multiple items in any order, tab to the list box and press
Shift F8. Use the up and down arrow keys to navigate within the
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list box. Press the space bar to select each item. Tab to the Add (>)
button. Press the Return key. This method applies only to work-
stations.

Using Filters with Commands
Many Timing Analyzer menu commands have dialog boxes that
allow you to filter a list of choices, that is, display a subset of the
listed items. These dialog boxes contain a filter field and Apply and
Reset buttons, such as those below Filter for Nets Not to be Selected
in the “List Boxes Within a Dialog Box” figure. Applying filters with
commands produces more specific information in Timing Analyzer
reports.

This section describes valid filter inputs and wildcards, matching text
strings, and an example of how apply a filter in a menu command
dialog box.

Valid Inputs and Wildcards

In filter fields, you can enter a text string consisting of characters and
wildcards.

• Characters can be any alphanumeric characters, text spaces, and
the characters that appear on the top of the number keys on a
keyboard. Alphabetic characters are case-sensitive. No control
characters are permitted.

• A wildcard can be an asterisk (*), which can represent any
number of characters, or a question mark (?), which represents a
single character.

You cannot enter a range of items in filter fields.

Matching Text Strings

The Timing Analyzer does not strictly match patterns; it matches
entire text strings. It does not find a string if it is embedded in a larger
string, unless you use wildcards. For example, it does not find $1N36
if it is embedded in ABC$1N36XYZ. However, if you searched for
*$1N36*, it would find that string in ABC$1N36XYZ.
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Example Procedure

Following is a basic example of how to use filters and move items in
list boxes.

1. Select the Path Filters → Common Filters → Include
Paths with Nets  menu command.

The Include Paths with Nets dialog box appears and is shown in
the following figure. All the nets in the design are listed in the
Nets Not Selected list box.

Figure 3-3 Dialog Box Before Applying a Filter

2. Type BEL*  in the Filter for Nets Not to be Selected field.

When you enter text in the filter field, the Apply button is
enabled, as shown in the next figure.
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3. Click Apply .

Because the number of nets in the design can be cumbersome, as
shown in the following figure, applying a filter reduces the
number of nets displayed in the Nets Not Selected list box. Only
the nets whose names begin with BEL now appear in the list box.

To clear the filter, click Reset . Reset clears the filter and restores
all items to the left list box that are not in the right list box. You
can also backspace over the information in the filter text box, but
to affect the list box, you must then click on Apply or Reset.

Figure 3-4 Dialog Box After Applying a Filter
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4. Move BEL_CHX* from the Nets Not Selected list box to the
Selected Nets list box, using the methods described in the
“Moving Items in List Boxes” section.

If you are only interested in nets BEL_CHX_OUTSEL0.H through
BEL_CHX_RS422EN-.F, in this analysis, this step moves those
nets to the Selected Nets list box, as illustrated in the following
figure.

Figure 3-5 Nets Included in Analysis

Basic Timing Analysis Procedure
The typical procedure for using the Timing Analyzer is as follows.

1. Open the Timing Analyzer and load a design.

For FPGAs, if a physical constraints file (PCF) with the same
name as the design exists in the directory, the Timing Analyzer
also loads that file, by default. (The PCF file is generated when a
design is mapped.)
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2. If you are unfamiliar with the Timing Analyzer, explore its
features. You can use the online help facility to help you with this
process. To run the online help, select Help → Contents .

3. You can optionally generate a report to obtain a basic overview of
the design’s timing before you begin to analyze it in detail. The
Design Performance report provides that information. Choose
the Design Performance command from the Analyze menu to
generate a Design Performance report and display it.

4. Select commands from the Path Filters menu to determine which
types of paths to analyze and report. You can filter out paths you
are not interested in.

5. Select commands from the Options menu to change the speed
grade for analysis or format reports.

6. Choose the kind of report you want from the Analyze menu.

7. Use the File and Edit menu commands to view the report in more
detail, save the report, or print it.

8. Optionally, you can create macros comprising the commands just
issued.

These steps are all described in the “How to Use the Timing
Analyzer” chapter. Steps 2, 3, 4, and 5 are optional.

Obtaining Help
You can obtain help on the Timing Analyzer’s commands and proce-
dures by selecting commands in the Help menu, by selecting the
Help button in the toolbar, by clicking the Help button in dialog
boxes, or by pressing the F1 key. The Help button in the toolbar, the
ones contained in some menu command dialog boxes, and the F1 key
provide context-sensitive help for what you click on or that dialog
box, respectively. Context-sensitive help is discussed in “Context-
Sensitive Help” section.

Help Menu
The Help menu contains the following commands.

• Contents lists the online help topics available for the Timing
Analyzer. From the opening screen, you can jump to command
information or step-by-step instructions for using the Timing
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Analyzer. After you start the help, you can click the Contents
button (first button in the top-left corner) in the Help window
whenever you want to return to the help topic list.

• About Timing Analyzer displays a pop-up window that displays
the version number of the Timing Analyzer software.

Context-Sensitive Help
You can obtain context-sensitive help on the Timing Analyzer by
using the Help button in the toolbar or the Help button contained in
many menu command dialog boxes. This section describes both
methods of how to access the context-sensitive help.

Toolbar Button

To access context-sensitive help from the toolbar follow this proce-
dure.

1. Click on the Help button from the toolbar, shown in the following
figure.

The cursor changes to an arrow and question mark, like the
button.

2. For help on menu commands, click (with the left mouse button)
on the menu, then click the command in that menu or submenu.
For help on toolbar buttons, click once on the particular button.

The Timing Analyzer displays information about the selected
command or button.

Help Button in Dialog Boxes

Many of the dialog boxes associated with Timing Analyzer menu
commands have a Help button, such as that shown in the lower right
corner of the next figure. You can click on the button to obtain help on
that dialog box. A window opens that displays the information.
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Figure 3-6 Help Button in Dialog Box

F1 Key

Pressing the F1 key when the cursor is placed on a dialog box
displays help on that dialog box. Pressing the F1 key is the same
as selecting the Help Topics command from the Help menu, if no
dialog boxes are displayed.

Exiting the Timing Analyzer
To exit the Timing Analyzer, click File → Exit . Another method is
to type exit at the prompt in the Console window.

If you have unsaved reports open, a prompt box similar to that in the
next figure appears.
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Figure 3-7 Exit Prompt Box

Click Yes  to save the report, then follow the procedure described in
the “Saving a Report” section of the “How to Use the Timing
Analyzer” chapter.
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Chapter 4

How to Use the Timing Analyzer

This chapter describes all the functions that you can perform with the
Timing Analyzer. It contains the following main sections.

• “Opening a Design” section

• “Opening a Physical Constraints File” section

• “Viewing Settings” section

• “Viewing Clocks” section

• “Querying for Information” section

• “Creating Reports” section

• “Specifying Report Appearance and Content” section

• “Changing the Speed Grade” section

• “Using Path Filtering Commands” section

• “Using the Console Window” section

• “Using Macros” section

Note: The commands and dialog boxes in this chapter are used in the
context of procedures, but they are not explained in detail. For a
detailed explanation of them, see the “Menu Commands” chapter.

Opening a Design
Before you can create a timing report using the Timing Analyzer, load
a mapped NCD (FPGA) or a completed placed and routed VM6
(CPLD) design file. The NCD (FPGA) can be mapped, placed, or
routed. To open a design for timing analysis, follow these steps.

1. Select File → Open Design , or click on the Open Design
toolbar button.
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The Open Design dialog box appears, as shown in the “Open
Design Dialog Box” figure of the “Menu Commands” chapter.

2. In the Look in/Directories list box, click on the directory
containing the NCD (FPGA) or VM6 (CPLD) file to load.

3. Under Files of Type/List Files of Type, click on the pull-down the
list box and select FPGA Designs (*.ncd) or CPLD Designs
(*.vm6).

All the available NCD or VM6 files are displayed in the list box.

4. Select an NCD or a VM6 file from the list box, or type the name in
the field below File Name. (*.ncd appears by default; backspace
over the asterisk before typing in the design file name.)

5. Click OK.

The Timing Analyzer reads the design, the device information,
and processes any timing constraints, then loads the design. For
FPGA designs, the Timing Analyzer also reads the .pcf physical
constraints file with the same name as the design file, if one exists
in the same directory as the design file; the PCF file contains
physical constraints information. The order of the constraints in
the PCF file is reflected by the Timing Analyzer.

When the design is loaded, the path name and design file name
appear at the top of the Timing Analyzer window.

You can now create a timing report. Refer to the “Creating Reports”
section for instructions on this procedure.

Warning: If you open design when another design is open, the
Timing Analyzer resets the current settings to the defaults. If you re-
open a design that is already open, the Timing Analyzer also resets
the current settings to the defaults and opens the default PCF, if it is
exists.

Opening a Physical Constraints File
Physical Constraints Files (PCF) contain physical constraint informa-
tion. They apply only to FPGAs, because CPLD timing information is
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contained in the (VM6) design file itself. The order of the timing
constraints in the PCF file is reflected by the Timing Analyzer. To
open a physical constraints file, follow these steps.

1. Select Open Physical Constraints from the File menu.

The Open Physical Constraints dialog box appears.

2. In the Look in/Directories list box, click on the directory
containing the PCF file to load.

3. Under Files of Type/List Files of Type, Physical Constraints
(*.pcf) is the default and the only file type you can select.

All the available PCF files are displayed in the list box.

4. Select a PCF file from the list box, or type the name in the field
below File name. (*.pcf appears by default; backspace over the
asterisk before typing in the physical constraints file name.)

5. Click OK.

The Timing Analyzer reads the .pcf file and the path name
appears on the right side of the status bar at the bottom of the
Timing Analyzer window.

Alternate Methods
This section describes two alternate methods for opening a physical
constraints file.

Automatic

Similar to selecting File → Open Physical Constraints , select
File → Open Design . If a physical constraints file with the same
name as the design file exists in the same directory as the design file,
it is automatically loaded with the design. A message similar to the
following appears on the right side of the status bar at the bottom of
the Timing Analyzer window.

/export/home/mistral/deborah/ta/designs/test10.pcf

If there is no physical constraints file in the same directory with the
same name, a message box appears with a message similar to the
following.

No default Physical Constraints File found for design
"/export/home/mistral/deborah/ta/designs/test10.ncd"
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Manual

1. Select Open from the File menu.

The Open dialog box appears.

2. Under Files of Type/List Files of Type, select All Files (*.).

3. Select a PCF file from the list box, or type it in the field below File
Name.

4. Click OK.

The PCF file is displayed in a window and the path name appears on
the right side of the status bar at the bottom of the Timing Analyzer
window.

Viewing Settings
To view current Timing Analyzer settings, select View → Settings .

The Timing Analyzer displays a pop-up window with the current
settings and options. The following figure displays an example of the
Settings window.

Figure 4-1 Settings Window

When this window is the active window and you change an option
setting or a path filter, the change is immediately reflected in the
window. If it is not the active window and you change an option or a
filter, you must click inside the Settings window to update it auto-
matically.
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The contents of the window can be saved as a .xtm file to save the
settings as a macro to return the system to the same state as when the
settings were saved. See the “Saving a New Macro” and the
“Running a Macro” sections for more information. You can also save
the contents of the window to a .twr file. TWR files are listed as
Timing Analysis Reports (*.twr) under List Files of Type in File menu
command dialog boxes. See the “Saving a Report” section for the
procedure to save a report.

Viewing Clocks
The Clocks report lists the names of all of the clocks in the design. To
generate a Clocks report, select View → Clocks . The Timing
Analyzer displays the Clocks report in a pop-up window. You can
save the contents of the window as a (.twr) file. TWR files are listed as
Timing Analysis Reports (*.twr) under List Files of Type in File menu
command dialog boxes. See the “Saving a Report” section for the
procedure to save a report.

Querying for Information
You may want to focus on the source, destination, and timing of a
particular net or time group. You can obtain information about the
timing of particular nets or the members of a time group using the
Query command. This command only applies to FPGAs; it is
disabled if a CPLD design is open.

To perform a query, follow this procedure.

1. Select Analyze → Query .

The Query dialog box appears, as shown in the “Query Dialog
Box” figure of the “Menu Commands” chapter.

2. Select the subject of the query by clicking on Nets or TimeGroups.
Nets is the default.

The following information is generated for each option.

• Nets — The Timing Analyzer shows the fanout, the timing
from the source CLB to each of the destination CLBs, and the
CLB names in the generated Query Nets Report.
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• TimeGroups — The Timing Analyzer lists the elements in the
specified timing groups in the generated Query TimeGroups
Report.

The other fields in the dialog box change to Nets or TimeGroups
with your selection.

3. If you select Nets, enter a value in the Delay Greater Than field of
the Filter for Available Nets/TimeGroups section, if desired. This
field is disabled if you select TimeGroups.

The Delay Greater Than value specifies a minimum net delay in
nanoseconds. The Timing Analyzer displays only those paths
that have a delay greater than or equal to the specified value.

4. Enter a filter in the other portion of the Filter for Available Nets/
TimeGroups section, if desired, and click Apply .

If you enter a value in the Delay Greater Than and a filter in the
filter field, the Timing Analyzer lists the nets that meet both
criteria. See the “Using Filters with Commands” section of the
“Getting Started” chapter for valid filter inputs.

5. Select the nets or timing groups that you want to query from the
Available Nets/TimeGroups list box and move specific ones or all
of them to the Selected Nets/TimeGroups list box.

See the “Moving Items in List Boxes” section of the “Getting
Started” chapter for details on selecting and moving items
between list boxes.

6. Click OK.

The Timing Analyzer displays the Query Nets/TimeGroups Report
in a pop-up window, which can be saved as a TWR file. Nets/
TimeGroups is Nets or TimeGroups, corresponding with your
selection in step 2. See the “Saving a Report” section for the
procedure to save a report.

Query Nets Report
The following is an example of Query Nets Report.

M-- $1N15 ................ $1I37.O................ 4.0 $1N6.F4
                                               $1I45.O 4.0 $1N6.F4

--- $1N32 ................ C.I2................... 2.0 $1I45.T
                                                   2.0 $1N6.F3
4-6 Xilinx Development System



How to Use the Timing Analyzer
--- $1N34 ................ D.I2................... 1.0 $1N6.F1

--- $1N6 ................. $1N6.X................. 1.0 O1.O
                                                   1.0 O2.O

--- $1N51 ................ A1.I2.................. 0.0 $1I45.I

--- $1N38 ................ B.I2................... 2.0 $1I37.T

--- $1N41 ................ A.I2................... 2.0 $1I37.I

The contents of the Query Nets Report example have been placed in
the following table to illustrate the format of the report. Connections
are listed by net, then by source; each is only listed once. Explana-
tions of the information in Net Characteristics and Delay columns
follow the table.

Net Characteristics

The entries in the Net Characteristics column are comprised of three
characters. The characters indicate aspects of the net(s) you query.

Table 4-1 Query Nets Report Format

Net
Characteristics

Net Name
Driver Pin

Name
Delay Value Load Pin Name

M-- $1N15 $1I37.O 4.0 $1N6.F4

$1I45.O 4.0 $1N6.F4

--- $1N32 C.I2 2.0  $1I45.T

2.0 $1N6.F3

--- $1N34 D.I2 1.0 $1N6.F1

--- $1N6 $1N6.X 1.0 O1.O

1.0 O2.O

--- $1N51 A1.I2 0.0 $1I45.I

--- $1N38 B.I2 2.0 $1I37.T

--- $1N41 A.I2 2.0 $1I37.I
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Each character position is independent of the others. The character
position and values of each position are illustrated in this table.

Delay Value

The entries in the Delay Value column can include asterisks (*), ques-
tion marks (?), or tildes (~).

• The pin is unrouted or one or both pins are not yet placed if three
asterisks (***) appear as the delay value. An asterisk preceding a
number, *3 for example, indicates the connection delay is esti-
mated, if timing analysis is performed on an unrouted design.
Because the Timing Analyzer can perform timing analysis on
mapped FPGA designs, generating a Query Nets report can
determine if a design does not meet timing requirements before a
design is routed.

• A question mark (?) indicates the net was routed incorrectly.

• A tilde (~) preceding a delay value indicates that the delay value
is approximate. The delay can be longer than estimated.

Query Time Groups Report
The Query Time Groups report lists the contents of each time group
that you select. Time group information is also generated in the
Timing Constraints Analysis report.

Creating Reports
After you load a design file, you can decide what kind of report you
want to generate. This section describes how to create all the reports
available in the Timing Analyzer as well as how to save and print
them.

Left = Net Source Middle = Net Load Right = If Critical

S = No Source L = No Load C = Net marked with
CRITICAL property
in the design or Net
PRI is ≥ 10

M = Multiple Sources - = Not Critical
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With the Find command on the Edit menu, you can search for specific
text strings in reports. Directions for this procedure are given in the
“Searching for Text in a Report” section.

The Timing Analyzer has default settings that you can change using
filters with various commands. Filters modify the scope of generated
reports by specifying which paths you want to analyze. For more
information, refer to the “Using Path Filtering Commands” section.
To view the current settings, refer to the “Viewing Settings” section.

Timing Analysis
The Timing Analysis report compares the design’s performance to
the timing constraints.

To generate a Timing Analysis report, select Analyze → Timing
Constraints , or click on the Analyze Timing Constraints button in
the toolbar.

This command has an interrupt function when analyzing FPGA
designs. A Timing Analysis in Progress dialog box with an Abort
button appears.

Clicking the Abort button, the Esc key, or the Enter/Return key
aborts the analysis. A report is not generated or displayed.

After processing the design, the Timing Analyzer displays the Timing
Analysis report in a pop-up window. The contents of the window can
be saved as a TWR file; see the “Saving a Report” section for the
procedure to save a report. An example of a Timing Analysis report is
shown following.

-------------------------------------------------------------------------
Timing Analyzer M1.4.7
Copyright (c) 1995-1997 Xilinx, Inc.  All rights reserved.
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Design file:              C:\designs\loop.ncd
Physical constraint file: C:\designs\loop.pcf
Device,speed:             xc4036ex,-3 (x1_0.08 3.7f )
Report level:             verbose report, limited to 1 item per constraint
-------------------------------------------------------------------------

=========================================================================
Timing constraint: TS01 = MAXDELAY FROM TIMEGRP "FFS" TO TIMEGRP "FFS"
2000.000000 pS PRIORITY 0 ;
 1 item analyzed, 1 timing error detected.
 Maximum delay is   3.340ns.
-------------------------------------------------------------------------
Slack:    -1.340ns path $1N11 to $1N11 relative to
           2.000ns delay constraint

Path $1N11 to $1N11 contains 2 levels of logic:
Path starting from Comp: CLB.K (from $1N19)
To                   Delay type         Delay(ns)  Physical Resource
                                                   Logical Resource(s)
-------------------------------------------------  --------
CLB.XQ               Tcko                  1.830R  $1N11
                                                   $1N11
CLB.F2               net (fanout=2)     e  0.380R  $1N11
CLB.K                Tick                  1.130R  $1N11
                                                   $1N15
                                                   $1N11
-------------------------------------------------
Total (2.960ns logic, 0.380ns route)       3.340ns (to $1N19)
      (88.6% logic, 11.4% route)

-------------------------------------------------------------------------

========================================================================
Timing constraint: TS02 = MAXDELAY FROM TIMEGRP "PADS" TO TIMEGRP "FFS"
1500.000000 pS PRIORITY 0 ;
 3 items analyzed, 3 timing errors detected.
 Maximum delay is   4.006ns.
-------------------------------------------------------------------------
Slack:    -2.506ns path D to $1N11 relative to
           1.500ns delay constraint

Path D to $1N11 contains 2 levels of logic:
Path starting from Comp: IOB.PAD
To                   Delay type         Delay(ns)  Physical Resource
                                                   Logical Resource(s)
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-------------------------------------------------  --------
IOB.I1               Tpid                  1.810R  D
                                                   D
                                                   $1N13
CLB.F1               net (fanout=1)     e  1.066R  $1N13
CLB.K                Tick                  1.130R  $1N11
                                                   $1N15
                                                   $1N11
-------------------------------------------------
Total (2.940ns logic, 1.066ns route)       4.006ns (to $1N19)
      (73.4% logic, 26.6% route)

-------------------------------------------------------------------------

=========================================================================
Timing constraint: TS03 = MAXDELAY FROM TIMEGRP "FFS" TO TIMEGRP "PADS"
2500.000000 pS PRIORITY 0 ;
 1 item analyzed, 1 timing error detected.
 Maximum delay is  10.716ns.
-------------------------------------------------------------------------
Slack:    -8.216ns path $1N11 to OUT relative to
           2.500ns delay constraint

Path $1N11 to OUT contains 2 levels of logic:
Path starting from Comp: CLB.K (from $1N19)
To                   Delay type         Delay(ns)  Physical Resource
                                                   Logical Resource(s)
-------------------------------------------------  --------
CLB.XQ               Tcko                  1.830R  $1N11
                                                   $1N11
IOB.O                net (fanout=2)     e  1.066R  $1N11
IOB.PAD              Tops                  7.820R  OUT
                                                   OUT.OUTBUF
                                                   OUT
-------------------------------------------------
Total (9.650ns logic, 1.066ns route)      10.716ns
      (90.1% logic, 9.9% route)

-------------------------------------------------------------------------

3 constraints not met.

Table of Timegroups:
-------------------
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TimeGroup PADS:
BELs:
 OUT  D    C    CLR

TimeGroup FFS:
BELs:
 $1N11

Timing summary:
---------------

Timing errors: 5  Score: 15874

Constraints cover 5 paths, 0 nets, and 5 connections (100.0% coverage)

Design statistics:
   Maximum path delay from/to any node:  10.716ns

Analysis completed Wed Aug 27 14:29:35 1997
-------------------------------------------------------------------------

You can use the following path filtering commands to modify the
Timing Analysis report.

• Report Paths Failing Timing Constraints (Path Filters Menu)

• Report Paths Not Covered by Timing Constraints (Path Filters
Menu)

• Disable Timing Constraints (Path Filters Menu)

• Include Paths with Nets (Path Filters Menu)

• Exclude Paths with Nets (Path Filters Menu)

• Control Path Tracing (Path Filters Menu)

Design Performance
The Design Performance report provides a set of summary statistics
for the paths from the timing requirements submitted for analysis. To
generate a Design Performance report, select Analyze → Design
4-12 Xilinx Development System



How to Use the Timing Analyzer
Performance , or click on the Analyze Design Performance button in
the toolbar.

This command has an interrupt function when analyzing FPGA
designs. A Timing Analysis in Progress dialog box with an Abort
button appears.

Clicking the Abort button, the Esc key, or the Enter/Return key
aborts the analysis. A report is not generated or displayed.

After processing the design, the Timing Analyzer displays the Design
Performance report in a pop-up window. The contents of the window
can be saved as a TWR file; see the “Saving a Report” section for the
procedure to save a report. An example of an FPGA Design Perfor-
mance report is shown following.

-------------------------------------------------------------------------
Timing Analyzer M1.4.7
Copyright (c) 1995-1997 Xilinx, Inc.  All rights reserved.

Design file:              C:\designs\loop.ncd
Physical constraint file: C:\designs\loop.pcf
Device,speed:             xc4036ex,-3 (x1_0.08 3.7f )
Report level:             error report, limited to 1 item per constraint
-------------------------------------------------------------------------

=========================================================================
Timing constraint: TS01 = MAXDELAY FROM TIMEGRP "FFS" TO TIMEGRP "FFS"
2000.000000 pS PRIORITY 0 ;
 1 item analyzed, 1 timing error detected.
 Maximum delay is   3.340ns.
-------------------------------------------------------------------------
Slack:    -1.340ns path $1N11 to $1N11 relative to
           2.000ns delay constraint
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Path $1N11 to $1N11 contains 2 levels of logic:
Path starting from Comp: CLB.K (from $1N19)
To                   Delay type         Delay(ns)  Physical Resource
                                                   Logical Resource(s)
-------------------------------------------------  --------
CLB.XQ               Tcko                  1.830R  $1N11
                                                   $1N11
CLB.F2               net (fanout=2)     e  0.380R  $1N11
CLB.K                Tick                  1.130R  $1N11
                                                   $1N15
                                                   $1N11
-------------------------------------------------
Total (2.960ns logic, 0.380ns route)       3.340ns (to $1N19)
      (88.6% logic, 11.4% route)

-------------------------------------------------------------------------

=========================================================================
Timing constraint: TS02 = MAXDELAY FROM TIMEGRP "PADS" TO TIMEGRP "FFS"
1500.000000 pS PRIORITY 0 ;
 3 items analyzed, 3 timing errors detected.
 Maximum delay is   4.006ns.
-------------------------------------------------------------------------
Slack:    -2.506ns path D to $1N11 relative to
           1.500ns delay constraint

Path D to $1N11 contains 2 levels of logic:
Path starting from Comp: IOB.PAD
To                   Delay type         Delay(ns)  Physical Resource
                                                   Logical Resource(s)
-------------------------------------------------  --------
IOB.I1               Tpid                  1.810R  D
                                                   D
                                                   $1N13
CLB.F1               net (fanout=1)     e  1.066R  $1N13
CLB.K                Tick                  1.130R  $1N11
                                                   $1N15
                                                   $1N11
-------------------------------------------------
Total (2.940ns logic, 1.066ns route)       4.006ns (to $1N19)
      (73.4% logic, 26.6% route)

-------------------------------------------------------------------------

=========================================================================
Timing constraint: TS03 = MAXDELAY FROM TIMEGRP "FFS" TO TIMEGRP "PADS"
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2500.000000 pS PRIORITY 0 ;
 1 item analyzed, 1 timing error detected.
 Maximum delay is  10.716ns.
-------------------------------------------------------------------------
Slack:    -8.216ns path $1N11 to OUT relative to
           2.500ns delay constraint

Path $1N11 to OUT contains 2 levels of logic:
Path starting from Comp: CLB.K (from $1N19)
To                   Delay type         Delay(ns)  Physical Resource
                                                   Logical Resource(s)
-------------------------------------------------  --------
CLB.XQ               Tcko                  1.830R  $1N11
                                                   $1N11
IOB.O                net (fanout=2)     e  1.066R  $1N11
IOB.PAD              Tops                  7.820R  OUT
                                                   OUT.OUTBUF
                                                   OUT
-------------------------------------------------
Total (9.650ns logic, 1.066ns route)      10.716ns
      (90.1% logic, 9.9% route)

-------------------------------------------------------------------------

3 constraints not met.

Table of Timegroups:
-------------------
TimeGroup PADS:
BELs:
 OUT  D    C    CLR

TimeGroup FFS:
BELs:
 $1N11

Timing summary:
---------------

Timing errors: 5  Score: 15874

Constraints cover 5 paths, 0 nets, and 5 connections (100.0% coverage)
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Design statistics:
   Maximum path delay from/to any node:  10.716ns

Analysis completed Wed Aug 27 14:30:42 1997
-------------------------------------------------------------------------

The format of a CPLD Design Performance report differs from the
FPGA report format. An example portion is shown following.

                       Performance Summary Report
                       --------------------------

Design:     tspec1d
Device:     XC9572-7-PC84
Program:    Timing Report Generator Version Internal-M1.0.0a
Date:       Thu Oct 17 10:41:18 1996

Timing Analysis Options:

From: All
To:   All

Speed Grade:                        -7

Selected Path Types:

External
--------
Pad to Pad -                      Pad to pad combinatorial propagation
                                    delay. Paths through PRE/CLR register
                                  inputs are not reported.

Clock Pad to Output Pad -         Clock pad(global or product term
                                  clock) to output pad propagation
                                  delay.

Setup to Clock at Pad -           Setup time of data at PAD to clock at
                                  PAD. This parameter is only reported
                                  for global clocks and product term
                                     clocks driven directly from input pads

Internal
--------
Clock to Setup -                  Register to register cycle time.

Pad to Setup -                    Data path delay from PAD to register
                                  data input. Includes register tSU.
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Clock to Pad -                    Delay from register clock input to
                                  output pad.

Path Ending at Clock Pin of FFs - Clock path delay from clock
                                  pad(global or product term) to
                                  register clock input.

Other Options:
Report Only Longest Paths between Points: True

Performance Summary:

Worst case Pad to Pad path delay  :     9.0ns (1 macrocell levels)
 (Includes an external input margin of 0.0ns.)
 (Includes an external output margin of 0.0ns.)
Pad ‘X19’ to Pad ‘Y1’

-------------------------------------------------------------------------
                Combinational Pad to Pad Delays(nsec)

\ From        B    B    C    C    X    X    X    X   X    X    X    X
 \                 B         C    0    1    1    1   1    1    1    1
  \                                         0    1   2    3    4    5
   \
    \
     \
      \
    To \---------------------------------------------------------------

Y1          7.5     7.5         7.5  7.5  7.5  7.5  7.5  7.5  7.5 7.5
Y2                              7.5  7.5  7.5  7.5  7.5  7.5  7.5 7.5
Y3              9.0      9.0
Y4

-------------------------------------------------------------------------

               Combinational Pad to Pad Delays(nsec)

\ From        X    X    X    X    X    X    X    X    X    X    X    X
 \            1    1    1    1    2    3    4    5    6    7    8    9
  \           6    7    8    9
   \
    \
     \
      \
    To \----------------------------------------------------------------

Y1          7.5  7.5  9.0  9.0  7.5  7.5  7.5  7.5  7.5  7.5  7.5 7.5
Y2                              7.5  7.5  7.5  7.5  7.5  7.5  7.5 7.5
Y3
Y4
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.

You can use the following path filtering commands to modify the
scope of the Design Performance report.

• Report Paths Failing Timing Constraints (Path Filters Menu)

• Report Paths Not Covered by Timing Constraints (Path Filters
Menu)

• Disable Timing Constraints (Path Filters Menu)

• Include Paths with Nets (Path Filters Menu)

• Exclude Paths with Nets (Path Filters Menu)

• Control Path Tracing (Path Filters Menu)

All Paths
The All Paths report displays a detailed analysis of all specified
paths. It contains the worst-case path delays for all paths that are not
filtered out.

To generate an All Paths report, select Analyze → All Paths , or
click on the Analyze All Paths button in the toolbar.

This command has an interrupt function when analyzing FPGA
designs. A Timing Analysis in Progress dialog box with an Abort
button appears.

Clicking the Abort button, the Esc key, or the Enter/Return key
aborts the analysis. A report is not generated or displayed.
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After processing the design, the Timing Analyzer displays the All
Paths report in a pop-up window. The contents of the window can be
saved as a TWR file; see the “Saving a Report” section for the proce-
dure to save a report. An example is shown following.

-------------------------------------------------------------------------
Timing Analyzer M1.4.7
Copyright (c) 1995-1997 Xilinx, Inc.  All rights reserved.

Design file:              C:\designs\loop.ncd
Device,speed:             xc4036ex,-3 (x1_0.08 3.7f )
Report level:             verbose report, limited to 1 item per constraint
-------------------------------------------------------------------------

=========================================================================
Timing constraint: PATH "PATHFILTERS" = FROM TIMEGRP "SOURCES" TO TIMEGRP
"DESTINATIONS" ;
 5 items analyzed, 0 timing errors detected.
 Maximum delay is  10.716ns.
-------------------------------------------------------------------------
Delay:    10.716ns $1N11 to OUT

Path $1N11 to OUT contains 2 levels of logic:
Path starting from Comp: CLB.K (from $1N19)
To                   Delay type         Delay(ns)  Physical Resource
                                                   Logical Resource(s)
-------------------------------------------------  --------
CLB.XQ               Tcko                  1.830R  $1N11
                                                   $1N11
IOB.O                net (fanout=2)     e  1.066R  $1N11
IOB.PAD              Tops                  7.820R  OUT
                                                   OUT.OUTBUF
                                                   OUT
-------------------------------------------------
Total (9.650ns logic, 1.066ns route)      10.716ns
      (90.1% logic, 9.9% route)

-------------------------------------------------------------------------

All constraints were met.

Table of Timegroups:
-------------------
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TimeGroup SOURCES:
BELs:
 $1N11  OUT    D      C      CLR

TimeGroup DESTINATIONS:
BELs:
 $1N11  OUT    D      C      CLR

Timing summary:
---------------

Timing errors: 0  Score: 0

Constraints cover 5 paths, 0 nets, and 5 connections (100.0% coverage)

Design statistics:
   Maximum path delay from/to any node:  10.716ns

Analysis completed Wed Aug 27 14:31:19 1997
-------------------------------------------------------------------------

You can use the following path filtering commands to modify the
scope of the All Paths report.

• Select Sources (Path Filters Menu)

• Select Destinations (Path Filters Menu)

• Include Paths with Nets (Path Filters Menu)

• Exclude Paths with Nets (Path Filters Menu)

• Control Path Tracing (Path Filters Menu)

Saving a Report
Follow this procedure to save a generated report as a file.

1. Make sure the report that you want to save is the active window
by clicking on it. The active window has a colored border.

2. Select File → Save , or click the Save button.
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The Timing Analyzer displays the Save As dialog box, illustrated
in the “Save As Dialog Box” figure of the “Menu Commands”
chapter.

3. Under List Files of Type, click on the down arrow to display the
pull-down list box of available file types. Highlight Timing Anal-
ysis Reports (*.twr) to select it. File names of that format appear
in the list box below the File Name field.

4. In the File Name field, type in the name of the file in which to
store the report. Add a .twr extension to the file name.

If this is the first time you are saving the file, the Timing Analyzer
provides a default name corresponding with the type of informa-
tion contained in the window (timing constraints, clocks, and so
forth).

If you want to overwrite an existing file with the new report, click
on that file name in the list box, so it appears in the File Name
field.

You can use word processor applications to open and edit the
report file.

5. In the Save in field/Directories list box, select the directory in
which you want to save the report.

6. Click OK.

The Save As dialog box closes.

Searching for Text in a Report
You can use the Find command to search for any text string in the
active report window, including normal grammatical symbols like
hyphens or underscores. You cannot search for special characters like
tabs or hard returns, however.

To search for a text string in a report, do the following.

1. Open or select the report window in which you want to search.

2. Select Edit → Find .
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The Find dialog box appears, as shown in the “Find Dialog Box”
figure of the “Menu Commands” chapter.

3. Enter the text string that you want to search for in the Find What
field.

4. You can optionally match the case of the search string by
selecting Match Case. Then only instances that have the same
case as the text string will be found. By default, case is ignored.

5. Indicate the search direction.

• Up searches backward from the present location of the cursor
to the beginning of the report. Searching stops at the begin-
ning of the report.

• Down searches forward from the present location of the
cursor to the end of the report. Searching stops at the end of
the report. This direction is the default.

6. Click the Find Next button, the F3 key, or select Edit → Find Next
to find the next instance of the text string.

7. Click Cancel  to close the Find dialog box.

Printing a Report
You can send a Timing Analyzer report to your default printer, or you
can send it to a printer that you specify.

Note: Print dialog boxes vary between platforms and window oper-
ating systems. The procedure in this section is basic; consult your
specific system documentation for details.

To send a report to the default printer, follow these instructions.

1. Select File → Print , or click the Print button.

The Timing Analyzer displays the Print dialog box, shown in the
“Print Dialog Box” figure of the “Menu Commands” chapter.

2. If you want to print more than one copy, enter the number of
copies that you want to print in the Copies field.
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3. If you want to print a range of pages, enter “From” and “To”
pages in the corresponding boxes.

4. If you want to print to a file, select Print to File.

5. Click OK.

Closing a Report
To close a report, use one of the following methods.

Using Menu Commands

Select File → Close .

If the report has been previously saved, the window closes. If it has
not been saved, the Save As dialog box appears; see the “Saving a
Report” section for the procedure to save a report.

Using the Mouse

Make sure the report that you want to close is the active window by
clicking on it. The active window will have a colored border.

1. Click on the horizontal bar in the upper left-hand corner of the
report pop-up window.

A pop-up menu appears.

2. Select Close  from the menu.

The following prompt box appears.

3. Click Yes  to save the report window.

The Save As dialog box appears; see the “Saving a Report”
section for the procedure to save a report. If you click No, the
dialog box and report window both close without saving. If you
click Cancel, the dialog box closes and the report window
remains open.
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Using the Keyboard

Make sure the report that you want to close is the active window by
clicking on it. The active window will have a colored border.

1. Type Ctrl F4  from the keyboard.

The following prompt box appears.

2. Click Yes  to save the report.

The Save As dialog box appears; see the “Saving a Report”
section for the procedure to save a report. If you click No, the
dialog box and report window both close without saving. If you
click Cancel, the dialog box closes and the report window
remains open.

Opening a Saved Report
You can open a previously saved report to view or print by following
these steps.

1. Select File → Open.

The Open dialog box appears, as shown in the “Open Dialog
Box” figure of the “Menu Commands” chapter.

2. In the Look in/Directories list box, click on the directory
containing the report file to load.

3. In the List Files of Type field, select Timing Analysis Reports
(*.twr) is selected. The default is Timing Analysis Macros (*.xtm).

All the available report files are displayed in the list box (below
the File Name field).

4. Select a report file from the list box, or type the name in the field
below File Name after backspacing over the asterisk. If you do
not specify a file extension, the Timing Analyzer loads an XTM
(macro) file by default.
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5. Click OK.

Specifying Report Appearance and Content
By default, the Timing Analyzer analyzes and reports on all paths in a
design. However, you can determine the appearance and the content
of the reports that the Timing Analyzer generates.

Perform the steps described in the following sections to customize
generated reports. Each section describes a report output option you
can specify.

1. Select Options → Report Options .

The Timing Analyzer displays the Report Options dialog box,
shown in the “Report Options Dialog Box” figure of the “Menu
Commands” chapter.

The following table lists each option in the dialog box and indi-
cates if the option is available for FPGA or CPLD designs.

2. After specifying all desired report options, click OK.

The Report Options dialog box closes. You can now select addi-
tional filtering commands or generate a Timing Analysis report,
as described in the “Timing Analysis” section.

Creating a Summary Report
This option only applies to FPGAs; it is disabled if a CPLD design is
open.

To generate a summary report, select Summary Report Only in the
Report Options dialog box. A summary report contains only the path

Option FPGA CPLD

Summary Report Only Yes No

Maximum Paths per Timing Constraint Yes Yes

Report Delays Less Than No Yes

Report Delays Greater Than No Yes

Sort On No Yes

Report Only Longest Paths Between Points No Yes

Wide Report Yes Yes
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source and end point. It lists one delay path per line and does not
display cumulative delays.

Setting the Maximum Number of Paths Per Timing
Constraint

To limit the total number of paths per timing constraint that the
Timing Analyzer reports, enter a value in the Maximum Number of
Paths per Timing Constraint field in the Report Options dialog box.
For FPGAs, the default is 1 path per timing constraint. For CPLDs,
the default is unlimited. Not specifying a value turns the limit Off.

You can use this option with the criterion you specify in the Sort On
field when generating an All Paths report. For example, if you enter
10 in the Maximum Number of Paths per Timing Constraint field and
set the Sort On option to Descending Delay, the Timing Analyzer
reports the 10 paths with the longest delay.

You can optionally use a keyboard command to set this option.

1. Select View → Console .

2. In the field at the bottom of the Console window, type the
following.

MaxPathsPerTimingConstraint number_of_paths

You can use this keyboard command in a macro.

Reporting Delays Less Than a Value
This option only supports analysis of CPLD designs; it is disabled if
an FPGA design is open.

To instruct the Timing Analyzer to report only those paths that have a
delay less than or equal to the specified value, enter a value, in nano-
seconds in the Report Delays Less Than field of the Report Options
dialog box. Make the field blank to include paths regardless of how
large the delays are.

Reporting Delays Greater Than a Value
This option only supports analysis of CPLD designs; it is disabled if
an FPGA design is open.
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You can instruct the Timing Analyzer to report only those paths that
have a delay greater than or equal to the specified value. To do so,
enter a value, in nanoseconds, in the Report Delays Greater Than,
field of the Report Options dialog box.

Sorting Path Report Order
This option only supports analysis of CPLD designs; it is disabled if
an FPGA design is open.

You can specify how the Timing Analyzer sorts path types when they
are reported. To specify how paths are sorted, click on the down
arrow next to the Sort On field in the Report Options dialog box, and
select a path type. See the “Report Options (Options Menu)” section
of the “Menu Commands” chapter for descriptions of these delay
path types.

• Ascending Delay

• Descending Delay

• Source Net

• Destination Net

• Source Clock Net

• Destination Clock Net

Reporting Only Longest Paths Between Points
This option only supports analysis of CPLD designs; it is disabled if
an FPGA design is open.

If there is more than one path between two end points, you can direct
the Timing Analyzer to report only the path with the longest delay.
Select Report Only Longest Paths Between Points in the Report
Options dialog box.

Generating Wide Reports
By default, the Timing Analyzer generates a report formatted with 80
characters per line. To generate a wide report, select Wide Report.
Wide reports have 132 characters per line. They help reduce the
number of truncated net names, since names are truncated to 132
characters instead of 80 characters as in a default report.
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Changing the Speed Grade
The speed grade is usually set during the design implementation
process. Changing the speed grade helps you determine if you need
to target a faster device to meet your timing requirements, or if using
a slower speed grade still meets timing constraints.

Note: Changing the speed grade with the Timing Analyzer only
affects analysis. The speed grade in the design file is not changed.

To change the speed grade for timing analysis, perform the following
steps.

1. Select Options → Speed Grade .

The Set Speed Grade dialog box appears, as shown in the “Set
Speed Grade Dialog Box” figure of the “Menu Commands”
chapter.

2. Select a speed grade from the list of available speed grades using
one of the following methods.

• Using the mouse, click on the down arrow and select a speed
grade from the pull-down list.

• Using the keyboard, tab until the speed grade is highlighted,
and press the up or down arrow keys until the desired speed
grade appears.

3. Click OK.

The Set Speed Grade dialog box closes. You can now select addi-
tional filtering commands or generate a report.

Using Path Filtering Commands
By default, the All Paths Analysis reports the path delays for all paths
in the design. However, you can instruct the Timing Analyzer to
analyze and report on a subset of paths by using commands in the
Path Filters menu and it submenus.

The Path Filters menu consists of three submenus: Timing Constraint
Filters, Path Analysis Filters, and Common Filters, and the Reset All
Path Filters command. The types of commands contained in these
submenus are described in the “Path Filtering Commands” section of
the “Introduction” chapter. Also, see the “Specifying Report Appear-
4-28 Xilinx Development System



How to Use the Timing Analyzer
ance and Content” section for information on report format and
general content customizing.

After using these commands to specify specific paths and applying
filters, you can generate reports using the commands in the Analyze
menu. Refer to the “Creating Reports” section for more information
on report generation.

The procedures in the following sections often direct you to specify a
filter in a dialog box or to move items between list boxes. Refer to the
“Using Filters with Commands” section and the “Moving Items in
List Boxes” section of the “Getting Started” chapter for detailed
instructions on specifying a filter and on selecting and moving items
between list boxes.

Timing Constraint Filters
If your design contains timing constraints, you can choose commands
presented in this section to specify the scope of the information
contained in the Timing Analysis and Design Performance reports.
They all exist in the Timing Constraints submenu of the Path Filters
menu and function only if a design is loaded. These commands do
not alter the Design Performance report or the All Paths report.

Reporting Paths that Fail Timing Constraints

You can instruct the Timing Analyzer to generate a report containing
only the paths that do not meet your timing constraints. After
opening a design, select Path Filters → Timing Constraint
Filters → Report Paths Failing Timing Constraints . A
box appears to the left of the menu item to indicate that the item is
selected. Now you can generate a Timing Analysis report, as
described in the “Timing Analysis” section, or select additional path
filtering commands.

Reporting Paths with No Timing Constraints

You can include paths without timing constraints, in addition to
paths with timing constraints, in analysis. After opening a design,
select Path Filters → Timing Constraint Filters →
Report Paths Not Covered by Timing Constraints . A box
appears to the left of the menu item to indicate that the item is
selected. Now you can generate a Timing Analysis report, as
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described in the “Timing Analysis” section, or select additional path
filtering commands.

Disabling Timing Constraints

To prevent the Timing Analyzer from analyzing specified timing
constraints, perform the following steps.

1. Select Path Filters → Timing Constraint Filters →
Disable Timing Constraints .

The Disable Timing Constraints dialog box appears, as shown in
the “Disable Timing Constraints Dialog Box” figure of the “Menu
Commands” chapter.

Note: If an FPGA design is open, Include User Constraints is selected
by default. Click the Omit User Constraints radio button, if you want
to include user constraints during analysis. User constraints are
contained in the “USER” section of the PCF. These two buttons and
their functions are only visible and available for FPGAs.

2. Enter a filter in the Filter for Enabled Timing Constraints field to
display a subset of timing constraints, if desired, and click Apply .

The subset of timing constraints is displayed in the Enabled
Constraints list box. See the “Using Filters with Commands”
section of the “Getting Started” chapter for valid filter inputs.

3. Select the timing constraints you want to exclude from the
Timing Analysis report in the Enabled Constraints list box and
move specific ones or all of them to the Disabled Constraints list
box.

See the “Moving Items in List Boxes” section of the “Getting
Started” chapter for instructions on moving items between list
boxes.

4. Click OK.

The Disable Timing Constraints dialog box closes. You can now
select another command or generate a Timing Analysis report.

Path Analysis Filters
You can select starting points and ending points using commands
described in this section to specify the scope of path analysis informa-
tion reported in the All Paths report. These commands exist in the
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Path Analysis Filters submenu of the Path Filters menu. By default,
the Timing Analyzer selects all sources and all destinations for path
analysis.

Selecting Sources

Sources can be flip-flops, pads, clocks, nets, pins, CLBs, or all types.
To select specific sources for path analysis, follow these steps.

1. Select Path Filters → Path Analysis Filters →
Select Sources .

The Select Sources dialog box appears, as shown in the “Select
Sources Dialog Box” figure of the “Menu Commands” chapter.

2. Click the Selected Sources radio button. (All Sources is selected
by default.)

3. Select the source type by clicking the down arrow of the Source
Element Type pull-down list box to display the list of sources,
then highlight it. The default is Flip-Flops.

FPGA source types can be flip-flops, pads, nets, pins, CLBs, or
clocks. CPLD source types can be flip-flops, pads, nets, macro-
cells, or clocks.

Element in the Filter for Element Not to be Selected field and the
Source Element list box changes to match the source type you
select.

4. If you select Clocks, indicate in the source clock edge by clicking
the down arrow and highlighting the selection in the Clock Edge
field. Clocks are only supported for FPGA designs. These are the
Clock Edge options.

• Rising or Falling (either clock edge)

• Rising

• Falling

5. Enter a filter in the Filter for Element Not to be Selected field to
display a subset of the specified source type, if desired, and click
Apply . See the “Using Filters with Commands” section of the
“Getting Started” chapter for valid filter inputs.
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6. Select the sources you want to include in Timing Analysis from
the Source Element list box and move specific ones or all of them
to the Selected Sources list box.

See the “Moving Items in List Boxes” section of the “Getting
Started” chapter for instructions on moving items between list
boxes.

7. Repeat steps 3 through 6 until you have moved all the desired
types elements to the Selected Sources list box.

8. Click OK.

The Select Sources dialog box closes. You can now select another
path filtering command or generate a timing report.

Selecting Destinations

Destinations can be flip-flops, pads, clocks, nets, pins, CLBs, or all
types. To select specific destinations for path analysis, follow this
procedure.

1. Select Path Filters → Path Analysis Filters →
Select Destinations .

The Select Destinations dialog box appears, as the “Select Desti-
nations Dialog Box” figure of the “Menu Commands” chapter
illustrates.

2. Click the Selected Destinations radio button. (All Destinations is
selected by default.)

3. Select the ending point type by clicking the down arrow of the
Destination Element Type pull-down list box to display the list of
destinations, then highlight it. The default is Flip-Flops.

FPGA destination types can be flip-flops, pads, nets, pins, CLBs,
or clocks. CPLD destination types can be flip-flops, pads, nets,
macrocells, or clocks.

Element in the Filter for Element Not to be Selected field and the
Destination Element list box changes to match the destination
type you select.

4. If you select Clocks, indicate in the destination clock edge by
clicking the down arrow and making a selection in the Clock
Edge field. Clocks are only supported for FPGA designs. These
are the Clock Edge options.
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• Rising or Falling (either clock edge),

• Rising

• Falling

5. Enter a filter in the Filter for Element Not to be Selected field to
display a subset of the specified destination type, if desired, and
click Apply .

See the “Using Filters with Commands” section of the “Getting
Started” chapter for valid filter inputs.

6. Select the destinations you want to include in Path Analysis from
the Destination Element list box and move specific ones or all of
them to the Selected Destinations list box.

See the “Moving Items in List Boxes” section of the “Getting
Started” chapter for instructions on moving items between list
boxes.

7. Repeat steps 3 through 6 until you have moved all the desired
types of elements to the Selected Destinations list box.

8. Click OK.

The Select Destinations dialog box closes. You can now select
another path filtering command or generate a timing report.

Common Filters
You can include or exclude paths with nets or control path tracing
using commands described in this section to specify the scope of
timing analysis. These commands exist in the Common Filters
submenu of the Path Analysis menu.

Although the Include Paths with Nets and Exclude Paths with Nets
commands in the Common Filters submenu appear to be similar, they
are not mutually exclusive. For example, you might want to exclude
any path that goes through the synchronous Reset net of the counter
but include all paths that go through bit 1 of the counter. By using the
Exclude Paths with Nets command to exclude the synchronous Reset,
and the Include Paths with Nets command to include paths through
the bit 1, you can include or exclude specific nets that are attached to
the counter.
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After using the path filtering commands in the Common Filters
submenu, you can generate a Timing Analysis, a Design Perfor-
mance, or an All Paths report.

Including Paths with Nets

Use the Include Paths with Nets command to limit analysis to paths
that contain specified nets. If a net is not selected, paths through that
net are not analyzed. However, if no nets are selected, which is the
default, all paths, except those subject to other filtering commands,
are analyzed. To select nets to be included for analysis, use this proce-
dure.

1. Select Path Filters → Common Filters → Include
Paths with Nets .

The Include Paths with Nets dialog box appears, as shown in the
“Include Paths with Nets Dialog Box” figure of the “Menu
Commands” chapter.

2. Enter a filter in the Filter for Nets Not to be Selected field to
display a subset in the Nets Not Selected list box, if desired, and
click Apply .

See the “Using Filters with Commands” section of the “Getting
Started” chapter for valid filter inputs.

3. Select the nets that you want to include in your timing analysis
from the Nets Not Selected list box and move specific ones or all
of them to the Selected Nets list box.

See the “Moving Items in List Boxes” section of the “Getting
Started” chapter for instructions on moving items between list
boxes.

4. Click OK.

The Include Paths with Nets dialog box closes. You can now
select another path filtering command or generate a timing
report.

Excluding Paths with Nets

Use the Exclude Paths with Nets command to exclude paths
containing specific nets from analysis, regardless of which paths are
specified in the Include Paths with Nets command or other filters. If a
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net is selected, paths through that net are not analyzed. The default
does not exclude any nets from analysis. To exclude specific nets from
analysis, use this procedure.

1. Select Path Filters → Common Filters → Exclude
Paths With Nets .

The Exclude Paths with Nets dialog box appears, as shown in the
“Exclude Paths with Nets Dialog Box” figure of the “Menu
Commands” chapter.

2. Enter a filter in the Filter for Nets Not to be Selected field to
display a subset in the Nets Not Selected list box, if desired, and
click Apply .

See the “Using Filters with Commands” section of the “Getting
Started” chapter for valid filter inputs.

3. Select the nets that you want to exclude from your timing anal-
ysis from the Nets Not Selected list box and move specific ones or
all of them to the Selected Nets list box.

See the “Moving Items in List Boxes” section of the “Getting
Started” chapter for instructions on moving items between list
boxes.

4. Click OK.

The Exclude Paths with Nets dialog box closes. You can now
select another path filtering command or generate a timing
report.

Controlling Path Tracing

Use the Control Path Tracing command to enable or disable path
analysis through delay path types for specific components, such as
latches, RAMs, and TBUFs. These paths may be irrelevant to your
analysis.

Note: This command only applies to FPGAs; it is disabled if a CPLD
design is open. (CPLD path timing analysis ignores paths through
Set/Reset logic and breaks paths at birdirectional I/O pins.)

After specifying which path types to control through which compo-
nents, you can generate the Timing Analysis, Design Performance, or
All Paths report. Use the following procedure to specify path types
through components for path analysis.
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1. Select Path Filters → Common Filters → Control Path
Tracing .

The Timing Analyzer displays the Control Path Tracing dialog
box, illustrated in the “Control Path Tracing Dialog Box” figure of
the “Menu Commands” chapter.

2. Select the path type that you want to control from the Path Type
pull-down list box. Click on the down arrow, then highlight one
of the path types. The following types are available; see the
“Control Path Tracing (Path Filters Menu)” section of the “Menu
Commands” chapter for details on these path types.

• Asynchronous Set/Reset to Output

• Data to Output for Transparent Latch

• RAM Data to Output

• RAM WE (Write Enable) to Output

• TBUF Tristate Control to Output

• TBUF Input to Output

• I/O Pad to Input

• I/O Tristate Control to Pad

• Bidirectional Tristate I/O Output to Input

• I/O Output to Pad

The Timing Analyzer displays all components that use the speci-
fied path type in the Enabled Components or Disabled Compo-
nents list box, corresponding with the default of that path type.
The path type default is the state when you initially open a
design or use the Reset All Path Filters command.

3. Enter a filter in the Filter for Enabled/Disabled Components field
to display a subset of components of the specified type, if desired,
and click Apply .

The Filter for Enabled/Disabled Components changes to match the
default state of the path type. See the “Using Filters with
Commands” section of the “Getting Started” chapter for valid
filter inputs.
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4. Select the components that you want to enable or disable by
moving them from the Enabled Components to the Disabled
Components list box or vice versa.

See the “Moving Items in List Boxes” section of the “Getting
Started” chapter for instructions on moving items between list
boxes.

5. Click OK.

The Control Path Tracing dialog box closes. You can now select
another filtering command or generate any timing report.

Resetting Path Filters to Defaults
You can reset all of the path filters to the design default settings. After
opening a design, select Path Filters → Reset All Path
Filters . To then view those default settings, select View →
Settings .

Using the Console Window
The Console window records all the commands that you have used in
a Timing Analyzer session. You can use these commands to form
macros, as described in the “Creating a Macro” section. In addition, it
provides an alternative to using some menu commands by allowing
you to enter commands from the keyboard.

Executing a Command
To execute a command in the Console window, follow these steps.

1. To open the Console window, select View → Console .

The Console window appears, as shown in the “Console
Window” figure of the “Menu Commands” chapter.

Note: You cannot delete text from within the Console window.

2. You can add a command manually by typing it in the field at the
bottom of the window below the Show Command Status box.
Use the syntax given for the command in the “Keyboard
Commands” chapter. After you enter the command and press the
Return key, the command is executed and is reflected in the
Console window.
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Re-Executing Commands
If you want to re-execute a command shown in the Console window,
you can use one of the following three methods in the field at the
bottom of the window below the Show Command Status box.

• Type two exclamation points (!!) to repeat the last command.

• Type an exclamation point (!) and the number of the command
that appears to the left of the command in the Console window.

• Type in an exclamation point (!) and the first letter or first few
letters of the command.

• Use the up or down arrow keys to move to the command, select
it, and press the Return key.

With all these methods, the Timing Analyzer starts the search from
the bottom of the command list.

To see if the system issued a response to the command, such as an
error or warning message, click the Show Command Status  box.

Using Macros
A macro command is a script file for running Timing Analyzer
commands and options. You can create a macro, save it in a new file,
the same file, or another existing file, and run it in the Console
window. The Timing Analyzer records all commands executed
during the current session.

Creating a Macro
To create a macro, perform the following steps.

1. Select View → Console  to open the Console window.

Alternatively, you can create or edit a macro manually or create
one by entering keyboard commands in a text file.

2. From the menus, select the commands that will constitute the
macro or type keyboard commands in the field at the bottom of
the window.

These commands are recorded in the Console window numeri-
cally. See the “Keyboard Commands” chapter for listings,
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descriptions, syntax, abbreviations, and examples of keyboard
commands.

3. Select File → New Macro  or click the New Macro button, in the
upper left corner of the Timing Analyzer window.

A New Macro window appears.

4. In the Console window, hold down the left mouse button and
highlight the sequence of commands that will constitute the
macro.

5. Click the Copy Button.

6. Position the cursor in the New Macro window and click the Paste
Button and located just to the right of the Copy Button on the
toolbar.

The lines from the Console window are pasted into the New
Macro window.

You can also highlight, copy, and paste individual lines from the
Console window to the New Macro window.

You can add text in the New Macro window by inserting the
cursor and typing. Delete text by pressing the backspace key or
by highlighting and pressing the Delete key.

7. Save the new macro by following the instructions in the “Saving
a New Macro” section.

Saving a New Macro
To save a new macro, follow these steps.
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1. Make sure the macro that you want to save is the active window
by clicking on it. The active window has a colored border.

2. Select File → Save , or click the Save button.

The Save As dialog box, appears as shown in the “Save As Dialog
Box” figure of the “Menu Commands” chapter.

3. In the Look in/Directories list box, select the directory in which
you want to save the macro.

4. In the List Files of Type field, make sure that Timing Analysis
macros (*.xtm) is selected. (File names of that format appear in
the list box below the File Name field).

A default name corresponding with the type of information
contained in the window (timing constraints, clocks, and so
forth), with a .xtm extension appears in the File Name field.

5. In the File Name field, type in a name for your new macro.

You must save the macro in a file with a .xtm extension.

6. Click OK.

The Save As dialog box closes. You can use word processor appli-
cations to open and edit the report file.

Running a Macro
Follow these instructions to run an existing macro.

1. Select File → Open.

The Open dialog box appears as shown in the “Open Dialog Box”
figure of the “Menu Commands” chapter.

2. In the Look in/Directories list box, select the directory in which
the macro file is located.

3. Timing Analysis Macros (*.xtm), the default, is listed in the List
Files of Type field. If not, select it from the pull-down list box.

4. In the File Name field, backspace over the asterisk and type in the
name of the macro file that you want to open. Alternatively, click
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on the name of the XTM file in the list box below the File Name
field.

5. Click OK.

The Open dialog box closes, and the macro window opens and
remains active.

6. Select File → Run Macro , or click the Run Macro Button.

Editing a Macro
You can also edit an existing macro.

1. Select File → Open.

The Open dialog box appears and is shown in the “Open Dialog
Box” figure of the “Menu Commands” chapter.

2. In the Look in/Directories list box, select the directory in which
the macro file is located.

3. In the List Files of Type field, select Timing Analysis Macros
(*.xtm) from the pull-down list box, if it is not.

4. In the File Name field, backspace over the asterisk and type in the
name of the macro file that you want to open. Alternatively, click
on the name of the XTM file in the list box below the File Name
field.

5. Click OK.

The Open dialog box closes, and the macro window opens and
remains active.

6. Edit the macro, using the information in the “Creating a Macro”
section to add, delete, copy, and paste commands in the macro
window.

7. If you want to save the edited macro in the same file, select File
→ Save , or click the Save button.
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If you have saved the macro once, the Save command saves the
macro in the existing file without activating the Save As dialog
box.

If you want to save the edited macro to another file, follow the
instructions in the “Saving an Edited Macro to a New File”
section.

Overwriting an Existing Macro
If you want to save an edited macro in the same file, follow these
steps.

1. Make sure the macro that you want to save is the active window
by clicking on it or opening the macro file.

2. Select File → Save , or click the Save button.

The Save As dialog box appears as shown in the “Save As Dialog
Box” figure of the “Menu Commands” chapter.

3. In the Look in/Directories list box, select the directory in which
the existing macro is located.

4. In the List Files of Type field, make sure that Timing Analysis
macros (*.xtm) is selected. (File names of that format appear in
the list box below the File Name field).

5. In the File Name field, type in a name of the existing macro, or
click on that file name in the list box below the File Name field.

6. Click OK.

The Timing Analyzer displays a prompt box asking if you want
to overwrite the existing file, as shown in the following figure.
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Saving an Edited Macro to a New File
Follow this procedure to save an edited macro to another file.

1. Make sure the macro that you want to save is the active window
by clicking on it or opening the macro file.

2. Select File → Save , or click the Save button.

The Save As dialog box appears, as shown earlier in “Save As
Dialog Box” figure of the “Menu Commands” chapter.

3. In the Look in/Directories list box, select the directory in which
you want to save the macro.

4. In the List Files of Type field, make sure that Timing Analysis
macros (*.xtm) is selected. (File names of that format appear in
the list box below the File Name field).

A default name corresponding with the type of information
contained in the window (timing constraints, clocks, and so
forth), with a .xtm extension appears in the File Name field.

5. In the File Name field, type in a name for new macro.

You must save the macro in a file with a .xtm extension.

6. Click OK.

The Save As dialog box closes. You can use word processor appli-
cations to open and edit the report file.
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Suppressing Informational Messages
When you run a macro, the commands in the macro file can generate
informational, confirmational, and error messages. However, you can
suppress the informational and confirmational messages by using the
following procedure. You cannot suppress these messages while
executing menu commands. This command does not have an equiva-
lent menu command.

1. Open a design, as described in the “Opening a Design” section.

2. Select View → Console .

The Console window appears.

3. In the field at the bottom of the Console window, below Show
Command Status, type in the following command.

SetForce on

If you did not open a design the Timing Analyzer displays the
following message.

4. If you are creating a new macro or editing an existing one, follow
the procedure in the “Creating a Macro” section, inserting the
SetForce on  command when you want to suppress messages.
(For example, after opening a design.)

5. Select File → Run Macro , or click the Run Macro Button.

6. To restore the informational and confirmational messages, type
the following command in the Console window.

SetForce off
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Menu Commands

This chapter lists and describes all the commands available in the
menus of the Timing Analyzer window, except for the Edit menu.
The Edit menu contains the: Cut, Copy, Paste, Find, and Find Next
commands which are common to many graphical tools. This chapter
contains these sections.

• “Menus” section

• “Commands” section

• “Toolbar” section

For a description of the fields that are common to many Timing
Analyzer dialog boxes, such as OK and Cancel, see the “Status Bar”
section of the “Getting Started” chapter.

Menus
The Timing Analyzer has eight menus, seven of which are described
in the following sections.

File Menu
The File menu contains commands that load designs, physical
constraints files, and macros. Commands that save and print reports
on designs, and exit the Timing Analyzer. The commands on the File
menu are the following.

New Macro Creates new macro

Open Design Loads design (NCD for FPGA, VM6 for
CPLD) and default physical constraints file
(FPGA only) for timing analysis
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Edit Menu
The Edit menu is visible and enabled only if a design, macro, or
report window is open.

View Menu
The View menu contains commands that control the appearance of
Timing Analyzer window.

Open Physical
Constraints

Loads file (PCF)

Open Loads report (TWR) or macro (XTM) files

Close Closes active file

Save Saves report, and macro files

Save As Saves file in active window to another file

Run Macro Runs specified macro

Print Sends file in active window to default printer

Recent Design Lists last four opened design files

Exit Exits the Timing Analyzer

Cut Cuts selected text

Copy Copies selected text

Paste Pastes cut or copied text

Find Finds specified text

Find Next Finds next occurrence of specified text

Toolbar Displays or hides toolbar

Status Bar Displays or hides status bar

Console Displays or hides Console window

Clocks Displays or hides clocks in the active design

Settings Displays or hides current command settings
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Analyze Menu
The Analyze menu contains commands that generate timing analysis
reports according to current Timing Analyzer commands and option
settings.

Path Filters Menu
The Path Filters menu contains three submenus which contain
commands that enable you to select a subset of information when
generating a timing report.

Timing Constraints Generates the Timing Analysis report
using current PCF

Design Performance Generates Design Performance
report

All Paths Generates All Paths report of anal-
ysis of all specified paths

Query Displays timing information about
net delays or time groups

Timing
Constraint Filters
Submenu

Report Paths
Failing Timing
Constraints

Reports only paths that
do not meet timing
constraints

Report Paths Not
Covered by Timing
Constraints

Reports paths with no
timing constraints (in
addition to paths with
timing constraints)

Disable Timing
Constraints

Omits specified timing
constraints from analysis

Path Analysis
Filters Submenu

Select Sources Defines path starting
points

Select Destinations Defines path ending
points

Common Filters
Include Paths with
Nets

Includes specific paths
in analysis
Timing Analyzer Reference/User Guide 5-3



Timing Analyzer Reference/User Guide
Options Menu
The Options menu contains commands that you can use to change
the speed grade for analysis and report options.

Window Menu
The Window menu contains commands that control the placement of
the windows on the main screen.

Help Menu
The Help menu contains commands that enable you to access online
help for the Timing Analyzer.

Commands
The following commands are available in the menus of the Timing
Analyzer’s graphical user interface.

Exclude Paths with
Nets

Excludes specific paths
from analysis

Control Path
Tracing

Controls tracing through
specified components

Reset Path Filters Resets path filters
to default settings

Speed Grade Changes speed grade for analysis

Report Options Determines format and content of
reports

Cascade Arranges open windows diagonally

Tile Arranges open windows in rows

Arrange Icons Arranges icons in row at bottom of the
Timing Analyzer window

Contents Lists online help topics

About Timing Analyzer Shows current software version
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About Timing Analyzer (Help Menu)
The About Timing Analyzer command displays a pop-up window
that displays the version number of the Timing Analyzer software.

All Paths (Analyze Menu)
The All Paths command generates the All Paths report, which
contains a detailed analysis of all specified paths and includes the
worst-case path delays for all paths in the design. Filters from the
Path Analysis Filters and Common Filters submenus are applied
during analysis to generate this report.

You can use the following path filtering commands to modify the
scope of this report.

• Select Sources (Path Filters Menu)

• Select Destinations (Path Filters Menu)

• Include Paths with Nets (Path Filters Menu)

• Exclude Paths with Nets (Path Filters Menu)

• Control Path Tracing (Path Filters Menu)

Arrange Icons (Window Menu)
The Arrange Icons command arranges the Timing Analyzer window
icons in a row along the bottom of the window.

Cascade (Window Menu)
The Cascade command arranges the open windows diagonally down
the screen so that they overlap one another, as shown in the next
figure. The active window is on top.
Timing Analyzer Reference/User Guide 5-5



Timing Analyzer Reference/User Guide
Figure 5-1 Cascaded Windows

Clocks (View Menu)
The Clocks command creates the Clocks report, which lists the names
of all clocks in the design.

Close (File Menu)
The Close command closes the active report, macro, or design file.

Common Filters Submenu (Path Filters Menu)
Common Filters is a submenu in the Path Filters menu, which
contains the following filtering commands that can be used to
generate Timing Analysis, Design Performance, and All Paths
reports.

• Include Paths with Nets (Path Filters Menu)

• Exclude Paths with Nets (Path Filters Menu)

• Control Path Tracing (Path Filters Menu)
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Refer to the alphabetical listings of these commands for an explana-
tion of their functions.

Console (View Menu)
The Console command displays the Console window, shown in the
next figure, which records all the commands that you have used in a
Timing Analyzer session.

Figure 5-2 Console Window

Note: You cannot delete text from the Console window.

You can add a command manually by typing it in the field at the
bottom of the window, below the Show Command Status box. Use
the syntax for the command listed in the “Keyboard Commands”
chapter of this manual. After you enter the command and press the
Return key, the command is executed and is reflected in the Console
window.

If you want to re-execute a command shown in the Console window,
you can use one of the following four methods in the field at the
bottom of the window.

• Use the up or down arrow keys to move to the command, and
press the Return key.

• Type an exclamation point (!) and the number of the command.

• Type an exclamation point (!) and the first letter or first few letters
of the command name.

• Type two exclamation points (!!) repeats the last command.
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With all of these methods, the Timing Analyzer starts the search for
the command from the last executed command in the list.

When you click on the Show Command Status box, the Timing
Analyzer displays any responses to a command, such as an error or
warning message.

Contents (Help Menu)
The Contents command lists the online help topics available for the
Timing Analyzer. From the opening screen, you can jump to
command information or step-by-step instructions for using the
Timing Analyzer. After you open help, you can click the Contents
button (first button on the left) in the Timing Analyzer Help window
when you want to return to the help topic list.

Pressing the F1 key is the same as selecting the Contents command, if
no dialog boxes are displayed.

Control Path Tracing (Path Filters Menu)
The Control Path Tracing command controls path tracing through
RAM, tristate buffers, input and output pins, and Set/Reset logic.
These paths may be irrelevant to your analysis. This command
appears in the Common Filters submenu.

Note: This command only applies to FPGAs; it is disabled if a CPLD
design is open. (CPLD path timing analysis ignores paths through
Set/Reset logic and breaks paths at bidirectional I/O pins.)

Use this command in conjunction with any of the following reports.

• Timing Analysis report, which compares the implementation of
the design to the XACT-Performance constraints

• Design Performance report, which indicates overall design
performance

• All Paths report, which contains detailed timing information for
all paths in the design

It displays the Control Path Tracing dialog box, shown in the next
figure.
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Figure 5-3 Control Path Tracing Dialog Box

This dialog box contains these fields.

• Path Type specifies paths that the Timing Analyzer can trace. The
paths can be the following.

• Asynchronous Set/Reset to Output enables path tracing
through CLB flip-flop asynchronous Set or Reset outputs. By
default, the Timing Analyzer does not analyze these paths.

• Data to Output for Transparent Latch enables path tracing
from the latch D input to the Q output. By default, the Timing
Analyzer does not analyze these paths.

• RAM Data to Output enables path tracing through the data
inputs of a CLB RAM. By default, the Timing Analyzer does
not analyze these paths.
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• RAM WE to Output disables path tracing through the write-
enable input of a CLB RAM. By default, the Timing Analyzer
analyzes these paths.

• TBUF Tristate Control to Output disables tracing of paths
that pass through a T pin to the O pin. By default, the Timing
Analyzer analyzes these paths.

• TBUF Input to Output disables path tracing from the input
pin to the output pin of a TBUF. By default, the Timing
Analyzer analyzes these paths.

• I/O Pad to Input disables path tracing from the pad pin to
the input pin of an IOB. By default, the Timing Analyzer
analyzes these paths.

• I/O Tristate Control to Pad disables path tracing from the
tristate control pin of an IOB to the pad. By default, the
Timing Analyzer analyzes these paths.

• Bidirectional Tristate I/O Output to Input disables tracing of
paths that pass from the IOB O pin to the pad and back into
the chip through the IOB I pin. By default, the Timing
Analyzer analyzes these paths, but is disabled for tristate
IOBs.

• I/O Output to Pad disables path tracing from the output pin
of an IOB to the pad pin. By default, the Timing Analyzer
analyzes these paths.

If you select a path type, the Timing Analyzer displays all compo-
nents of that type in the Enabled Components or the Disabled
Components list box, depending on the default state of that path
type. In the “Control Path Tracing Path Types” table, the Abbrevi-
ation column lists path type abbreviations as they appear in the
Physical Constraints File (PCF). The Path Type column textually
describes the path type. The Default column refers to the default
state of the path type.

Table 5-1 Control Path Tracing Path Types

Abbreviation Path Type Default

reg_sr_q Asynchronous Set/Reset to Output Disabled

lat_d_q Data to output for transparent latch Disabled

ram_d_o RAM data to output Disabled
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• Filter for Enabled/Disabled Components filters the components
that the Timing Analyzer traces paths through to those you
specify.

• Apply removes the components that do not match the filter
from the Enabled Components or Disabled Components list
box.

• Reset deletes the filter and redisplays all components with
the Path Type default state, except those you excluded with
other filters and commands in the Enabled Components or
Disabled Components list box.

• Enabled Components — if you have not applied a filter, Enabled
Components lists all the components for which tracing of the
selected path type is enabled. If you applied a filter, this “filtered”
list displays components that have path tracing enabled.
However, some of the enabled components may be hidden when
the filter was applied.

• Disabled Components — if you have not applied a filter,
Disabled Components lists all the components for which tracing
of the selected path type is disabled. If you applied a filter, this
“filtered” list displays components that have path tracing
disabled; however, some of the disabled components may be
hidden when the filter was applied.

• Add (>) moves the selected component from the Enabled
Components list box to the Disabled Components list box.

• Add All (>>) moves all the listed components from the Enabled
Components list box to the Disabled Components list box.

ram_we_o RAM WE to output Disabled

tbuf_t_o TBUF tristate control to output Enabled

tbuf_i_o TBUF input to output Enabled

io_pad_i I/O pad to input Enabled

io_t_pad I/O tristate control to pad Enabled

io_o_i Bidirectional tristate I/O output to input Enabled

io_o_pad I/O output to pad Enabled

Table 5-1 Control Path Tracing Path Types

Abbreviation Path Type Default
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• Remove (<) moves the selected component from the Disabled
Components list box to the Enabled Components list box.

• Remove All (<<) moves all listed components from the Disabled
Components list box to the Enabled Components list box.

Copy (Edit Menu)
The Copy command functions like the standard Copy command; it
copies highlighted text to the clipboard. The Edit menu is visible and
enabled only if a design, macro, or report window is open.

Cut (Edit Menu)
The Cut command functions like the standard Cut command; it cuts
highlighted text and moves it to the clipboard. The Edit menu is
visible and enabled only if a design, macro, or report window is
open.

Disable Timing Constraints (Path Filters Menu)
The Disable Timing Constraints command omits selected timing
constraints from analysis. This command appears in the Timing
Constraint Filters submenu.

Use this path filtering command in conjunction with the Timing
Analysis report, which compares the implementation of the design to
the XACT-Performance constraints. And with the Design Perfor-
mance report, which provides a set of summary statistics for the
paths from the timing requirements specified for analysis.

This command displays the Disable Timing Constraints dialog box,
shown in the following figure.
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Figure 5-4 Disable Timing Constraints Dialog Box

The dialog box contains these buttons and fields.

• Include User Constraints — this radio button is automatically
selected because the Timing Analyzer, by default, analyzes all
constraints.

• Omit User Constraints — this radio button disables all of the
timing constraints from the “USER” section of the Physical
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Constraints File (PCF). The order of the timing constraints in the
PCF file is reflected by the Timing Analyzer.

Note: The Include User Constraints and Omit User Constraints
buttons are only available for FPGAs. CPLD timing constraint infor-
mation is contained in the design file (VM6) itself.

• Filter for Enabled Timing Constraints limits the timing
constraints displayed in the Enabled Constraints list box to those
you specify. You can include a “?” or an “*” wildcard in the
component name for the filter to use in searches. The “?” repre-
sents a single character; the “*” represents zero or more charac-
ters.

• Apply executes the filter indicated in the Filter for Enabled
Timing Constraints field and displays the subset in the
Enabled Constraints list box.

• Reset deletes the filter and redisplays all the enabled timing
constraints in the Enabled Constraints list box.

• Enabled Constraints lists the timing constraints to be included in
the timing analysis, except those that you specified in the Filter
for Enabled Timing Constraints field. If you do not specify a filter,
it lists all the timing constraints in the design.

• Disabled Constraints lists all the timing constraints to be ignored
in the current timing analysis.

• Add (>) moves the selected timing constraint from the Enabled
Constraints list box to the Disabled Constraints list box.

• Add All (>>) moves all listed timing constraints from the
Enabled Constraints list box to the Disabled Constraints list box.

• Remove (<) moves the selected timing constraint from the
Disabled Constraints list box to the Enabled Constraints list box.

• Remove All (<<) moves all listed timing constraints in the
Disabled Constraints list box to the Enabled Constraints list box.

Design Performance (Analyze Menu)
The Design Performance command generates the Design Perfor-
mance report, which provides a set of summary statistics for the
paths from the timing requirements specified for analysis.
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For FPGAs, this report displays the results of analyzing the
constraints specified in the constraints file. If no constraints are speci-
fied, this report displays the maximum clock frequencies for all clocks
in the design and the worst-case timing for all clock paths. For
CPLDs, this report displays all external pad-to-pad (tPD), clock pad-
to-output pad (tCO), setup-to-clock-the-pad delays (tSU), and
internal clock-to-setup (tCYC) delays.

You can use the following path filtering commands to modify the
scope of this report.

• Report Paths Failing Timing Constraints (Path Filters Menu)

• Report Paths Not Covered by Timing Constraints (Path Filters
Menu)

• Disable Timing Constraints (Path Filters Menu)

• Include Paths with Nets (Path Filters Menu)

• Exclude Paths with Nets (Path Filters Menu)

• Control Path Tracing (Path Filters Menu)

Exclude Paths with Nets (Path Filters Menu)
The Exclude Paths with Nets command excludes paths containing
specified nets from timing analysis, regardless of what paths are spec-
ified in the Include Paths with Nets command or other path filtering
commands. If a net is selected, paths through that net are not
analyzed. The default does not exclude any nets from analysis. This
command appears in the Common Filters submenu.

Use this path filtering command in conjunction with any of the
following reports.

• Timing Analysis report, which compares the implementation of
the design to the XACT-Performance constraints

• Design Performance report, which indicates overall design
performance

• All Paths report, which contains detailed timing information for
all paths in the design

This command displays the Exclude Paths with Nets dialog box,
shown in the next figure.
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Figure 5-5 Exclude Paths with Nets Dialog Box

This dialog box includes the following fields and buttons.

• Filter for Nets Not to be Selected limits the nets displayed in the
Nets Not Selected list box to those you specify. You can include a
“?” or an “*” wildcard in the net name for the filter to use in
searches. The “?” represents a single character; the “*” represents
zero or more characters.

• Apply executes the filter specified in the Filter for Nets Not to
be Selected field, which hides all nets in the Nets Not
Selected list box that do not match the filter.
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• Reset deletes the filter and displays all the nets, except those
that have been moved to the Selected Nets list box, in the
Nets Not Selected list box,.

• Nets Not Selected lists the nets that are available to be excluded
from timing analysis. These are all the nets in the design except
those that are hidden after applying a filter in Filter for Nets Not
to be Selected or those you move to the Selected Nets list box.

• Selected Nets lists the net to be excluded from timing analysis.

• Add (>) moves selected nets from the Nets Not Selected list box
to the Selected Nets list box.

• Add All (>>) moves all the listed nets from the Nets Not Selected
list box to the Selected Nets list box.

• Remove (<) moves selected nets from the Selected Nets list box to
the Nets Not Selected list box.

• Remove All (<<) moves all listed nets from the Selected Nets list
box to the Nets Not Selected list box.

Exit (File Menu)
The Exit command exits the Timing Analyzer. If you have unsaved
reports or macros open, the following prompt box appears, so you
can save them.

The three options in this prompt box are the following.

• Yes — For reports, existing and new macros, it displays the Save
As dialog box, shown in the “Save As Dialog Box” figure, so you
can specify a file name.

• No exits the Timing Analyzer without saving the file.

• Cancel cancels the exit operation.
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Find (Edit Menu)
The Edit menu is visible and enabled only if a design, macro, or
report window is open. The Find command displays the Find dialog
box, shown in the next figure. It enables you to search for a text string
within a Timing Analyzer report.

Figure 5-6 Find Dialog Box

The Find dialog box contains these fields.

• Find What is the field in which you type the text string to find.

• Match Case finds only instances that have the same case as the
text string. By default, it ignores the case of the text.

• Direction indicates the direction to search.

• Up searches backwards from the present location of the
cursor to the beginning of the report. It stops at the beginning
of the report.

• Down searches forward from the present location of the
cursor to the end of the report. It stops at the end of the
report. This direction is the default.

• Find Next finds the next instance of the text string you are
searching for.

Find Next (Edit Menu)
The Find Next command finds the next instance of the text string you
are searching for with the same parameters as the previous search
with Timing Analyzer reports or macros. It is available for the
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Console window. The Edit menu is visible and enabled only if a
design, macro, or report window is open.

Include Paths with Nets (Path Filters Menu)
The Include Paths with Nets command limits analysis to paths that
contain specified nets. If a net is not specified, paths through that net
are not analyzed. However, if no nets are selected, which is the
default, all nets, except those you exclude with other path filtering
commands, are analyzed. This command appears in the Common
Filters submenu.

Use this path filtering command in conjunction with any of the
following reports.

• Timing Analysis report, which compares the implementation of
the design to the XACT-Performance constraints

• Design Performance report, which indicates overall design
performance

• All Paths report, which contains detailed timing information for
all paths in the design

This command displays the Include Paths with Nets dialog box,
shown in the following figure.
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Figure 5-7 Include Paths with Nets Dialog Box

This dialog box includes these buttons and fields.

• Filter for Nets Not to be Selected limits the nets displayed in the
Nets Not Selected list box to those you specify. You can include a
“?” or an “*” wildcard in the net name for the filter to use in
searches. The “?” represents a single character; the “*” represents
zero or more characters.

• Apply executes the filter in the Filter for Nets Not to be
Selected field, which hides all nets in the Nets Not Selected
list box that do not match the filter.

• Reset deletes the filter and displays in the Nets Not Selected
list box, all nets except those that have been moved to the
Selected Nets list box.
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• Nets Not Selected lists the nets to be excluded from timing anal-
ysis, except those that are hidden after applying a filter in Filter
for Nets Not to be Selected or those you move to the Selected
Nets list box. If no nets are moved to the Selected Nets list box,
which is the default, all nets except those you include with other
filters or commands are analyzed.

• Selected Nets lists the nets to be included in timing analysis.

• Add (>) moves selected nets from the Nets Not Selected list box
to the Selected Nets list box.

• Add All (>>) moves all the listed nets from the Nets Not Selected
list box to the Selected Nets list box.

• Remove (<) moves selected nets from the Selected Nets list box to
the Nets Not Selected list box.

• Remove All (<<) moves all listed nets from the Selected Nets list
box to the Nets Not Selected list box.

New Macro (File Menu)
The New Macro command opens a new Timing Analyzer macro
document window, in which you can perform text editing to create a
macro. You can also copy or cut a sequence of commands from the
Console window and paste it in a New Macro window. The macro is
saved to a .xtm file, which is the only document type you create
directly in the Timing Analyzer.

Open (File Menu)
The Open command opens existing timing report (TWR) or timing
analysis macro (XTM) files. It displays the Open dialog box, shown in
the next figure.
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Figure 5-8 Open Dialog Box

This dialog box contains the following fields.

• File Name specifies the name of the macro, report, or other file to
load. The default is a report (TWR) file. (Backspace over the
asterisk.) You can also click on the file name in the list box just
below this field.

• Directories (workstation)/Look in (PC) lists the directories (for
the specified drive on PCs) so you can select the directory that
contains the file that you want to load.

• List Files of Type (workstation)/Files of type (PC) lists the catego-
ries of files to open. It can be a macro (XTM), a report (TWR), or
all files. Report (TWR) files is the default.

Open Design (File Menu)
The Open Design command opens a mapped NCD (FPGA) or a
completed placed and routed VM6 (CPLD) file. The mapped FPGA
design can be partially or completely placed, routed, or both. For
FPGAs, a physical constraints file (PCF) is also need for timing anal-
ysis for specific constraints. By default, the Timing Analyzer opens
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the PCF file with the same name and in the same directory as the
design file. You can analyze the same design with different PCF files.
The command displays the Open Design dialog box, shown in the
following figure.

Figure 5-9 Open Design Dialog Box

This dialog box contains the following fields.

• File Name specifies the name of the NCD (FPGA) or VM6 (CPLD)
design file to load. (Backspace over the asterisk.) You can also
click on the design file name in the list box just below this field.

• Directories (workstation)/Look in (PC) lists the directories (for
the specified drive on PCs) so you can select the directory that
contains the design file you want to load.

• List Files of Type (workstation)/Files of type (PC) specifies
whether the file to load is an NCD (FPGA) or VM6 (CPLD)
design file. The default is an NCD file.

Open Physical Constraints (File Menu)
The Open Physical Constraints command displays the Open Physical
Constraints dialog box which you use to load an existing physical
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constraints file (PCF) other than the default. The default PCF file has
the same name and exists in the same directory as the (NCD) design
file.

Note: This command only supports FPGAs; CPLD physical
constraint information exists in the (VM6) design file itself. The order
of the constraints in the PCF file is reflected by the Timing Analyzer.

The Open Physical Constraints command displays the dialog box
shown in the next figure.

Figure 5-10 Open Physical Constraints Dialog Box

The dialog box contains the following fields.

• File Name specifies the physical constraints file (PCF) to load.
(Backspace over the asterisk.) You can also click on the PCF file
name in the list box just below this field.

• Directories (workstation)/Look in (PC) lists the directories (for
the specified drive on PCs) so you can select the directory that
contains the physical constraints file that you want to load.

• List Files of Type (workstation)/Files of type (PC) lists physical
constraints files (PCF).
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Paste (Edit Menu)
The Paste command function likes the standard Paste command; it
pastes text last copied to the clipboard. The Edit menu is visible and
enabled only if a design, macro, or report window is open.

Path Analysis Filters Submenu (Path Filters Menu)
Path Analysis Filters is a submenu in the Path Filters menu, which
contains the following commands that allow you to the define paths
you want to analyze.

• Select Sources (Path Filters Menu)

• Select Destinations (Path Filters Menu)

These commands apply to the All Paths command in the Analyze
menu that produces the All Paths report. Refer to the alphabetical
listings of these commands for an explanation of their functions.

Print (File Menu)
The Print command displays the Print dialog box, which sends the
file that is displayed in the active window to the default printer. It
also enables you to indicate how many copies to print, to send the file
to a printer other than the default, or to change printer options. The
Print dialog box is shown in the following figure.
Timing Analyzer Reference/User Guide 5-25



Timing Analyzer Reference/User Guide
Figure 5-11 Print Dialog Box

Print dialog boxes vary between workstations and PCs. Four basic
options in this dialog box follow.

• Print Range

• All prints the entire file

• Pages From is the field in which you enter the beginning of
the range of pages to print.

• Pages To is the field where you enter the end of the range of
pages to print.

• Copies is the field in which you enter the number of copies you
want to print.

• Setup displays the printer Manager dialog box.

• Print to File is the box to select to print to a file.

Query (Analyze Menu)
The Query command generates a report containing timing informa-
tion of particular nets or members of a time group. It displays the
Query dialog box, shown in next figure.
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Figure 5-12 Query Dialog Box

Note: This command only supports FPGAs. It is disabled if a CPLD
design is open.

The Query dialog box contains the following buttons and fields.

• Nets displays timing information of particular nets. When you
select this button, the Query Nets Report shows the fanout, the
timing from the source CLB to each of the destination CLBs, and
the CLB names.

• TimeGroups displays members of time groups. The Query Time
Groups report lists the elements in the specified timing groups.
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• Filter for Available Nets/TimeGroups limits the elements
displayed in the Available Nets/Timegroups list box to those you
specify. The filter display alternates between Nets and TimeGroups
with the button you select.

• Field in which to specify a filter to display a subset of nets or
time groups. You can include a “?” or an “*” wildcard. The
“?” represents a single character; the “*” represents zero or
more characters.

• Delay Greater Than specifies a minimum delay in nanosec-
onds. The Timing Analyzer displays only those paths that
have a delay greater than or equal to the specified value. You
can enter a value in this field only when you select Nets. If
you enter a value in both the Delay Greater Than and the
filter field, the Timing Analyzer lists the nets that meet both
criteria.

• Apply executes the filter in the filter field and displays the
subset in the Available Nets/TimeGroups list box.

• Reset deletes the filter and redisplays all the nets or time
groups in the Available Nets/TimeGroups list box.

• Available Nets/TimeGroups displays all the available net or
timing group elements on which you can obtain information.

• Selected Nets/TimeGroups displays only the net or timing group
elements that you selected.

• Add (>) moves selected elements from the Available Nets/Time-
Groups list box to the Selected Nets/TimeGroups list box.

• Add All (>>) moves all the listed elements from the Available
Nets/TimeGroups list box to the Selected Nets/TimeGroups list box.

• Remove (<) moves selected elements from the Selected Nets/
TimeGroups list box to the Available Nets/TimeGroups list box.

• Remove All (<<) moves all the listed elements from the Selected
Nets/TimeGroups list box to the Available Nets/TimeGroups list
box.

Recent Design (File Menu)
The Recent Design command lists up to the last four design files
(NCD for FPGA or VM6 for CPLD) that you opened. The design you
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select (and for FPGAs, its default physical constraints file) are auto-
matically loaded as the current design.

Report Options (Options Menu)
The Report Options command determines the appearance of a report
and the information that it contains. It displays the Report Options
dialog box, shown in following figure, so you can customize the
Timing Analyzer reports.

Figure 5-13 Report Options Dialog Box

The following table lists each option in the dialog box and indicates if
the option supports FPGA or CPLD designs.

Option FPGA CPLD

Summary Report Only Yes No

Maximum Paths per Timing Constraint Yes Yes

Report Delays Less Than No Yes

Report Delays Greater Than No Yes

Sort On No Yes

Report Only Longest Paths Between Points No Yes
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• Summary Report Only generates a report containing only the
path source and end point. This report lists one delay path per
line and does not display cumulative delays through CLBs.
Applies only to FPGAs.

• Maximum Paths per Timing Constraint sets the limit for the
number of paths reported per timing constraint. For FPGAs, the
default is one path per timing constraint. For CPLDs, the default
is unlimited. Not specifying a value is equivalent to “no limit.”
This option can be useful, because it limits the size of report files.

• Report Delays Less Than (CPLD only) reports only those paths
that have a delay less than or equal to the specified value. Not
specifying a value is equivalent to “no limit” and the option is
turned Off.

• Report Delays Greater Than (CPLD only) reports only those
paths that have a delay greater than or equal to the specified
value. The default is zero, which reports all paths, regardless of
their delay.

• Sort On (CPLD only) specifies how paths are sorted when they
are reported. The pull-down list box has the following six
options.

• Ascending Delay lists paths in order from shortest to longest
delays.

• Descending Delay lists paths in order from longest to
shortest delays.

• Source Net sorts path delays by the source net name, which is
useful when trying to determine the worst-case delay from a
given component.

• Destination Net sorts path delays by the destination net
name, which can help determine the worst-case path to each
component.

• Source Clock Net sorts path delays by the clock name that
sources the first element in a path, which separates delay
information for two or more clock nets in a design.

Wide Report Yes Yes

Option FPGA CPLD
5-30 Xilinx Development System



Menu Commands
• Destination Clock Net sorts path delays by the clock name
that sources the last element in a path.

• Report Only Longest Paths Between Points (CPLD only) reports
only the path with the longest delay if there is more than one
path between two end points.

• Wide Report creates a report formatted with 132 characters per
line instead of 80 characters per line as in a default report. This
helps prevent truncating long component and net names since
they are truncated to 132 characters instead of 80 characters.

Report Paths Failing Timing Constraints (Path Filters
Menu)

The Report Paths Failing Timing Constraints command reports only
the paths that do not meet the timing constraints. This command
appears in the Timing Constraint Filters submenu.

Use this path filtering command in conjunction with the Timing
Analysis report, which compares the implementation of the design to
the timing constraints. And with the Design Performance report,
which provides a set of summary statistics for the paths from the
timing requirements specified for analysis.

Report Paths Not Covered by Timing Constraints
(Path Filters Menu)

The Report Paths Not Covered by Timing Constraints command
reports paths that do not have timing constraints, in addition to paths
with timing constraints. This command appears in the Timing
Constraint Filters submenu.

Use this path filtering command in conjunction with the Timing
Analysis report, which compares the implementation of the design to
the timing constraints. And with the Design Performance report,
which provides a set of summary statistics for the paths from the
timing requirements specified for analysis.

Reset All Path Filters (Path Filters Menu)
The Reset Path Filters command resets path filters to default settings.
To display path filter settings, see the Settings (View Menu)
command.
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Run Macro (File Menu)
The Run Macro command runs the specified macro, which is a script
file that contains Timing Analyzer commands, filters, report options,
or all three.

Save (File Menu)
The Save command saves reports in the active window to a specified
file. It also saves macros created with the New Macro command. By
default, the Timing Analyzer saves reports as TWR files and macros
as XTM files. This command displays the Save As dialog box which
you can use to save reports and macros as different files. It is shown
in “Save As Dialog Box” figure. If you saved the report or macro
once, the Save command saves the document in the existing file
without activating the Save As dialog box.

Save As (File Menu)
The Save As command saves the edited report or macro to another
file. It displays the Save As dialog box, which is the same dialog box
activated by the Save command. This dialog box is displayed in the
following figure.

Figure 5-14 Save As Dialog Box

The Save As dialog box contains the following fields.
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• File Name specifies the name of the file in which to save the
report or macro. (Backspace over the asterisk.) You can also click
on the file name in the list box just below this field.

• Directories (workstation)/Save in (PC) lists the directories (for
the specified drive on PCs) so you can select the directory in
which to save the report or macro file.

• List Files of Type (workstation)/Save as type (PC) lists categories
of file types from which you select to display in the File Name
field and list box. You do not have to save the file as a TWR or an
XTM file, but the Timing Analyzer saves reports as TWR or
macros as XTM files by default. Additionally, the Timing
Analyzer only reads XTM files, that is, files with a .xtm extension.

Select Destinations (Path Filters Menu)
The Select Destinations command defines the ending points of paths
you want to analyze, which can be flip-flops, IOBs, clocks, nets, pins,
CLBs, or all types. This command appears in the Path Analysis Filters
submenu.

Use this path filtering command in conjunction with the Design
Performance report, which indicates overall design performance. Or
with the All Paths report, which contains detailed timing information
for all paths in the design.

This command displays the Select Destinations dialog box, shown in
following figure.
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Figure 5-15 Select Destinations Dialog Box

This dialog box contains the following buttons and fields.

• The All Destinations radio button is selected by default, because
by default, the Timing Analyzer analyzes all paths. It disables all
other dialog box options, except OK, Cancel, and Help.

• The Selected Destinations radio button enables other dialog box
options when selected. It allows you to specify path destinations
you want to analyze.

• Destination Element Type is a pull-down list box that lists the
destination elements. The default is flip-flops.
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FPGA destination types are: flip-flops, pads, nets, pins, CLBs, or
clocks. CPLD destination types are: flip-flops, pads, nets, macro-
cells, or clocks.The default is flip-flops.

• Clock Edge determines whether the destination is a clock’s rising
or falling edge, or either edge. This option is available only for
FPGAs when you select Clocks in the Destination Element Type
field.

• Filter for Element Not to be Selected limits the destination to a
particular element or elements within the specified category and
displayed in the Destination Element list box. The Element
changes with the element you select in the Destination Element
Type. You can include a “?” or an “*” wildcard in the element
type for the filter to use in searches. The “?” represents a single
character; the “*” represents zero or more characters.

• Apply executes the filter in the Filter for Element Not to be
Selected field and displays the subset in the Destination
Element list box.

• Reset deletes the filter and redisplays all the element destina-
tions in the Destination Element list box.

• Destination Element lists all the individual destinations that you
specify in the Destination Element Type. You can display a subset
of this list by applying a filter in the Filter for Element Not to be
Selected field.

• Selected Destinations displays the individual destinations that
you selected.

• Add (>) moves selected elements from the Destination Element
list box to the Selected Destinations list box.

• Add All (>>) moves all the listed elements from the Destination
Element list box to the Selected Destinations list box.

• Remove (<) removes selected elements from the Selected Destina-
tions list box.

• Remove All (<<) removes all listed elements from the Selected
Destinations list box.
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Select Sources (Path Filters Menu)
The Select Sources command defines the starting points of paths you
want to analyze. They can be flip-flops, pads, clocks, nets, pins, CLBs,
or macrocells. This command appears in the Path Analysis Filters
submenu.

Use this path filtering command in conjunction with the All Paths
report, which contains detailed timing information for all paths in the
design.

This command displays the Select Sources dialog box, shown in the
next figure.
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Figure 5-16 Select Sources Dialog Box

This dialog box displays the following buttons and fields.

• The All Sources button is selected by default, because by default,
the Timing Analyzer analyzes all paths. It disables all other
dialog box options, except OK, Cancel, and Help.

• The Selected Sources button enables other dialog box options
when selected. It allows you to specify path sources you want to
analyze.
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• Source Element Type is a pull-down list box that lists the source
elements. The default is flip-flops.

FPGA source types are: flip-flops, pads, nets, pins, CLBs, or
clocks. CPLD source types are: flip-flops, pads, nets, macrocells,
or clocks.The default is flip-flops.

• Clock Edge determines whether the source is a clock’s rising
edge or falling edge, or either edge. This option is available only
for FPGAs when you select Clocks in the Source Element Type.

• Filter for Element Not to be Selected limits the elements displayed
in the Source Element list box to those you specify. The Element
changes with the element you select in the Source Element Type.
You can include a “?” or an “*” wildcard in the source name for
the filter to use in searches. The “?” represents a single character;
the “*” represents zero or more characters.

• Apply executes the filter in the Filter for Element Not to be
Selected and displays the subset in the Source Element list
box.

• Reset deletes the filter and redisplays all the sources of the
specified type in the Source Element list box.

• Source Element list box lists all the individual sources that you
specify in the Source Element Type field. You can display a subset
by applying a filter in the Filter for Element Not to be Selected
field.

• Selected Sources displays all the individual sources that you
selected for the specified source type.

• Add (>) moves selected elements from the Source Element list box
to the Selected Sources list box.

• Add All (>>) moves all the listed elements from the Source
Element list box to the Selected Sources list box.

• Remove (<) moves selected elements from the Selected Sources
list box to the Source Element list box.

• Remove All (<<) moves all listed elements from the Selected
Sources list box to the Source Element list box.
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Settings (View Menu)
The Settings command lists the current settings of Timing Analyzer
options specified with the commands in the Path Filters and Options
menus in a pop-up window. The “Settings Window” figure of the
“How to Use the Timing Analyzer” chapter gives an example of the
window and the information it displays when you select this
command.

You can save the settings as a macro (.xtm) file to return the system to
the same state as when the settings were saved. See the “Saving a
New Macro” section and the “Running a Macro” section of the “How
to Use the Timing Analyzer” chapter for more information. You can
also save the contents of the window to a .twr file. TWR files are listed
as Timing Analysis Reports (*.twr) under List Files of Type in File
menu command dialog boxes. See the “Saving a Report” section of
the “How to Use the Timing Analyzer” chapter for the procedure to
save a report.

The settings apply to both FPGAs and CPLDs unless specified. The
default settings are as follows.

Setting Description

OpenPCF file_name Displays the current physical constraints file
(PCF).

Speed speed_grade Sets the speed grade for analysis. See Speed
Grade (Options Menu).

IncludeNets If no arguments specified, includes all nets
during analysis. See Include Paths with Nets
(Path Filters Menu).

ExcludeNets If no arguments specified, includes all nets
during analysis, no nets are excluded. Default
is no nets are excluded. See Exclude Paths
with Nets (Path Filters Menu).

SelectFailingTimeConstraint True/False If set to True, reports only paths that do not
meet timing constraints. The default is False.
See Report Paths Failing Timing Constraints
(Path Filters Menu).
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IncludeNoTimeConstraint True/False If set to True, reports paths without timing
constraints, in addition to paths with timing
constraint. Default is False for FPGAs, True for
CPLDs. See Report Paths Not Covered by
Timing Constraints (Path Filters Menu).

Report Normal|Wide The default is Normal. A Normal report is 80
characters per line. A Wide report is 132 char-
acters per line.

MaxPathsPerTimingConstraint number Displays maximum number of paths per
timing constraint. Set in the Report Options
(Options Menu) dialog box.

DelayLessThan delay_value Optional command that only supports anal-
ysis of CPLD designs. If not specified, there is
“no upper limit.” Change the delay_value in
the Report Options (Options Menu) dialog
box.

DelayGreaterThan 0.000 Only supports analysis of CPLD designs.
Default is 0, which includes all paths. Change
this number in the Report Options (Options
Menu) dialog box.

OnlyLongestPaths False Only supports analysis of CPLD designs. If
set to True, reports only the path with the
longest delay, if there is more than one path
between two end points. Change this setting
in the Report Options (Options Menu) dialog
box.

SortOn Ascend Only supports analysis of CPLD designs.
Specifies how paths are sorted when
reported. Corresponds with the Sort On pull-
down list box in the Report Options (Options
Menu) dialog box.

DefineEndpoints ToAll Corresponds with the Select Destinations
(Path Filters Menu) command.

DefineEndpoints FromAll Corresponds with the Select Sources (Path
Filters Menu) command.

Setting Description
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Speed Grade (Options Menu)
The Speed Grade command changes the speed grade for timing anal-
ysis only. The speed grade you set in the NCD or VM6 design file is
not affected. This command displays the Set Speed Grade dialog box,
shown in following figure.

Figure 5-17 Set Speed Grade Dialog Box

In the dialog box, Speed Grade is a pull-down list box that lists the
available speed grades for the target device.

Status Bar (View Menu)
The Status Bar command controls whether or not the status bar is
displayed. It is displayed by default. The status bar displays a brief
description of the current menu item under the cursor, which
command is being executed, the open PCF file name, and Timing
Analyzer messages.

OmitUserConstraints False Only supports analysis of FPGA designs. If
set to True, disables timing constraints in
“USER” section of the PCF. If set to False,
enables timing constraints in “USER” section.

DropTimingConstraint Corresponds with the Disable Timing
Constraints (Path Filters Menu) command.

Setting Description
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Tile (Window Menu)
The Tile command arranges the open windows in rows across the
Timing Analyzer screen. The windows are fitted into all available
screen space without overlapping, as the next figure demonstrates.

Figure 5-18 Tiled Windows

Timing Constraints (Analyze Menu)
The Timing Constraints command generates the Timing Analysis
(TWR) report of all active timing constraints in the current physical
constraints file (PCF). The order of the constraints in the PCF file is
reflected in the Timing Analyzer reports. Filters from the Timing
Constraint Filters and Common Filters submenus are applied during
analysis.

You can use the following path filtering commands to modify the
scope of this report.

• Report Paths Failing Timing Constraints (Path Filters Menu)
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• Report Paths Not Covered by Timing Constraints (Path Filters
Menu)

• Disable Timing Constraints (Path Filters Menu)

• Include Paths with Nets (Path Filters Menu)

• Exclude Paths with Nets (Path Filters Menu)

• Control Path Tracing (Path Filters Menu)

Timing Constraint Filters Submenu (Path Filters
Menu)

The Timing Constraint Filters submenu contains the following
commands, which modify the scope of timing analysis. They can be
used to generate Timing Analysis and Design Performance reports.

• Report Paths Failing Timing Constraints (Path Filters Menu)

• Report Paths Not Covered by Timing Constraints (Path Filters
Menu)

• Disable Timing Constraints (Path Filters Menu)

Refer to the alphabetical listings of these commands for an explana-
tion of their functions.

Toolbar (View Menu)
The Toolbar command controls whether or not the toolbar is
displayed. It is displayed by default. See the “Toolbar” section,
following, for a description of the buttons on the toolbar.

Toolbar
The toolbar provides button access to frequently used menu
commands. Textual labels for the buttons appear when you move the
cursor over a button. This feature is called a tool tip. Every toolbar
button has a tool tip; a longer description appears in the status bar.
The Cut, Copy, Paste, and Run Macro buttons appear only when you
click on the New Macro command. The Timing Analyzer window
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displays the following buttons, which are discussed in the order that
they appear on the toolbar.

New Macro
New Macro opens a new Timing Analyzer macro document window.
It is equivalent to the New Macro (File Menu) command.

Open Design
Open Design button opens an existing design for timing analysis. It is
equivalent to the Open Design (File Menu) command.

Save
The Save button saves the active macro or report window to a speci-
fied file. It is equivalent to the Save (File Menu) command.

Print
The Print button displays the Print dialog box and sends the contents
displayed in the active window to the default printer. It is equivalent
to the Print (File Menu) command.
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Cut
The Cut button cuts the selected text from a macro window and
moves the text to the clipboard. It is enabled when a macro window is
open and text is selected. (The Console and report windows are read-
only.) The Cut button is equivalent to the Cut (Edit Menu) command.

Copy
The Copy button, copies the highlighted commands in the Console
window or selected text in a macro or report window to the clip-
board, so that you can paste them into a macro window to form a
new macro or edit an existing one. It is enabled when the Console
window is open and commands are highlighted or a macro or report
window is open and text is selected. The Copy button performs the
same function as the Copy (Edit Menu) command.

Paste
The Paste button replaces the currently selected text in the macro
window with the contents of the clipboard. If no text is selected, the
contents of the clipboard are inserted at the cursor position in the
macro window. The Paste button functions the same as the Paste
(Edit Menu) command.

Analyze Timing Constraints
The Analyze Timing Constraints button generates the Timing Anal-
ysis report, which compares the implementation of the design to the
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XACT-Performance constraints. It is equivalent to the Timing
Constraints (Analyze Menu) command.

Analyze Design Performance
The Analyze Design Performance button generates the Design
Performance report. The report indicates overall design performance.
It is equivalent to the Design Performance (Analyze Menu)
command.

Analyze All Paths
The Analyze All Paths button generates the All Paths report, which
contains worst-case path delays for all paths in the design. It is equiv-
alent to the All Paths (Analyze Menu) command.

Run Macro
The Run Macro button runs an existing macro, which you open with
the Open command on the File menu. It is enabled when a macro file
is active. The Run Macro button is equivalent to the Run Macro (File
Menu) command.
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About
The About button displays program and copyright information about
the Timing Analyzer. It is equivalent to the About Timing Analyzer
(Help Menu) command.

Help
Help displays information about a menu command or option when
you click on it. The information is displayed in a pop-up window. See
the “Obtaining Help” section of the “Getting Started” chapter.
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Chapter 6

Keyboard Commands

This chapter describes all the commands that you can enter from the
keyboard in the Timing Analyzer’s Console or New Macro window.
They are listed in alphabetical order.

• “AnalyzeAllPaths” section

• “AnalyzeDesignPerformance” section

• “AnalyzeTimingConstraints” section

• “ControlPathTracing” section

• “DefineEndPoints” section

• “DelayGreaterThan” section

• “DelayLessThan” section

• “DropTimingConstraint” section

• “ExcludeNets” section

• “Exit” section

• “IncludeNets” section

• “IncludeNoTimingConstraint” section

• “MaxPathsPerTimingConstraint” section

• “OmitUserConstraints” section

• “OnlyLongestPaths” section

• “OpenDesign” section

• “OpenPCF” section

• “Query” section

• “Report” section
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• “ResetAllPathFilters” section

• “RunMacro” section

• “SelectFailingTimingConstraint” section

• “SetForce” section

• “ShowClockNets” section

• “ShowSettings” section

• “SortOn” section

• “Speed” section

The syntax of these commands is case-insensitive; capitalization is for
easy reading. Parameters in the “Abbreviation” sections have the
same respective meanings as the parameters in the longer form of the
syntax.

For more information on issuing commands through the Console
window, see the “Using the Console Window” section of the “How to
Use the Timing Analyzer” chapter. For instructions on using these
commands to build macros, see the “Using Macros” section of the
same chapter.

AnalyzeAllPaths Generates report containing worst-
case path delays for paths in
design, except those suppressed by
filtering commands

AnalyzeDesignPerformance Generates report indicating overall
design performance

AnalyzeTimingConstraints Generates report indicating
whether design meets timing
constraints

ControlPathTracing Controls path tracing through
components

DefineEndPoints Defines path starting and ending
points

DelayGreaterThan Specifies minimum delay. Only
supports analysis of CPLD designs

DelayLessThan Specifies maximum delay. Optional
CPLD-only command
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DropTimingConstraint Omits specified timing constraints
from analysis

ExcludeNets Prohibits analysis of specified nets

Exit Exits the Timing Analyzer

IncludeNets Limits analysis to paths containing
specified nets

IncludeNoTimingConstraint Forces reporting of paths with no
timing constraints

MaxPathsPerTimingConstraint Limits the total number of paths
reported per timing constraint

OmitUserConstraints Enables or disables user-specified
constraints in the PCF file

OnlyLongestPaths Reports only path with longest
delay for each constraint. Only
supports analysis of CPLD designs

OpenDesign Loads a design for timing analysis

OpenPCF Opens an existing physical
constraints file

Query Displays timing information about
groups of elements

Report Determines format of reports

ResetAllPathFilters Causes path filters to revert to
default

RunMacro Runs macro

SelectFailingTimingConstraint Limits reporting to paths that do
not meet timing constraints

SelectPathType Selects path types to analyze

SetForce Suppresses messages when macro
is run

ShowClocks Show or hide the window showing
the clock nets

ShowSettings Show or hide the window
displaying current settings of
filters and command option
settings
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AnalyzeAllPaths
The AnalyzeAllPaths command creates the All Paths report, a long
report that displays a detailed analysis of all specified paths.

This command is equivalent to the Analyze → All Paths menu
command.

Syntax
The syntax of the AnalyzeAllPaths command is the following.

AnalyzeAllPaths [save file_name.twr]

• Save  indicates that you can optionally save the All Paths report
in a file. If this option is not specified, the report appears in a
window.

• File_name is the name of the file in which the All Paths report is
saved. TWR is the extension for report files.

Abbreviation
Abbreviate the AnalyzeAllPaths command syntax as follows.

aap [s file_name.twr]

Example
Following is an example of the AnalyzeAllPaths command.

analyzeallpaths save xredesign.twr

AnalyzeDesignPerformance
The AnalyzeDesignPerformance command generates a Design
Performance report. This report, which provides a set of summary
statistics for the paths from the timing requirements specified for
analysis.

SortOn Specifies how paths are sorted
when they are reported. Only
supports analysis of CPLD designs

Speed Changes speed grade during anal-
ysis
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For FPGAs, this report displays the results of analyzing the
constraints specified in the constraints file. If no constraints are speci-
fied, this report displays the maximum clock frequencies for all clocks
in the design and the worst-case timing for all clock paths. It is a short
report that calculates the maximum clock frequencies for all clocks in
the design and displays the worst-case timing all clock paths. For
CPLDs, the Design Performance report lists all external Pad to Pad
(tPD), Clock Pad to Output Pad (tCO), Setup to Clock at the Pad (tSU)
and delays, and internal Clock to Setup (tCYC) delays.

This command is equivalent to the Analyze → Design Performance
menu command.

Syntax
The syntax of the AnalyzeDesignPerformance command is the
following.

AnalyzeDesignPerformance [save file_name.twr]

• Save  indicates that you can optionally save the Design Perfor-
mance report in a file. If this option is not specified, the report
appears in a window.

• File_name is the name of the file in which the Design Performance
report is saved. TWR is the extension for report files.

Abbreviation
Abbreviate the AnalyzeDesignPerformance command syntax as
follows.

adp [s file_name.twr]

Example
The following is an example of the AnalyzeDesignPerformance
command.

analyzedesignperformance save shelby.twr
Timing Analyzer Reference/User Guide 6-5



Timing Analyzer Reference/User Guide
AnalyzeTimingConstraints
The AnalyzeTimingConstraints command generates the Timing
Analysis report, which compares design performance to the timing
constraints entered using XACT-Performance.

This command is equivalent to the Analyze → Timing Constraints
menu command.

Syntax
The following is the syntax for the AnalyzeTimingConstraints
command.

AnalyzeTimingConstraints [save file_name.twr]

• Save  indicates that you can optionally save the Timing Analysis
report in a file. If this option is not specified, the report appears in
a window.

• File_name is the name of the file in which the Timing Analysis
report is saved.

Abbreviation
Abbreviate the AnalyzeTimingConstraints command syntax as
follows.

atc [s file_name.twr]

Example
The following is an example of the AnalyzeTimingConstraints
command.

analyzetimingconstraints save nikko.twr

ControlPathTracing
The ControlPathTracing command controls path tracing through
RAMs, tristate buffers, input and output pins, components, and Set/
Reset logic. These paths may be irrelevant to your analysis.

Note: This command only applies to FPGAs; it does not function if a
CPLD design is open. (CPLD path timing analysis ignores paths
through Set/Reset logic and breaks paths at bidirectional I/O pins.)
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This command is equivalent to the Path Filters → Common Filters →
Control Path Tracing menu command.

Syntax
The syntax of the ControlPathTracing command is the following.

ControlPathTracing {Enable|Disable}
{reg_sr_q|lat_d_q|ram_d_o|ram_we_o|tbuf_t_o|tbuf_i_o|
io_pad_i|io_t_pad|io_o_i|io_o_pad} component_name
component_name...

• reg_sr_q  enables path tracing through CLB flip-flop asynchro-
nous Set or Reset outputs. By default, this path is disabled; the
Timing Analyzer does not analyze these paths.

• lat_d_q  enables path tracing from the latch D input to the Q
output. By default, this path is disabled; the Timing Analyzer
does not analyze these paths.

• ram_d_o  enables path tracing through the data inputs of a CLB
RAM. By default, this path is disabled; the Timing Analyzer does
not analyze these paths.

• ram_we_o  disables path tracing through the write-enable input
of a CLB RAM. By default, this path is enabled; the Timing
Analyzer analyzes these paths.

• tbuf_t_o  disables path tracing of paths that pass through a T
pin to the O pin. By default, this path is enabled; the Timing
Analyzer analyzes these paths.

• tbuf_i_o  disables path tracing from the input pin to the output
pin of a TBUF. By default, this path tracing is enabled; the Timing
Analyzer analyzes these paths.

• io_pad_i  disables path tracing from the pad pin to the input pin
of an IOB. By default, this path tracing is enabled; the Timing
Analyzer analyzes these paths.

• io_t_pad  disables path tracing from the tristate control pin of
an IOB to the pad. By default, this path tracing is enabled; the
Timing Analyzer analyzes these paths.

• io_o_i  disables path tracing of paths from the IOB O pin to the I
pin. By default, this path is enabled but is disabled for tristate
IOBs; the Timing Analyzer analyzes these paths.
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• io_o_pad  disables path tracing from the output pin of an IOB to
the pad pin. By default, this path tracing is enabled; the Timing
Analyzer analyzes these paths.

• Component_name is the name(s) of the CLBs, IOBs, or TBUFs that
the path goes through.

Abbreviation
Abbreviate the ControlPathTracing command syntax as follows.

cpt {Enable|Disable}
{reg_sr_q|lat_d_q|ram_d_o|ram_we_o|tbuf_t_o|tbuf_i_o|
io_pad_i|io_t_pad|io_o_i|io_o_pad} component_name
component_name...

Example
Following is an example of the ControlPathTracing command.

controlpathtracing ram_we_o CLB_R4C4

DefineEndPoints
The DefineEndPoints command selects the starting and ending
points of the paths that you want to analyze.

This command is equivalent to the Path Filters → Path Analysis
Filters → Select Sources and the Path Filters → Path Analysis Filters
→ Select Destinations menu commands.

FPGA starting and ending points are: flip-flops, pads, nets, pins,
CLBs, or clocks. CPLD starting and ending points are: flip-flops,
pads, nets, macrocells, or clocks.

Syntax
The syntax of the DefineEndPoints command is the following.

DefineEndPoints {FromAll|ToAll}
DefineEndPoints {FromPad|ToPad} pad_name
DefineEndPoints {FromCLB|ToCLB} CLB_name
DefineEndPoints {FromNet|ToNet} net_name
DefineEndPoints {FromPin|ToPin} pin_name
DefineEndPoints {FromFF|ToFF} flip-flop_name
DefineEndPoints {FromEitherEdge|ToEitherEdge}
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clock_name
DefineEndPoints {FromRising|ToRising} clock_name
DefineEndPoints {FromMacrocell|ToMacrocell}
macrocell_name
DefineEndPoints {FromFalling|ToFalling} clock_name

• FromAll  selects paths that begin at any path source.

• ToAll  selects paths that end at any path destination.

• FromPad  selects pads as starting points for the path to be
analyzed.

• ToPad selects pads as ending points for the path to be analyzed.

• FromCLB selects CLBs as starting points for the path to be
analyzed.

• ToCLB selects CLBs as ending points for the path to be analyzed.

• FromNet  selects nets as starting points for the path to be
analyzed.

• ToNet  selects nets as ending points for the path to be analyzed.

• FromPin  selects pins as starting points for the path to be
analyzed.

• ToPin  selects pins as the ending points for the path to be
analyzed.

• FromFF selects flip-flops as starting points for the path to be
analyzed.

• ToFF selects flip-flops as ending points for the path to be
analyzed.

• FromEitherEdge  selects either clock edge as starting points for
the path to be analyzed

• ToEitherEdge  selects either clock edge as ending points for the
path to be analyzed.

• FromRising  selects rising clock edges as starting points for the
path to be analyzed.

• ToRising  selects rising clock edges as ending points for the path
to be analyzed.

• FromMacrocell  selects macrocells as starting points for the
path to be analyzed.
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• ToMacrocell  selects macrocells as ending points for the path to
be analyzed.

• FromFalling  selects falling clock edges as starting points for
the path to be analyzed.

• ToFalling  selects falling clock edges as ending points for the
path to be analyzed.

• Pad_name is the name of the PAD that is the starting or ending
point of the path to be analyzed.

• CLB_name is the name of the CLB that is the starting or ending
point of the path to be analyzed.

• Net_name is the name of the net that is the starting or ending
point of the path to be analyzed.

• Pin_name is the name of the pin that is the starting or ending
point of the path to be analyzed.

• Flip-Flop_name is the name of the flip-flop that is the starting or
ending point of the path to be analyzed.

• Clock_name is the name of the clock that is the starting or ending
point of the path to be analyzed.

• Macrocell_name is the name of the macrocell that is the starting or
ending point of the path to be analyzed.

The defaults are FromAll and ToAll.

Abbreviation
Abbreviate the DefineEndPoints command syntax as follows.

dep {fall|tall}
dep {fpad|tpad} pad_name
dep {fclb|tclb} CLB_name
dep {fnet|tnet} net_name
dep {fpin|tpin} pin_name
dep {fff|tff} flip-flop_name
dep {fee|tee} clock_name
dep {fris|tris} clock_name
dep {fmc|tmc} macrocell_name
dep {ffal|tfal} clock_name
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Example
Following are examples of the DefineEndPoints command.

defineendpoints fromff CNT3Q0 CNT3Q1

defineendpoints topad P80 P68

DelayGreaterThan
The DelayGreaterThan command specifies a minimum delay in
nanoseconds. This command only supports analysis of CPLD
designs. The Timing Analyzer reports only those paths that have a
delay greater than or equal to the specified value. By default,
delay_value is 0, which reports all paths regardless of their delay.

This command is equivalent to the Report Delays Greater Than field
in the Report Options dialog box, which is activated by the Options
→ Report Options menu command.

Syntax
The syntax of the DelayGreaterThan command is the following.

DelayGreaterThan delay_value

Delay_value is the minimum delay in nanoseconds.

Abbreviation
Abbreviate the DelayGreaterThan command syntax as follows.

dg delay_value

Example
Following is an example of the DelayGreaterThan command.

delaygreaterthan 30

DelayLessThan
The DelayLessThan command specifies a maximum delay in nano-
seconds. This command only supports analysis of CPLD designs. The
Timing Analyzer reports only those paths that have a delay less than
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or equal to the specified value. By default, the Timing Analyzer
reports all paths regardless of their delay.

This command is equivalent to the Report Delays Less Than option in
the Report Options dialog box, which is activated by the Options →
Report Options menu command.

Syntax
The syntax of the DelayLessThan command is the following.

DelayLessThan delay_value

Delay_value is the maximum delay in nanoseconds. It is optional. If a
value is not specified, the limit is turned Off.

Abbreviation
Abbreviate the DelayLessThan command syntax as follows.

dl delay_value

Example
Following is an example of the DelayLessThan command.

delaylessthan 30

DropTimingConstraint
The DropTimingConstraint command prevents the Timing Analyzer
from analyzing the specified timing constraints.

This command is equivalent to the Path Filters → Timing Constraint
Filters → Disable Timing Constraints menu command.

Syntax
The syntax of the DropTimingConstraint command is the following.

DropTimingConstraint [ time_constraint1 time_constraint2...]

Time_constraint1, time_constraint2, and so forth are the timing
constraints to be ignored. Each can be either the name or the full text
of the timing constraint in single quotes.
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Abbreviation
Abbreviate the DropTimingConstraint command syntax as follows.

dtc [ time_constraint1 time_constraint2...]

Example
Following is an example of the DropTimingConstraint command.

droptimingconstraint TS08 TS09 TS10

ExcludeNets
The ExcludeNets command excludes paths that contain specified nets
from analysis. If a net is selected, paths through that net are not
analyzed. However, if no nets are selected, which is the default, all
nets, except those you exclude with other path filtering commands,
are analyzed.

This command is equivalent to the Path Filters → Common Filters →
Exclude Paths with Nets menu command.

Syntax
The syntax of the ExcludeNets command is the following.

ExcludeNets [ net_name1 net_name2...]

Net_name1, net_name2, and so forth are the names of the nets to be
excluded.

Abbreviation
Abbreviate the ExcludeNets command syntax as follows.

exnet [ net_name1 net_name2...]

Example
Following is an example of the ExcludeNets command.

excludenets $1N95 CNT5 CNT6 CNT7 EXT_CLK1 EXT_CLK2
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Exit
The Exit command exits the Timing Analyzer.

This command is equivalent to the File → Exit menu command.

Syntax
The syntax of the Exit command is the following.

exit

Abbreviation
Abbreviate the Exit command syntax as follows.

e

Example
Following is an example of the Exit command.

exit

IncludeNets
The IncludeNets command limits analysis to paths that contain speci-
fied nets. If a net is not specified, paths through that net are not
analyzed. However, if no nets are selected, which is the default, all
nets, except those you exclude with other path filtering commands,
are analyzed. This command is equivalent to the Path Filters →
Common Filters → Include Paths with Nets menu command.

Syntax
The syntax of the IncludeNets command is the following.

IncludeNets [ net_name1 net_name2...]

Net_name1, net_name2, and so forth are the selected nets.

Abbreviation
Abbreviate the IncludeNets command syntax as follows.

incnet [ net_name1 net_name2...]
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Example
Following is an example of the IncludeNets command.

includenets in2_1 in2_2

IncludeNoTimingConstraint
The IncludeNoTimingConstraint command includes paths without
timing constraints, in addition to paths with timing constraints, in
analysis.

This command is equivalent to the Path Filters → Timing Constraint
Filters → Report Paths Not Covered by Timing Constraints menu
command.

Syntax
The syntax of the IncludeNoTimingConstraint command is the
following.

IncludeNoTimingConstraint {true|false}

• True  reports paths with no timing concurrents (as well the paths
with timing constraints). It is the default setting when opening a
CPLD design.

• False  does not report paths with no timing constraints. This
argument is the default when opening an FPGA design.

Abbreviation
Abbreviate the IncludeNoTimingConstraint command syntax as
follows.

intc {t|f}

Example
Following is an example of the IncludeNoTimingConstraint
command.

includenotimingconstraint true
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MaxPathsPerTimingConstraint
The MaxPathsPerTimingConstraint command limits the number of
paths reported per timing constraint. For FPGAs, the default is one
path per timing constraint. For CPLDs, the default is unlimited. This
option can be useful, because it limits the size of report files. By
default, the Timing Analyzer reports all paths that satisfy the other
settings.

The command is equivalent to the Maximum Paths Per Timing
Constraint field in the Report Options dialog box, which is activated
by the Options → Report Options menu command.

Syntax
The syntax of the MaxPathsPerTimingConstraint command is the
following.

MaxPathsPerTimingConstraint number

Number is the maximum number of paths per timing constraint that
the Timing Analyzer reports. It is optional. No number turns the limit
Off.

Abbreviation
Abbreviate the MaxPathsPerTimingConstraint command syntax as
follows.

mpptc number

Example
Following is an example of the MaxPathsPerTimingConstraint
command.

maxpathspertimingconstraint 20

OmitUserConstraints
The OmitUserConstraints command enables or disables timing
constraints in the “USER” section of the Physical Constraints File
(PCF). The order of the timing constraints in the PCF file is reflected
by the Timing Analyzer. It only supports analysis of FPGA designs.
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This command is equivalent to the Omit User Constraints radio
button in the Disable Timing Constraints dialog box, which is acti-
vated by the Path Filters → Timing Constraint Filters → Disable
Timing Constraints menu command.

Syntax
The syntax for the OmitUserConstraints command is the following.

OmitUserConstraints {true|false}

• True  disables the “USER” timing constraints in the PCF file.

• False  enables the “USER” timing constraints in the PCF file.

Abbreviation
Abbreviate the OmitUserConstraints command syntax as follows.

ouc {t|f}

Example
Following is an example the OmitUserConstraints command.

omituserconstraints false

OnlyLongestPaths
The OnlyLongestPaths command restricts the Timing Analyzer to
reporting only the path with the longest delay, if there is more than
one path between two end points. It only supports analysis of CPLD
designs. By default, the Timing Analyzer reports all paths.

This command is equivalent to the Report Only Longest Paths
Between Points check box in the Report Options dialog box, which is
activated by the Options → Report Options menu command.

Syntax
The syntax of the OnlyLongestPaths command is the following.

OnlyLongestPaths {true|false}

• True  includes only the longest paths; it is the default when you
generate the Design Performance report.
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• False  includes all paths; it is the default when you generate any
report except the Design Performance report.

Abbreviation
Abbreviate the OnlyLongestPaths command syntax as follows.

olp {t|f}

Example
Following is an example of the OnlyLongestPaths command.

onlylongestpaths false

OpenDesign
The OpenDesign command opens a mapped NCD (FPGA) or a
completely placed and routed VM6 (CPLD) design file for timing
analysis. The mapped FPGA design can be partially or completely
placed, routed, or both.

This command is equivalent to the File → Open Design menu
command.

Syntax
The syntax of the OpenDesign command is the following.

OpenDesign { design_name.ncd| design_name.vm6}

Design_name is the NCD or VM6 file name, including the path of the
directory in which it is located.

This command does not open a report (TWR) file.

Abbreviation
You can abbreviate the OpenDesign command syntax as follows.

od desgin_name.ncd

Example
Following is an example of the OpenDesign command.

opendesign checkers.ncd
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OpenPCF
The OpenPCF command opens an existing physical constraints file
(PCF). This command applies only to FPGAs. The order of the
constraints in the PCF file is reflected by the Timing Analyzer.

This command is equivalent to the File → Open Physical Constraints
menu command.

Syntax
The syntax of the OpenPCF command is the following.

OpenPCF file_name.pcf

File_name is the name of the PCF file.

Abbreviation
You can abbreviate the OpenPCF command syntax as follows.

op file_name.pcf

Example
Following is an example of the OpenPCF command.

openpcf checkoffset.pcf

Query
The Query command reports timing information about particular
nets and members of time groups. This command applies only to
FPGAs. See the “Query (Analyze Menu)” section of the “Menu
Commands” chapter for the specific information that this command
reports.

This command is equivalent to the Options → Query menu
command.

Syntax
The syntax of the Query command is the following.

query {Net|TimeGroup} element_name

• Net  reports information about nets.
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• TimeGroup  reports information about timing groups.

• Element_name can be the following:

• Net name when you specify the net option.

• Timing group name when you specify the TimeGroup
option.

Abbreviation
Abbreviate the Query command syntax as follows.

qy {n|tg} element_name

Example
Following are examples of the Query command.

query net ram_d_o
query timegroup 05

Report
The Report command determines the format of the report output.

This command is equivalent to the Wide Report option in the Report
Options dialog box, which is activated by the Options → Report
Options menu command.

Syntax
The syntax of the Report command is the following.

report {wide|normal}

• Wide  sets a format of 132 characters per line, which prevents long
component and net names from being truncated.

• Normal , the default, displays a detailed list of path delays. The
width is 80 characters per line. Because normal is the default, it
does not appear as an option for the Report Options menu
command.

Abbreviation
You can abbreviate the Report command syntax as follows.
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r {w|n}

Example
Following is an example of the Report command.

report wide

ResetAllPathFilters
The ResetAllPathFilters command resets the path filtering commands
to the system defaults. See the “Settings (View Menu)” section of the
“Menu Commands” chapter for a listing of these defaults.

This command is equivalent to the Path Filters → Reset All Path
Filters menu command.

Syntax
The syntax of the ResetAllPathFilters command is the following.

ResetAllPathFilters

Abbreviation
Abbreviate the ResetAllPathFilters command syntax as follows.

rapf

Example
Following is an example of the ResetAllPathFilters command.

resetallpathfilters

RunMacro
The RunMacro command runs an existing macro.

This command is equivalent to the File → Run Macro menu
command.

Syntax
The syntax of the RunMacro command is the following.

RunMacro file_name.xtm
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File_name is the name of the macro file.

Abbreviation
You can abbreviate the RunMacro command syntax as follows.

runm file_name.xtm

Example
Following is an example of the RunMacro command.

runmacro deb.xtm

SelectFailingTimingConstraint
The SelectFailingTimingConstraint command reports only the paths
that do not meet timing constraints. This command is equivalent to
the Path Filters → Timing Constraint Filters → Report Paths Failing
Timing Constraints menu command.

Syntax
The syntax of the SelectFailingTimingConstraint command is the
following.

SelectFailingTimingConstraint {true|false}

• True  includes only the paths that do not meet your timing
constraints.

• False  includes all paths. This setting is the default.

Abbreviation
Abbreviate the SelectFailingTimingConstraint command syntax as
follows.

sftc {t|f}

Example
Following is an example of the SelectFailingTimingConstraint
command.

selectfailingtimingconstraint true
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SetForce
When you run a macro, the commands in the macro file can generate
informational, confirmational, and error messages. When the
SetForce command is set to On, the Timing Analyzer suppresses the
warning and confirmational messages that appear in dialog boxes.
Only error messages continue to appear. Macros continue to run until
an error is produced. You cannot suppress messages while executing
menu commands. SetForce Off restores the appearance of all three
types of messages to the Console window.

This command does not have an equivalent menu command.

Syntax
The syntax of the SetForce command is the following.

SetForce {on|off}

On suppresses the informational and confirmational messages, and
Off  restores them. On is the default.

Abbreviation
You can abbreviate the SetForce command syntax as follows.

sf {on|off}

Example
Following is an example of the SetForce command.

setforce on

ShowClockNets
The ShowClockNets command creates the Clocks report, which lists
the names of all clocks in the design.

This command is equivalent to the View → Clocks menu command.

Syntax
The syntax of the ShowClockNets command is the following.

ShowClockNets [save file_name]
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The report appears in a pop-up window.

• Save  indicates that you can optionally save the Show Clocks
report in a file.

• File_name is the name of the saved file. You can add a .twr exten-
sion to the file_name to list it under Timing Analysis Reports
(*.twr) under List Files of Type in File menu command dialog
boxes.

Abbreviation
You can abbreviate the ShowClockNets command syntax as follows.

scn [s file_name]

Example
Following is an example of the ShowClockNets command.

showclocknets save nikkoclocks

ShowSettings
The ShowSettings command lists all the current settings for Timing
Analyzer options. You can save the contents of the window as a
macro or a report.

This command is equivalent to the View → Settings menu command.

Syntax
The syntax of the ShowSettings command is the following.

ShowSettings [save file_name]

The report appears in a pop-up window.

• Save  indicates that you can optionally save the Show Settings
report in a file.

• File_name is the name of the saved file. You can add a .xtm exten-
sion to the file_name to save the settings as a macro to return the
system to the same state as when the settings were saved. See the
“Saving a New Macro” section and the “Running a Macro”
section of the “How to Use the Timing Analyzer” chapter for
more information.
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Or you can add a .twr extension to the file_name to save the
settings as a report. TWR files are listed as Timing Analysis
Reports (*.twr) under List Files of Type in File menu command
dialog boxes. See the “Saving a Report” section of the “How to
Use the Timing Analyzer” chapter for the procedure to save a
report.

Abbreviation
You can abbreviate the ShowSettings command syntax as follows.

ss [s file_name.xtm]

Example
Following is an example of the ShowSettings command.

showsettings save triad2.xtm

SortOn
The SortOn command specifies how paths are sorted when they are
reported. It only supports analysis of CPLD designs.

This command is equivalent to the Sort On field in the Report
Options dialog box, which is activated by the Options → Report
Options menu command.

Syntax
The syntax of the SortOn command is the following.

SortOn {Ascend|Descend|SourceNet|DestNet|
SourceClkNet|DestClkNet}

• Ascend  lists paths in order from shortest to longest delays.

• Descend , the default, lists paths in order from longest to shortest
delays.

• SourceNet  sorts path delays by the source net name, which is
useful when trying to determine the worst-case delay from a
given net.

• DestNet  sorts path delays by the destination net name, which
can help determine the worst-case path to each net.
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• SourceClkNet  sorts path delays by the clock name that sources
the first element in a path, which separates delay information for
two or more clock nets in a design.

• DestClkNet  sorts path delays by the clock name that sources
the last element in a path.

Abbreviation
You can abbreviate the SortOn command syntax as follows.

sort {a|d|sn|dn|scn|dcn}

Example
Following is an example of the SortOn command.

sorton sourcenet

Speed
The Speed command sets the speed grade during analysis. Changing
the speed grade helps you determine if you need to target a faster
device to meet your timing requirements, or if using a slower speed
grade still meets timing constraints. The speed grade is set in the
design file, NCD for FPGAs or VM6 for CPLDs. Using this command
does not affect the speed grade set in the design file.

This command is equivalent to the Options → Speed Grade menu
command.

Syntax
The syntax of the Speed command is the following.

speed speed_grade

Speed_grade can be any of the speed grades available for the architec-
ture used. You can obtain this information from the Design Manager
or the Timing Analyzer’s graphical interface.

Abbreviation
You can abbreviate the Speed command syntax as follows.

sp speed_grade
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Example
Following is an example of the Speed command.

speed -3
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Appendix A

Glossary

This chapter defines the key terms and concepts that you must under-
stand to use the Timing Analyzer effectively. The terms are listed in
alphabetical order.

BEL
A Basic ELement. Basic Elements are the building blocks that make
up a CLB or IOB—function generators, flip-flops, carry logic, and
RAMs.

CLB
The CLB, or Configurable Logic Block, constitutes the basic FPGA
cell. The FPGA is an array of CLBs organized in columns and rows on
the silicon die. CLBs are used to implement macros and other
designed functions. They provide the physical support for an imple-
mented and downloaded design. They have inputs on each side, and
this versatility makes them flexible for the mapping and partitioning
of logic. See The Programmable Logic Data Book for each device’s CLB.

clock input path
A clock input path is a logic transition, which when applied to a clock
pin on a synchronous element, captures data. It starts at either an
input or an output of the chip, but can also start at other sequential
elements. A clock input path propagates through any number of
levels of combinatorial logic and ends at any clock pin on a flip-flip,
latch enable, or synchronous RAM. These paths do not propagate
through synchronous elements. The clock input path time is the
maximum time required for the signal to arrive at the clock input of
the synchronous element.
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clock skew
The difference between the time a clock signal arrives at the source
flip-flop in a path and the time it arrives at the destination flip-flop.

clock-to-pad path
A path starting at the Q output of a flip-flop or latch and ending at an
output of the chip. It includes the clock-to-Q delay of the flip-flop and
the path delay from that flip-flop to the chip output. The clock-to-pad
path time is the maximum time required for the data to leave the
source flip-flop, travel through logic and routing, and arrive at the
output.

clock-to-setup path
A path starting at the Q output of a flip-flop or latch and ending at an
input to another flip-flop, latch, or RAM, where that pin has a setup
requirement before a clocking signal. It includes the clock-to-Q delay
of the source flip-flop, the path delay from that flip-flop to the desti-
nation flip-flop, and the setup requirement of the destination flip-
flop. The clock-to-setup path time is the maximum time required for
the data to propagate through the source flip-flop, travel through the
logic and routing, and arrive at the destination before the next clock
edge occurs.

component
A logical configuration that will, at some point, go into a physical
site. Examples of components are CLBs, IOBs, tristate buffers, pull-up
resistors, and oscillators.

console log
Record of the commands that you invoked during a session.

critical path
The path within a design that dictates the fastest time at which an
entire design can run. This path runs from the source to a sink node
such that if any activity on the path is delayed by an amount t, then
the entire circuit function is delayed by time t.
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destination
A sink node or stopping point for a timing analysis path, often the
data input of a synchronous element or a pad.

endpoints
A node which acts as either the driver to begin a path or a load to end
a path.

filter
A set of limitations or options applied to the timing analysis to more
specifically target important items of interest.

fitting
The process of putting logic from your design into physical macrocell
locations in a CPLD. Routing is performed automatically, and
because of the interconnect architecture, all designs are routable.

high-density function block (HDFB)
A group of macrocells in a CPLD that can efficiently perform complex
logic such as arithmetic operations.

hold time
The time following a clock event during which the data input to a
latch or flip-flop must remain stable in order to guarantee that the
latched data is correct.

IOB (input/output block)
A collection or grouping of basic elements that implement the input
and output functions of FPGA and CPLD devices.

macro
A physical macro is a logical function which has been mapped into the
components of a specific device family. Physical macros are stored in
files with the extension .nmc. In addition to components and nets, the
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file can also contain placement, routing, or both kinds of information.
A macro can be unplaced, partially placed, or fully placed. It can also
be unrouted, partially routed, or fully routed. See the “Working with
Physical Macros” chapter of the EPIC Design Editor Reference/User
Guide for information about physical macros.

Specific to the Timing Analyzer, a macro is an ASCII file containing a
sequence of Timing Analyzer keyboard commands that are executed
in script form.

main window
The background against which windows are displayed.

menu bar
The area located at the top of the main window that provides access
to the menus.

net
A logical connection between two or more symbol instance pins.
After routing, the abstract concept of a net is transformed to a phys-
ical connection called a wire.

offset
Defines the timing relationship between an external clock and its
associated data-in or data-out pin.

pad
The physical bonding pad on an Integrated Circuit. All signals on a
chip must enter and leave by way of a pad. Pads are connected to
package pins in order for signals to enter or leave an Integrated
Circuit package.

pad-to-pad path
A path starting at an input of the chip and ending at an output of the
chip. The pad-to-pad path time is the maximum time required for the
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data to enter the chip, travel through logic and routing, and leave the
chip. It is not controlled or affected by any clock signal.

pad-to-setup path
A path starting at an input of the chip and ending at an input to a flip-
flop, latch, or RAM—wherever there is a setup time against a control
signal. The pad-to-setup path time is the maximum time required for
the data to enter the chip, travel through logic and routing, and arrive
at the input before the clock or control signal arrives.

path
An ordered set of elements identifying a logic flow pathway through
a circuit. A path may consist of a single net or a grouping of related
nets and components. There can be multiple paths (consisting of nets
and components) between the two pins. When a component is
selected as part of a path, both the input pin to the component and
the output pin are included in the path. A path stops when it reaches
the data input of a synchronous element (flip-flop) or pad. A path
usually starts at the output of a synchronous element or pad.

Paths can be defined by using timing specifications. See the “XACT-
Performance Utility” chapter of the Development System Reference
Guide. In the “Path Example” figure, there are three paths between
Pin A and Pin B. One path travels from Pin A through LB2 and
through LB6 to Pin B, another travels from Pin A through LB3 and
through LB6 to Pin B, and another travels from Pin A through LB4,
LB5, and LB6 to Pin B.
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Figure 6-1 Path Example

period
The time specified for a clock signal to transition from a state back to
the same state. Also, a requirement placed on the clock signal that the
place and route software is expected to meet. The period of the clock
is affected by the amount of time it takes the output of one sequential
element to pass to the next sequential element in a path.

pin
A symbol pin or package pin. A package pin is a physical connector
on an Integrated Circuit package that carries signals into and out of
an Integrated Circuit.

A symbol pin, also referred to as an instance pin, is the connection
point of an instance to a net.

X6976

A

X6976

B

LB1 LB2

LB3

LB4 LB5

LB6
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primitive
A logic element that directly corresponds, or maps, to a basic
element.

schematic
A hierarchical diagram representing a design in terms of user and
library components.

SDF
Standard Delay Format, which is an industry-standard file format for
specifying timing information. It is often used for simulation.

sequential element
A flip-flop, synchronous RAM, or Latch.

setup time
The time relative to a clock event during which the data input to a
latch or flip-flop must remain stable in order to guarantee that the
latched data is correct.

slack
The difference between the constraint and the analyzed value, with
negative slack indicating an error condition.

source
An output pin that drives a path. Sources are input pads and the
outputs of synchronous elements.

static timing analysis
A point-to-point delay analysis of a design network with respect to a
given set of constraints. It does not include insertion of stimulus
vectors.
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status bar
An area located at the bottom of an application window that provides
information about the commands that you are about to select or that
are being processed.

time group
A collection of design elements, including nets, BELs, components,
and so forth that can be used to constrain many objects in the same
way.

timing constraints
A series of constraints applied to a given set of paths or nets that
dictate the desired performance of a design. Constraints may be
period, frequency, net skew, maximum delay between end points, or
maximum net delay.

toolbar
A group of buttons with graphic icons located under the menu bar in
the application window that provide button access to frequently used
commands in pull-down menus.

TRACE
The Timing Reporter And Circuit Evaluator provides static timing
analysis of a design based on input timing constraints. Its two major
functions are timing verification and reporting.

universal interconnect matrix (UIM)
The routing matrix for CPLD devices. This fully populated switching
matrix allows any output to be routed to any input, guaranteeing
100 percent routability of all designs. The UIM can also function as a
very wide AND gate, which can allow more logic to be placed in
macrocells.
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verification
In timing, the process of comparing the desired performance of a
design using constraints against the expected performance, based on
software models of the device speed and routing delays.

VHDL
An acronym for VHSIC Hardware Description Language (VHSIC is
an acronym for Very High-Speed Integrated Circuits) or HDL, which
can be used to model a digital system at many levels of abstraction
ranging from the algorithmic level to the gate level.
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Find command 5-18
Find What option 4-22

G

global routing 2-15

H

help 1-6, 3-12, 3-13, 5-8
Help button 3-5, 5-47
Help Contents command 3-12
Help icon 3-13
Help menu 1-6, 3-12, 5-4
Help option 3-13
hold time A-3

I

I/O Output to Pad path 5-10
I/O Pad to Input path 5-10
I/O pad to IOB input path

Control Path Tracing command 4-36
I/O Tristate Control to Pad path 5-10
Include Paths with Nets command 4-12, 4-18, 4-20,

4-33, 4-34, 5-5, 5-6, 5-15, 5-19, 5-39, 5-43
IncludeNets 6-14

Include Paths with Nets dialog box 5-19
IncludeNets command 6-14
IncludeNoTimingConstraint command 6-15
Input to output of TBUF path

Control Path Tracing command 4-36
inputs 1-3
IOB

definition A-3
IOB tristate control to pad path

Control Path Tracing command 4-36
IOBs

path destinations 5-33

K

keyboard
changing speed grade 4-28
selecting items in dialog boxes 3-7
selecting menu commands 3-4

L

List Files of Type option
Open Design dialog box 4-2
Index-3
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Open dialog box 4-24
Open Physical Constraints dialog box 4-3

M

macros 1-4, 1-5, 3-4, 3-12, 4-37
creating 4-38
editing 4-41
running 4-40, 5-32
saving 4-41, 5-32

edited 4-43
existing 4-42
new 4-39

suppressing messages 4-44
mapper 2-14
mapping 1-2
Match Case

Find command 5-18
maximum clock frequencies 1-4
maximum clock time 2-10
Maximum Number of Paths per Timing Constraint

option 4-26
Maximum Paths per Timing Constraint

Report Options command 5-30
MaxPathsPerTimingConstraint command 4-26, 6-16
menus 1-4

commands available 5-1
selecting commands 3-4

minimum clock time 2-10
minimum delay

nets 5-28
minimum net delay 4-6
mouse

changing speed grade 4-28
selecting items in dialog boxes 3-6
selecting menu commands 3-4

N

NCD or VM6 file
output by PAR 1-3

negative clock skew 2-16
Nets

Query command 5-27
Nets Not Selected list box 5-17, 5-21
Nets option

Query command 4-5
New Macro button 5-44
New Macro command 4-39, 5-21, 5-43

New Macro window 4-39, 6-1
adding text 4-39
deleting text 4-39
pasting text 4-39

Normal report
Report Options command 5-40

O

off-chip delay 2-18
OK button 3-5
OmitUserConstraints command 6-16
online help 3-12, 5-8
OnlyLongestPaths command 6-17
Open command 4-24, 4-40, 4-41, 5-21

Run Macro 5-46
Open Design button 4-1, 5-44
Open Design command 4-1, 5-22, 5-44, 6-18
Open Physical Constraints command 6-19
OpenDesign command 6-18
OpenPCF command 5-39, 6-19
Options menu 3-12, 5-4, 5-39
Output to input of IOB path

Control Path Tracing command 4-36
outputs 1-3

P

pads 4-31, 4-32
pad-to-pad path 1-4, 2-11, A-4
pad-to-setup path 2-12, A-5
Paste button 4-39, 5-43, 5-45
Paste command 5-45
Path Analysis Filters submenu 1-5, 4-28, 5-25
path filtering commands

All Paths report 4-20, 4-30, 4-34, 4-35
Control Path Tracing 4-35
Design Performance report 4-34, 4-35, 5-15
destinations 4-32
path analysis 4-30
paths with nets 4-33
resetting all 4-37
selecting sources 4-31
Timing Analysis report 4-34, 4-35
Timing Constraint Analysis report 4-12
timing constraints 4-29
using 4-28

path filters
All Paths report 5-5, 5-6, 5-8, 5-15, 5-19, 5-36
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Design Performance report 5-6, 5-8, 5-12, 5-15,
5-19, 5-33

destinations 5-33
Exclude Paths with Nets 5-15
path analysis 5-25
paths with nets 5-19
resetting 5-31
sources 5-36
Timing Analysis report 5-6, 5-8, 5-15, 5-19, 5-42
timing constraints 5-12, 5-31
viewing settings 4-4

path filters commands
Design Performance report 4-18

Path Filters menu 3-12, 4-28, 5-3, 5-39
Path Type

Control Path Tracing command 5-9
Path Type field

Control Path Tracing command 4-36
path types

CPLD 2-1
setup to clock at the pad 2-10

paths ending at clock pin of flip-flops 2-10
PCF file

OmitUserConstraints command 6-16
period A-6
physical constraints file

opening 4-3
placing and routing 1-2
positive clock skew 2-16
Print button 4-22, 5-44
Print command 4-22, 5-25, 5-44

Q

Query command 2-18, 4-5, 5-26, 6-19
Query Nets report 1-5
Query Timegroups report 1-5

R

RAM 2-12, A-5
control path tracing 5-8

RAM Data to Output path 5-9
RAM WE to Output path 5-10
Report command 6-20
Report Delays Greater Than

Report Options command 5-30
Report Delays Greater Than option 4-27
Report Delays Less Than

Report Options command 5-30
Report Delays Less Than option 4-26
Report only longest paths 5-40
Report Only Longest Paths Between Points

Report Options command 5-31
Report Only Longest Paths Between Points option 4-

27
Report Options

OnlyLongestPaths 6-17
Report Options command 4-25, 5-29, 5-40, 6-20

DelayGreaterThan 6-11
DelayLessThan 6-12
MaxPathsPerTimingConstraint 6-16
SortOn 6-25

Report Paths Failing Timing Constraints command 4-
12, 4-18, 4-29, 5-15, 5-31, 5-39, 5-42, 5-43,
6-22

Report Paths Not Covered by Timing Constraints
command 4-12, 4-18, 4-29, 5-15, 5-31, 5-
40, 5-43, 6-15

reports
closing 4-23
creating 4-8
customizing 4-25
opening saved 4-24
printing 4-22
saving 4-20, 5-32
searching for text 4-21

Reset All Path Filters command 4-36, 4-37, 5-31, 6-
21

ResetAllPathFilters command 6-21
Run 5-46
Run Macro button 4-41, 5-43, 5-46
Run Macro command 4-41, 4-44, 5-32, 5-46, 6-21
RunMacro command 6-21

S

Save As command 5-32
Save As dialog box 4-21, 5-32
Save As Macro command 4-43
Save button 4-20, 4-40, 5-44
Save command 4-20, 4-40, 4-41, 4-42, 5-32, 5-44
See Open Physical Constraints command 5-39
Select Destinations command 4-20, 4-32, 5-5, 5-25,

5-33, 5-40
DefineEndPoints 6-8

Select Sources command 4-20, 4-31, 5-5, 5-25, 5-36,
5-40

DefineEndPoints 6-8
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Selected Destinations list box
Select Destinations command 5-35

Selected Nets list box 5-17, 5-21
Selected Nets/TimeGroups list box

Query command 5-28
Selected Sources list box

Selected Sources command 5-38
SelectFailingTimingConstraint command 6-22
Set Force command 4-44
SetForce command 6-23
settings

current 1-5
Settings command 4-4, 5-31, 5-39, 6-24
Settings report 1-5
Settings window 4-4
Setup

Print command 5-26
setup and hold checks 1-2
setup time 2-12, A-5, A-7
setup-to-clock-at-the-pad path 1-4, 2-10
Show Command Status box 4-38, 5-7, 5-8
ShowClockNets command 6-23
ShowSettings command 6-24
Sort On

Report Options command 5-30
Sort On option 4-26, 4-27
SortOn command 6-25
source clock edge option

Select Sources 4-31
Source Clock Net

Sort On option 5-30
Source Clock Net path 4-27
Source Element list box

Select Sources command 5-38
Source Element Type

Select Sources command 5-38
Source Element Type option

Select Sources command 4-31
Source Net

Sort On option 5-30
Source Net path 4-27
sources 4-31
Speed command 6-26
speed grade 4-28, 6-26
Speed Grade command 4-28, 5-39, 5-41, 6-26
starting Timing Analyzer 3-1
static timing analysis A-7
status bar

location in Timing Analyzer window 3-4
Status Bar command 3-3, 5-41

Summary Report Only
Report Options command 5-30

Summary Report Only option 4-25
synchronous Reset 4-33

T

TBUF Input to Output path 5-10
TBUF Tristate Control to Output path 5-10
Tile command 5-42
TimeGroup option

Query command 4-6
TimeGroups

Query command 5-27
Timing 1-4
timing analysis

filtering 5-43
Timing Analysis report 1-4, 1-5, 4-9, 4-25, 4-29, 4-30,

4-34, 4-35
Analyze Timing Constraints command 5-45
AnalyzeTimingConstraints command 6-6
Common Filters submenu 5-6
Control Path Tracing command 5-8
Exclude Paths with Nets command 5-15
Include Paths with Nets command 5-19
Report Paths Failing Timing Constraints

command 5-31
Report Paths Not Covered by Timing Constraints

command 5-31
Timing Constraint Filters submenu 5-43

Timing Analyzer window 3-3
timing constraint filters 5-43

Design Performance report 5-43
Timing Analysis report 5-43

Timing Constraint Filters submenu 1-5, 4-28, 5-42, 5-
43

timing constraints 2-14, 4-9, A-8
disabling 4-30
failing 6-22
filtering 4-29
ignore 6-12
ignoring 5-12
reporting paths that do not meet 5-31
reporting paths with no 4-29
reporting paths with none 5-31

Timing Constraints command 4-9, 5-46
timing groups 4-6

Query command 5-27
timing specifications

reporting paths that do not meet 4-29
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tool tip 5-43
Timing Analyzer buttons 3-4

toolbar 1-4
buttons 3-4, 5-43
displaying 5-43
location in Timing Analyzer window 3-4

Toolbar command 3-3, 5-43
Transparent latch input to output path

Control Path Tracing command 4-36
Tristate to output pin of TBUF path

Control Path Tracing command 4-36

U

Up search direction 5-18
Up setting

Find command 4-22

V

View menu 5-2

W

Wide Report
Report Options command 5-31

wildcards 3-8
Window menu 5-4
Windows Program Manager

starting the Timing Analyzer 3-1
worst-case path delay 1-4, 4-18
Write Enable of CLB RAM path

Control Path Tracing command 4-36

X

Xilinx report files see TWR files
XTM files 1-3, 4-41
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