
Chapter 3

HDL Editor

Introduction
The HDL editor is used for entering and editing designs expressed by
ABEL and VHDL programs statements. The HDL editor is invoked by

clicking on the HDL Editor icon in the Project Manager.

The welcome screen (Figure 3-1) that appears after invoking the HDL
Editor allows:

r creating new document using the HDL Design Wizard (please refer to
the File |New option description in this manual),

r creating empty document,
r opening existing document,

Figure 3-1. HDL Editor Welcome Screen.
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r selecting one of the recently opened documents.

After selecting one of those options the HDL editor main window is dis-
played (Figure 3-2).

A set of menus at the top of the window allows for detailed design ma-
nipulations and processing. For speedy access, the HDL editor provides
a set of icons, which are grouped according to their operational functions.

Toolbar Icons

Project Control Icons

The New icon starts Design Wizard. Upon entering I/O ports for
the new design, HDL editor opens a blank file for entering an HDL de-
sign.

The Open icon activates the Open window which allows selecting
one of the existing HDL files. The Open window (Figure 3-3) is typical of
Windows applications and no details on its operation are offered here.

Figure 3-2. HDL Editor Main Window.
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The Save icon saves the current HDL file on hard disk.

Print Icon

Clicking on the Print icon displays the typical Windows print
screen. The printer setup window (Figure 3-4) allows setting the print
range and selecting the printer and the number of printed copies. Check-
ing off the Print to file box, will generate a file instead of printout.

Clicking on the Properties button activates the Printer Properties win-
dow (Figure 3-5), which allows an advanced setup of the page format:

Figure 3-4. Opening An Existing HDL Project.

Figure 3-3. The Printing Options.
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r Paper size and orientation
r Layout of the pages
r Unprintable areas
r Paper tray

Copy, Cut And Paste Icons

These operations are typical Windows copy, cut and paste operations,
such as found in many text editors. Since there are no exceptions to the
commonly accepted rules and procedures, description of these features is
cursory. All characters are copied into the clipboard, without any excep-
tion.

Clicking on the Cut icon cuts the selected area off the screen and
saves it to a software clipboard.

Clicking on the Copy icon copies the selected screen area into the
clipboard but does not delete the selected area from the screen.

Figure 3-5. Advanced Printing Options.
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Clicking on the Paste icon places the contents of the clipboard at the
current cursor location.

Undo & Redo Icons

Clicking on the Undo icon reverses previous operations performed
in the HDL Editor.

Clicking on the Redo icon restores the state preceding the last Undo
operation.

Find Combo Box

Entering a text in the Find combo box and press-
ing Enter finds the text in the HDL Editor window.

Previously entered texts can be recalled to the Find combo box by click-
ing on the “down arrow” button and selecting them with the mouse.
Double clicking on the text finds its first occurence in the HDL Editor
window. Successive double clicking on the text finds its next occurences.

Creating VHDL File - Language Assistant

The VHDL language is considered verbose by some because requires
many statements that are not typical of other software programs. How-
ever, with the help of language assistant, all you need to enter is the de-
sign specific information, such as port names, generics, etc. Because of
this simplification introduced by the Language Assistant utility, VHDL
code is easy to write and maintain.

If you try to learn VHDL from books, you may find it too complex and
difficult. And if you write a VHDL code totally from scratch, you may
find it cumbersome and prone to syntax errors. However, writing VHDL
code with the language assistant is easy and efficient way to describe
physical phenomena in electronics, hydraulics and pneumatics. Becom-
ing familiar with the language assistant speeds learning of the VHDL lan-
guage.

Clicking on the Language Assistant icon activates the Language As-
sistant window (Figure 3-9), which allows selection of the language tem-
plates and logic synthesis templates.

Some turn-key solutions have the HDL editor preset for a specific HDL-
logic synthesis configuration, and no setup of the HDL environment is
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needed. However, as a general rule, select the desired HDL design envi-
ronment before using the language assistant.

To set the HDL design environment, click on the Synthesis|Configura-
tion menu. When the Configuration window(Figure 3-6) is displayed,

r select VHDL in the Language field,
r select the HDL compiler from the drop-down list in the Tool field,
r select internal (performed by the HDL Editor) or external (performed

by the selected synthesis tool) syntax checking.

NOTE: Because none of the logic synthesis tools can work directly with
the 1076 VHDL code, HDL compilers need to be especially matched for
the selected logic synthesis tool.

Selecting the Colors tab in the Tools | Preferences window (Figure 3-7),
displays a list of items which color can be set from that folder:

r Normal text
r Comments
r Keywords of the HDL language
r Program Constants
r Meta Symbols

Figure 3-6. Selecting HDL Environment.
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Clicking on the Editor tab in the Tools | Preferences window displays a
card (Figure 3-8) that allows setting Enable highlighting, Show margin,
and Auto indent options . The card also enables changing the tabulation
size and error description length.

Figure 3-7. The HDL Program Colors Card.

Figure 3-8. Editor Preferences Card.
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After the HDL environment has been selected, click on the Language As-
sistant icon. In response, the Language Assistant window (Figure 3-9)
will appear, and offer three main choices:

r Language Templates; used for writing general VHDL statements such
as architecture, block statement, signal declaration, etc.

r Synthesis Templates; providing complete hardware description blocks
such as D Flip-flop, asynchronous counter, multiplexer, shift register, etc.

r Synthesis Templates; enabling the user to store frequently used frag-
ments of code for the quick retrieval.

Clicking on the ‘+’ sign by the Language Templates option in the Lan-
guage Assistant window will display a list of language templates. Select-
ing the template and clicking on the Show preview>> button will
display the template (Figure 3-10).

Clicking with the right mouse button on the template name displays a lo-
cal menu with five options: Use, Edit, New, Delete and Read Only.

r Use transfers template text to the editor.
r Edit enables template name change.
r New allows creating new templates; the text of the new template can

be entered in the preview section of the Language Assistant window.
r Delete removes template from the list
r Read Only - when checked, makes template protected, i.e. disables

any changes to the template name and text (Language and Synthesis
templates have the Read Only options checked to prevent entering
accidental changes).

Figure 3-9. Language Assistant Options.
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Note:
Any changes can be made to the unprotected template text in the Pre-
view section of the Language Assistant window. A prompt for saving tem-
plate changes is displayed during the exit from HDL Editor.

Language assistant allows the following transfers of templates into HDL
editor:

r unaltered - by clicking on the Use button transfers the original template
into HDL editor

r partial - by selecting an area of the template and clicking on the Use
button.

The design data can be entered into any template that has been trans-
ferred into the HDL editor program.

Check Syntax Icon

The Check Syntax icon activates the 1076 IEEE VHDL analyzer and
checks for syntax errors.

Note: If the title bar of the HDE shows “untitled.vhd” design file name,
standard Save As window (Figure 3-11) will be displayed to enable sav-
ing of the edited file.

Figure 3-10. Language Assistant With Template Preview.
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Compile Icon

The Compile icon, activates the logic synthesis tool that has been se-
lected in the Synthesis |Configuration menu. The logic synthesis tool
must be present and active to run this option. Otherwise, the HDL editor
will produce a warning about the missing logic synthesis tool and will
discontinue compilation.

Since logic synthesis tools can only work with their proprietary subsets
of the 1076 IEEE VHDL language, the source code displayed in the HDL
editor is compiled according to the setups that are required by the se-
lected logic synthesis tool. To simplify user interface, these setups are fac-
tory made and are hidden from the user. Selecting the desired logic
synthesis tool automatically forces certain established setups in the HDL
editor and compiler.

The compilation error report produced by the logic synthesis tool is dis-
played at the bottom of the screen in Figure 3-1.

View Report Icon

Clicking on the View Report icon invokes Report Browser with the
synthesis report generated by the selected synthesis tool.

Figure 3-11. Standard Save As Window.
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About Icon

The About icon displays the current version of the HDL Editor and
the copyright notice.

Help Icon

Clicking on the Help icon produces the “question mark” cursor.
Clicking with this cursor over an HDL Editor interface element (toolbar
button, menu option etc.) , will display a brief description of that element.

HDL Editor Main Menu
The editor operations are grouped into five menus, listed in the HDL Edi-
tor window (Figure 3-13).

Figure 3-12. Displaying 'About HDL Editor' Window.

Figure 3-13. HDL Editor Menus.
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File menu
The File menu (Figure 3-14) includes typical Windows operations, such
as New, Open, Save, Save As, Print, etc. These items are similar to the
ones described in reference to the schematic editor and state machine edi-
tor File menus.

File|New

The File|New option starts HDE Design Wizard. Select the HDL lan-
guage (ABEL or VHDL) in the Language window (Figure 3-15) and click
on the Next button.

Figure 3-14. File Menu.
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Enter the HDL design name in the Name window (Figure 3-16) and click
on the Next button.

Clicking on the New button in the Ports window activates the port entry
fields in the figure 3-17. Enter the port name into the Name field. Select
its direction from the Direction field, and choose the port Type by click-

Figure 3-16. Design Wizard - Language Screen.

Figure 3-15. Design Wizard - Name Screen.
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ing on the Advanced button and making appropriate selections from the
new window.

Entering the CLOCK input port will display the figure 3-18 shown below.

HDL Editor assigns by default the std_logic type to each single line ports.
However, if a different port type is required, click on the Advanced but-

Figure 3-17. Design Wizard - Ports Screen.

Figure 3-18. Design Wizard With CLOCK Input Entry.
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ton which will display the Advanced Port Settings window. This win-
dow allows setting other VHDL allowable port types.

Clicking on the New button transfers the entered port (Name, Direction,
Type) into the port listing field.

Port Types

If the VHDL option has been selected, then the HDL editor will automat-
ically set single line inputs and outputs to the STD_LOGIC Type, and
buses will be set to the STD_LOGIC_VECTOR Type. If other types are re-
quired, select the port type from Advanced Port Settings window. This
window allows setting other VHDL allowable port types

Editing Ports

To edit a port, click on it in the listing of ports. It will automatically be
copied into the Name field. Then you can edit it in the Name, Port Type
and Advanced Port Settings window. The changes are applied to the se-
lected port as long as it remains selected in the listing.

When entering of ports has been completed, click on the Finish button.
HDL Editor automatically displays the entity section of the VHDL code,
based on the declared input ports. Using language assistant, you can add
to this code some other VHDL constructs.

Figure 3-19. Advanced Port Settings Window.
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File|Open

The File|Open option allows to open one of the existing HDL projects.
The operation of this option is similar to the File|Open option in other
Windows programs. A sample of the Open window is shown below.

Figure 3-20. Entity Section Created by Design Wizard.

Figure 3-21. Open File Window.
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File|Print

This option operates same as in other Windows products.

File|Print Preview

This option operates same as in other Windows products.

File|Print Setup

This option operates same as in other Windows products.

Edit menu
The Edit menu options are listed in figure 3-23.

Options Undo, Redo, Cut, Copy, Paste are described in the Toolbar Icons
section.

Delete and Select All operate similarly to equivalent options in such
text editors as Microsoft Word and others.

Figure 3-22. Editor Window After File Open Operation.
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Edit|Symbol

This option allows making changes to the symbol that will be generated
during the macro creation or update. To edit port name, direction or type
click on it in the View Symbol window (figure 3-24) and enter changes.

Edit|Read Only

This option, when checked, switches the editor to Read Only mode. In
this mode no changes in the edited file are allowed.

Figure 3-23. Edit Menu.

Figure 3-24. View Symbol Window.
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Search Menu
The Search menu options are shown on figure 3-25.

Find, Find Next and Replace operate similarly to equivalent options in
other text editors.

The Search|Previous Error option underlines the line where the pre-
vious compilation error ocurred. The line is also marked with the red tab
on the left gray margin.

The Search|Next Error option underlines the line where the next compi-
lation error ocurred. The line is also marked with the red tab on the left
gray margin.

The Search|Go To option allows moving of the cursor to the specified
line number.

The Search|Toggle bookmark option sets the blue tab on the left margin
of the current line. Jumping from one line marked this way to the other is
available by selecting Search|Previous Bookmark or Search|Next Book-
mark options. All bookmarks can be removed by choosing Search|Clear
All Bookmarks option.

Figure 3-25. Search Menu.
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View Menu
The View menu options are shown on figure 3-26.

The View|Toolbar option activates the toolbar with icons for direct con-
trol of the most popular option. These icons are located at the top of the
display screen.

The View|Status Bar option activates the message bar at the bottom of
the screen. The message bar lists warnings advisory notes, etc.

The View|Line Numbers option activates numbering of lines in the
HDL code.

Synthesis Menu
The Synthesis menu options are shown on figure 3-27.

Figure 3-26. View Menu.

Figure 3-27. Synthesis Menu.
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Synthesis|Configuration

This option displays the window shown on figure 3-6 that allows synthe-
sis tool selection. This option is described in the Toolbar Icons section.

Synthesis|Check Syntax

The HDL Editor comes with a 1076 IEEE VHDL compiler, which oper-
ates as a spell checker of the edited VHDL code. This option invokes the
VHDL compiler, which verifies the HDL constructs with the VHDL
standard and restrictions imposed by the selected logic synthesis tool.

Errors detected during the syntax checking are listed in the special sec-
tion at the bottom of the HDL Editor window. The line containing first er-
ror is underlined and marked with the red tab on the left margin (Figure
3-28). Lines that contain other errors can be marked by double clicking
on the error description in the error list or by using Search|Next Error or
Search|Previous Error options.

Synthesis|Options

This option allows you to set the compilation parameters of the selected
logic synthesis tool. (If XVHDL is selected this option displays the win-
dow shown in figure 3-29).

The compilation parameters may include:

Optimize field

r Optimization for area and speed (a compromise solution)
r Optimize for speed
r Optimize for the best use of silicon area

Figure 3-28. Syntax Checking Results.
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The Effort Level options determines how much time the processing
should take:

r High; take as much time as required to do a high performance layout
r Medium; conserve computer RAM memory
r Low; just provide an information for simulation.

NOTES:

1. Generally, you should uncheck X-BLOX option, if not in use.

2. Use Improvex software for higher conversion optimization.

3. If the design is for a macro, select the Macro option. If compilation of
the entire device should take place, select Chip option from the Com-
pile field.

The Advanced card from the VHDL options window allows selecting
VHDL entity and architecture that will be synthesized.

The Library Alias card allows attaching additional VHDL files to the
standard libraries.

Synthesis|Synthesize

This option invokes the logic synthesis tool software which compiles the
HDL Editor code into a target FPGA device. All errors produced by the
logic synthesis tool are listed at the bottom of the HDL Editor screen.

Line containing the first error on the list is underlined and marked with
the red tab on the left margin (Figure 3-30). Using Search|Next Error op-

Figure 3-29. VHDL Options Window.
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tion or double clicking on the error description moves the red tab to the
appropriate line.

Synthesis|View Report

Lists all messages generated by logic synthesis tools and the HDL compil-
ers checking for syntax errors. This option can also be invoked from the
toolbar.

Project Menu
The Project menu options are shown in figure 3-31.

The Project|Add To Project option registers the edited file as the current
project resource.

Figure 3-30. Compilation Error Messages.

Figure 3-31. Project Menu.
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The Project|Create Macro option creates ACTIVE-CAD macro from the
current HDL code. This option is inactive when the macro has already
been created.

The Project|Update Macro option updates the ACTIVE-CAD macro af-
ter the changes in the HDL source code. This option is inactive when the
macro has not been created.

Tools Menu
The Tools menu options are shown in figure 3-32.

Tools|Preferences

The HDL Editor features such as fonts and colors used in the editing win-
dowor editor options may be customized by selecting Tools|Preferences
option. The Preferences window allows changing settings on three
cards: Editor, Font and Colors. The Editor and Color cards are described
in the Toolbar Icons section and shown in figures 3-7 and 3-8.

The Fonts card (Figure 3-33) allows selecting name, size and style of the
font used in the editing window. Deselecting Show Proportional check
box limits the list of names displayed in Font list box. to fixed width
fonts only. Using fixed width fonts is suggested to preserve clear indent-
ing of the edited text.

Figure 3-32. Tools Menu.
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Tools|Language Assistant

Refer to the Language Assistant Icon section for details.

Tools|Project Manager

This option brings on top the Project Manager window.

Help Menu
The Help menu options are shown in figure 3-34.

The Help|Help Topics option displays the list of subjects covered by the
HDL Editor help system.

Figure 3-33. Preferences Window - Fonts Card.

Figure 3-34. Help Menu Options.
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The Help|Using Help option displays essential information on using
Windows help.

The Help|About HDL Editor... option displays the version number and
copyright notice shown on figure 3-12.
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