
HW-130 Programmer User Guide - 0401575 01 Printed in U.S.A.

Getting Started

Programmer Operations

Command Reference

Keyboard Reference

Diagnostics Procedures

Automation

Wiring Conventions

HW-130
Programmer
User Guide



HW-130 Programmer User Guide

Xilinx Development System

, XILINX, XACT, XC2064, XC3090, XC4005, XC-DS501, FPGA Architect, FPGA Foundry, NeoCAD,
NeoCAD EPIC, NeoCAD PRISM, NeoROUTE, Plus Array, Plustran, P+, Timing Wizard, and TRACE are registered
trademarks of Xilinx.

, all XC-prefix product designations, XACTstep, XACTstep Advanced, XACTstep Foundry, XACT-Floorplanner,
XACT-Performance, XAPP, XAM, X-BLOX, X-BLOX plus, XChecker, XDM, XDS, XEPLD, XPP, XSI, BITA,
Configurable Logic Cell, CLC, Dual Block, FastCLK, FastCONNECT, FastFLASH, FastMap, HardWire, LCA, Logic
Cell, LogiCore, LogicProfessor, MicroVia, PLUSASM, PowerGuide, PowerMaze, Select-RAM, SMARTswitch,
TrueMap, UIM, VectorMaze, VersaBlock, VersaRing, and ZERO+ are trademarks of Xilinx. The Programmable
Logic Company and The Programmable Gate Array Company are service marks of Xilinx.

IBM is a registered trademark and PC/AT, PC/XT, PS/2 and Micro Channel are trademarks of International Business
Machines Corporation. DASH, Data I/O and FutureNet are registered trademarks and ABEL, ABEL-HDL and ABEL-
PLA are trademarks of Data I/O Corporation. SimuCad and Silos are registered trademarks and P-Silos and P/C-
Silos are trademarks of SimuCad Corporation. Microsoft is a registered trademark and MS-DOS is a trademark of
Microsoft Corporation. Centronics is a registered trademark of Centronics Data Computer Corporation. PALASM
is a registered trademark of Advanced Micro Devices, Inc. UNIX is a trademark of AT&T Technologies, Inc. CUPL,
PROLINK, and MAKEPRG are trademarks of Logical Devices, Inc. Apollo and AEGIS are registered trademarks
of Hewlett-Packard Corporation. Mentor and IDEA are registered trademarks and NETED, Design Architect,
QuickSim, QuickSim II, and EXPAND are trademarks of Mentor Graphics, Inc. Sun is a registered trademark of
Sun Microsystems, Inc. SCHEMA II+ and SCHEMA III are trademarks of Omation Corporation. OrCAD is a
registered trademark of OrCAD Systems Corporation. Viewlogic, Viewsim, and Viewdraw are registered
trademarks of Viewlogic Systems, Inc. CASE Technology is a trademark of CASE Technology, a division of the
Teradyne Electronic Design Automation Group. DECstation is a trademark of Digital Equipment Corporation.
Synopsys is a registered trademark of Synopsys, Inc. Verilog is a registered trademark of Cadence Design Systems,
Inc.

Xilinx does not assume any liability arising out of the application or use of any product described or shown herein;
nor does it convey any license under its patents, copyrights, or maskwork rights or any rights of others. Xilinx
reserves the right to make changes, at any time, in order to improve reliability, function or design and to supply
the best product possible. Xilinx will not assume responsibility for the use of any circuitry described herein other
than circuitry entirely embodied in its products. Xilinx devices and products are protected under one or more of
the following U.S. Patents: 4,642,487; 4,695,740; 4,706,216; 4,713,557; 4,746,822; 4,750,155; 4,758,985;
4,820,937; 4,821,233; 4,835,418; 4,853,626; 4,855,619; 4,855,669; 4,902,910; 4,940,909; 4,967,107; 5,012,135;
5,023,606; 5,028,821; 5,047,710; 5,068,603; 5,140,193; 5,148,390; 5,155,432; 5,166,858; 5,224,056; 5,243,238;
5,245,277; 5,267,187; 5,291,079; 5,295,090; 5,302,866; 5,319,252; 5,319,254; 5,321,704; 5,329,174; 5,329,181;
5,331,220; 5,331,226; 5,332,929; 5,337,255; 5,343,406; 5,349,248; 5,349,249; 5,349,250; 5,349,691; 5,357,153;
5,360,747; 5,361,229; 5,362,999; 5,365,125; 5,367,207; 5,386,154; 5,394,104; 5,399,924; 5,399,925; 5,410,189;
5,410,194; 5,414,377; 5,422,833; 5,426,378; 5,426,379; 5,430,687; 5,432,719; 5,448,181; 5,448,493; 5,450,021;
5,450,022; 5,453,706; RE 34,363, RE 34,444, and RE 34,808. Other U.S. and foreign patents pending. Xilinx, Inc.
does not represent that devices shown or products described herein are free from patent infringement or from any
other third party right. Xilinx assumes no obligation to correct any errors contained herein or to advise any user of
this text of any correction if such be made. Xilinx will not assume any liability for the accuracy or correctness of
any engineering or software support or assistance provided to a user.

Xilinx products are not intended for use in life support appliances, devices, or systems. Use of a Xilinx product in
such applications without the written consent of the appropriate Xilinx officer is prohibited.

Copyright 1991-1995 Xilinx, Inc. All Rights Reserved.

R



HW-130 Programmer User Guide i

Declaration of Conformity

Manufacturer’s name and address:

Xilinx Inc.
2100 Logic Drive
San Jose, CA 95124
U.S.A.

declares that the product:

Product name: Programmer
Model number: HW-130

conforms to the following standards:

EMC:
EN55022:1995 Class B ITE
EN50082-1:1992
IEC 1000-4-2:1995 Level 3
IEC 1000-4-3:1995 Level 2
IEC 1000-4-4:1995 Level 2

Safety: EN60950:1992/A1:1993/A2:1993/A3:1995

This product complies with the requirements of the EMC Directive
89/336/EEC , and the Low Voltage Directive 73/23/EEC.

Hardware Engineering Group
San Jose, CA, U.S.A.
April 1997

European contact:

Xilinx Ireland
Logic Drive, Citywest Business Campus
Saggart, Co. Dublin
Ireland



HW-130 Programmer User Guide

ii Xilinx Development System



HW-130 Programmer User Guide iii

Preface

About This Manual
This manual describes Xilinx’s HW-130 Programmer and its interface
software. The HW-130 Programmer is a tool used for programming
Xilinx programmable devices on a PC in a DOS or Windows
environment or on a UNIX workstation. Although this manual
emphasizes Windows PC installations, DOS and UNIX differences
are noted where applicable.

Manual Contents
This manual covers the following topics.

● Chapter 1, “Getting Started,” describes the HW-130 Programmer
hardware and explains how to install the hardware and its
accompanying software.

● Chapter 2, “Programmer Operations,” is a step-by-step
description of all software procedures for the programmer.

● Chapter 3, “Command Reference,” lists and describes the
programmer commands alphabetically.

● Appendix A, “Keyboard Reference,” lists the keyboard shortcuts
used to interface with the programmer and to navigate on the
programmer display.

● Appendix B, “Diagnostics Procedures,” covers auto-calibration
and diagnostics.
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● Appendix C, “Automation,” explains how to use the programmer
with an autohandler to automate device programming.

● Appendix D, “Wiring Conventions,” covers power plug and serial
connector drawings.



HW-130 Programmer User Guide v

Conventions

The following conventions are used in this manual’s syntactical
statements:

Courier font System messages or program files appear
regular in regular Courier font.

Courier font Literal commands that you must enter in
bold syntax statements are in bold Courier font.

italic font Variables that you replace in syntax
statements are in italic font.

[ ] Square brackets denote optional items or
parameters. However, in bus specifications,
such as bus [7:0], they are required.

{ } Braces enclose a list of items from which
you must choose one or more.

· A vertical ellipsis indicates material that has
· been omitted.
·

. . . A horizontal ellipsis indicates that the
preceding can be repeated one or more
times.

| A vertical bar separates items in a list of
choices.

↵ This symbol denotes a carriage return.
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Chapter 1

Getting Started

This manual covers installation and use of the HW-130 Programmer
and its interface software, which are designed to program Xilinx
programmable device families on PCs running DOS, Windows,
SunOS, Sun Solaris, HP, or IBM UNIX workstations.

● Installation of the HW-130 Programmer and interface software is
covered in this chapter.

● Programming procedures are covered in the “Programmer
Operations” chapter.

● An alphabetical list and description of commands are included in
the “Command Reference” chapter.

The HW-130 Programmer is a desktop unit that communicates with a
host computer system by means of an RS-232 serial port using the
HW-130 Programmer software.

The interface software enables you to select a device and download
its algorithm to the HW-130 Programmer, ensure that the device is
blank, program the device, and verify that the device has been
programmed correctly.

Hardware and Software Requirements
The following are the minimum requirements needed for the
different systems.

PC Installations
If you have a PC, ensure your system meets the following system
requirements.

● PC 80286 and higher
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● DOS Version 3.3 or higher (DOS installations only)

● Windows 95 or Windows NT or Windows 3.1x (Windows
installations only)

● RS-232 serial port

● 495 KB conventional memory (DOS only)

● 2 MB of hard disk space available

● Serial mouse (recommended)

The HW-130 Programmer software controls the HW-130 Programmer
from the keyboard or the mouse. See Appendix A for a summary of
keyboard quick keys.

Workstation Installations
If you have a workstation, ensure your system meets the following
system requirements.

● 6 MB of hard disk space available

● DB25 or DB9 serial port with read and write permissions

● X-based Windows Manager (X11R5 or higher)

● Operating System:

The HW-130 Programmer software controls the HW-130 Programmer
from the keyboard or the mouse. See Appendix A for a summary of
keyboard quick keys.

Hardware Installation
This section explains how to install and configure the HW-130
Programmer.

SunOS: SunOS 4.1.3 or higher

Solaris: SunOS 5.3 or higher (Solaris 2.3 or higher)

HP9000/700: HP-UX 09.05 or higher

IBM RS6000: AIX 3.2.5.0 or higher



Getting Started

HW-130 Programmer User Guide 1-3

HW-130 Programmer Description
The HW-130 Programmer comes with the following items:

● RS-232 9-to-9-pin data cable and 9-to-25-pin adapter

● 25-pin female adapter for PC and IBM workstation users

● 25-pin male adapter for Sun workstation users

● HP workstation users do not need a 9-to-25-pin adapter

● Universal Power Supply

● Power Cord

● Software

● User Guide

● Vacuum Handling Tool Kit

The HW-130 Programmer consists of a base with a 96-pin connector
on top of the case to attach the different socket adapters for each
device and package type.

Socket adapters are available for each of the different product
families.

As indicated in Figure 1-1, the top of the programmer case has three
LEDs: red (fail), green (pass), and a power indicator. A push-button is
used for operator responses.
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Figure 1-1 Top Panel of Programmer

On the back panel of the programmer, there is a power jack, an ON-
OFF power switch, a female DB9 serial port connector, and a Ground
jack for use with an ESD wrist strap. Figure 1-2 illustrates these
features.
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Caution: The Programmer may be damaged by static discharge into
the adapter connector or socket. Please follow normal Electro Static
Discharge (ESD) precautions when handling devices and the
programmer in order to avoid damage or misprogramming. Use a
ground strap when loading and unloading devices into the socket on
the adapter. Use caution when inserting or removing the socket
adapters.

Figure 1-2 Rear Panel of Programmer

Installation
Use the following instructions to set up the HW-130 Programmer
using Figure 1-1 and Figure 1-2 to guide you.

1. Turn off the power switch on the rear panel of the programmer.

2. Connect the RS-232 cable to the DB9 or the DB25 serial port on
your PC or workstation and the programmer DB9 serial port.

3. Connect the AC adapter to the power connector input and AC line
source.

4. Install the appropriate socket adapter onto the programmer 96-
pin connector as shown in Figure 1-1. Ensure that there is no
device in the socket, or the power-on self-test (POST) will not
function.

5. Turn on the programmer power switch.

After the power is turned on, the POST takes a few seconds to test
the hardware. The Power Indicator LED flashes during the POST
and then remains lit.

RS-232
2A

9V
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The Fail indicator LED flashes during the POST if there is a
hardware problem. Refer to Table 1-1 to determine the nature of
the problem.

Table 1-1  HW-130 Programmer Troubleshooting

Resetting the HW-130 Programmer
If for any reason, the programmer stops responding, the keyboard
locks up, or you wish to abort all operations, select the Reset
Programmer command from the Options menu to execute a
hardware reset. This command causes the HW-130 Programmer to
run its POST and display the test results listed in Table 1-1 if a
hardware error occurs. POST runs only once for each invocation of
Reset and is only active if there is no device in the socket adapter.

Software Installation
This section covers installation of the HW-130 Programmer software.
Go to the section for the environment you are using, Windows, UNIX,
or DOS.

Installing Software from Windows
Use the information in this section to install and run the program
from Windows.

Installing Software

To install the software, follow these instructions:

1. If you are using a diskette, insert the diskette into the appropriate

Fail Indicator Flashing Problem

1 time Socket adapter not empty
2 times EPROM checksum failure
3 times Voltage DAC calibration failure
4 times PVpp current measurement failure
5 times Memory banks 0 and 1 failures
6 times Memory banks 2 and 3 failures
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drive (typically A:). If you are using a CD-ROM, insert the CD into
the CD-ROM drive (typically D:).

2. Type the following to invoke Windows:

win ↵

3. Select Run from the File menu of the Program Manager.

4. Type the following information in the Run dialog box.

a:\setup.exe ↵ (diskette)

d:\windows\setup.exe (CD-ROM)

The HW-130 Installation dialog box is displayed as shown in
Figure 1-3.

Figure 1-3 Installation Dialog Box

5. Click OK to accept the default installation directory or type the
name of the drive and directory in which you want to install the
HW-130 Programmer software.

Starting the Program

After finishing the installation, start the program as follows:

1. Turn on the power on the HW-130 Programmer.

2. Open the Xilinx HW-130 Programmer group and click on the
following icon within that program group.

Figure 1-4 HW-130 Programmer Icon
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Note: If the software cannot establish communication with the
programmer, a message is displayed and indicates possible reasons
for the communication failure.

The HW-130 screen is displayed. It consists of a menu bar and
toolbar buttons. The toolbar buttons allow you to interface
directly with the programmer operations.

Figure 1-5 Main Window (Windows)

Menu Bar

The menu bar is located at the top of the HW-130 Programmer
window. It includes the File, Options, and Help menus.

Toolbar

The toolbar is located at the top of the screen below the menu bar. It
displays several icons, which you can use to specify commands
directly. The toolbar offers an alternative to the menu commands.

Note: In the DOS version of the program, the command buttons,
located at the bottom of the screen, replace the toolbar. See Figure 1-7.

Menu Bar

Toolbar

Display

Status Bar
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Display

The display includes fields that are updated with the device type, the
design name, and the device quantity that you select. Additional
information appears as you perform programmer operations.

Status Bar

The status bar is located at the bottom of the HW-130 Programmer
window. It provides information about the commands that you are
about to select or that are being processed.

Installing Software on a Workstation from CD-ROM
This section explains how to install and run the HW-130 software on
a Sun4 (SunOS and Solaris), HP9000/700 and IBM RS6000
workstations. The HW-130 software product has a graphical interface
and requires an X-based Windows Manager.

These instructions describe how to:

● Load the CD-ROM

● Check whether the CD-ROM drive is mounted.

● Mount the CD-ROM drive, if necessary.

● Run the CD-ROM installation script to install the HW-130
software.

● Starting the program.

Note: The commands in these instructions show the default device
name for a CD-ROM drive. Device names may be different on your
system. If you encounter problems, check your hardware reference
manuals or ask your system administrator.

Loading the CD-ROM into the Drive

Put the CD-ROM in a caddy and insert the caddy into the drive. A
caddy is a plastic case that holds the disk. Load the disk so the
printed side is facing up.

Checking Whether the CD-ROM Drive is Mounted

You need to have the CD-ROM drive mounted before you can install
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the software. To determine if the drive has already been mounted,
type:

/etc/mount

You should see a list of mounted devices. If a line similar to one of the
following lines appears in the list, the CD-ROM drive has already
been mounted on your system.

If the drive has been mounted, continue to “Running the CD-ROM
installation script.”

Mounting the CD-ROM on a Local System

To mount a CD-ROM on a local system, follow these steps:

Note: You must have root access. Contact your system administrator
if you need help.

1. Create the mounting point by creating a ‘cdrom‘ directory. If the
directory /cdrom  does not already exist, enter:

mkdir cdrom

2. Enter the mount command for your platform.

Sun OS /cdrom on /dev/sr0

Solaris /cdrom on /dev/sr0  or
/cdrom on /dev/dsk/c0t6/
hw130 if vold (Volume Management
Deamon) is running.

HP /cdrom on device  where
device  depends on your system.

IBM /cdrom on /dev/cd0

Sun OS /etc/mount -r -t hsfs /dev/sr0/cdrom

Solaris /etc/mount -F hsfs -r /dev/sr0/cdrom

HP /etc/mount device  /cdrom -r -t cdfs
where device  depends on your system. Check your
hardware reference manuals or ask your system
administrator.

IBM /etc/mount -v ‘cdrfs‘ -r /dev/cd0/cdrom



Getting Started

HW-130 Programmer User Guide 1-11

3. Verify that the drive was mounted correctly by typing:

/etc/mount

The displayed list of mounted devices should include the drive
you just mounted.

Running the CD-ROM Installation Script

The easiest way to install the software is to run the installation script
from the CD-ROM.

1. Type the CD-ROM installation command for your platform:

2. The CD-ROM installation script will un-tar a file ‘hw130’ located
in the /cdrom/ <platform_dir> to the target directory or install_dir.
The script will also allow you to change the install_dir if you do
not agree with the displayed default directory. Follow the
instructions on the screen.

Note: If the install script fails to install the software, you may
manually un-tar the HW-130 software from the appropriate sub-
directory to the install_dir. Create an install_dir target directory and
change directory (cd ) to it.

mkdir <install_dir>

cd  <install_dir>

Sun OS: /cdrom/install

Solaris: /cdrom/install
Note: Vold (Volume Management Deamon) might
have mounted the CD-ROM to ‘/cdrom/hw130 ’ or
‘/cdrom/cdrom0 ’ in which case you should run
‘/cdrom/hw130/install ’ or
‘/cdrom/cdrom0/install ’

HP: /cdrom/install

IBM: /cdrom/install.rs6
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3. To manually copy the files to your current directory, enter the
following tar command at the command line:

No further setup is required for the software.

Starting the Program

After finishing the installation, start the program as follows:

1. Launch the X-based Windows Manager (e.g. OpenLook,
OpenWindows or Motif Window Manager) on your system if it is
not already running.

Note: The HW-130 software has a graphical interface and requires an
X-based Windows Manager.

2. Connect the programmer to the serial port of the workstation and
to the power supply of the programmer.

3. Turn on the power switch at the back of the HW-130 Programmer.

4. Change directory to the install_dir (the directory where the
software was installed) and type the following at the command
line:

hw130 &

Note: If the software cannot establish communication with the
programmer, a message is displayed and indicates possible reasons
for the communication failure.

The HW-130 screen is displayed. It consists of a menu bar and
toolbar buttons. The toolbar buttons allow you to interface
directly with the programmer operations.

Sun OS: tar xvf/cdrom/sn2/hw130

Solaris: tar xvf/cdrom/sol/hw130
or
Note: Vold (Volume Management Deamon) might
have mounted the CD-ROM to ‘/cdrom/hw130 ’ or
‘/cdrom/cdrom0 ’ in which case you should run
‘tar xvf /cdrom/hw130/sol/hw130 ’ or
‘tar xvf /cdrom/cdrom0/sol/hw130 ’

HP: tar xvf /cdrom/hp7/hw130

IBM: tar xvf /cdrom/rs6/hw130
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Figure 1-6 Main Window (UNIX Workstations)

Menu Bar

The menu bar is located at the top of the HW-130 Programmer
window. It includes the File, Options, and Help menus.

Toolbar

The toolbar is located at the top of the screen below the menu bar. It
displays several icons, which you can use to specify commands
directly. The toolbar offers an alternative to the menu commands.

Display

The display includes fields that are updated with the device type, the
design name, and the device quantity that you select. Additional
information appears as you perform programmer operations.

Status Bar

The status bar is located at the bottom of the HW-130 Programmer
window. It provides information about the commands that you are
about to select or that are being processed.

Menu Bar

Toolbar

Display

Status Bar
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Installing Software from DOS
This section covers installation and program start-up from DOS.

Installing Software

To install the software, follow these instructions:

1. Insert the HW-130 Programmer software diskette into the
appropriate drive and select that drive (typically A:). If you are
using a CD-ROM, insert the CD into the CD-ROM drive (typically
D:).

2. At the DOS prompt, type the following:

a:/install.exe ↵ (diskette)

d:/dos/install.exe ↵ (CD-ROM)

3. Follow the instructions on your screen.

Figure 1-7 Main Screen (DOS)

Use the menus and command buttons to interface to the HW-130
Programmer. In general, menu commands are for software
configuration and diagnostics, and command buttons are for
programmer operations. Refer to the online help for a detailed
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description of the menus and command buttons.

Configuring Software
The HW-130 software automatically configures the programmer and
your host computer for reliable communications. The default ports
that the PC or Workstation uses to find the HW130 programmer, are
listed in Table 1-2. Once configured, the communications settings can
be saved by selecting Save Settings from the File menu.

If the software cannot find the programmer, a dialog box is displayed
with a list of possible causes. Check to see that you have read and
write permissions on the serial ports for the workstation.

Table 1-2  Default Ports

Setting the Communications Options Manually

Once configured the HW-130 Programmer software operates at
standard baud rates that include: Auto, 1200, 2400, 4800, 9600, 19200,
and 38400 baud. Use the HW-130 Programmer software to change the
baud rate and the communications port if necessary.

Note: The DOS version also supports the 57600 and 115200 baud
rates.

1. Select Options ➝ Communications  to display the

Platform Default Ports Used

PC COM1 COM2 COM3 COM4

Sun4 ttya ttyb

Solaris ttya ttyb

HP700 ttya ttyb tt00 tt01

IBM RS6000 ttya ttyb tty0 tty1
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Communications dialog box.

Figure 1-8 Communications Dialog Box (Windows)

2. Select the baud rate you want.

3. Select the port type you want.

On a PC, the serial port options include AUTO, COM1, COM2,
COM3, and COM4. On a Sun Workstation, the serial port options
include AUTO, ttya, ttyb or any user defined serial device. On HP
workstations, the serial port options include AUTO, ttya, ttyb,
tty00, tty01 or any user defined serial device. On IBM
workstations, the serial port options include AUTO, ttya, ttyb,
tty0, tty1, or any user defined serial device. The software displays
only the port options for the ports available on your PC or
workstation. AUTO is the default. If you use the default, the
software searches for the programmer through all available
communications ports and negotiates the highest available baud
rate between the PC or workstation and the programmer.

On a workstation, select the port type you want by specifying the
path and device name for that port in the Serial Port Device name
box of the Communications dialog box, for example, /dev/ttya.
From the specified serial port box, you can also access different
serial device drivers, provided your system is configured to use
them.

4. Click on the OK button to exit from this window.

5. You can save these settings by selecting Save Settings  in the
File menu. These settings will be used with your next
programming session.
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Selecting Commands and Dialog Box Options
To choose a menu item or an option in a dialog box, you can use the
mouse or the keyboard.

Using the Mouse
Use the following guidelines when using the mouse to select menu
options or dialog box options.

1. Move the mouse pointer over a toolbar button or a menu name
and click on the left mouse button to select the object.

If you clicked on a toolbar button, a list box or a dialog box
appears if appropriate. If you clicked on a menu, menu options
are displayed.

2. Click on the option you want to use.

3. To exit a list box or a dialog box without selecting anything, press
Cancel. To exit a dialog box you can also double-click on the
upper left corner of the dialog box.

Using the Keyboard
Use the following guidelines when using the keyboard to select menu
options or dialog box options.

1. To choose a menu item, first select a menu by pressing the Alt key
and the highlighted letter key for that menu.

Note: On a workstation, use the F10 function key instead of the Alt
key to select the first menu, then use the arrow keys to select the other
menus.

The menu options are displayed.

2. Use the arrow keys to scroll down the list of menu or list items.

The status bar describes the option that is currently highlighted.

3. Press Enter when the option you want to use is highlighted or
type the underlined letter in the menu item name.

4. To exit a list box or dialog box without selecting anything, press
Escape or use Tab to position the cursor on the Cancel button and
press the Enter key.
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The DOS quick keys are also supported in Windows and UNIX. To
select a programmer operation, press the appropriate quick key. Refer
to the “Keyboard Reference” appendix for a complete list of keyboard
commands and programmer quick keys.

Invoking Help
There are several ways of getting Help from the HW-130 program.

● To get help from the main screen, select the Contents option of the
Help menu.

● To get help from the dialog boxes, click on the Help button located
on these dialog boxes. Alternatively, on a PC, you can use the Alt-
H key combination to access the help page for that dialog box.

● On a PC, to get information about the menu commands, highlight
the menu option and press the F1 key. The help page
corresponding to the menu option is displayed when you release
the F1 key.
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Chapter 2

Programmer Operations

This chapter describes the programmer procedures available for the
HW-130 Programmer. Before attempting any of the programmer
operations included in this chapter, verify that the device type and
other device-related criteria are correct.

If you saved the settings of a previous programming session, the
software uses the last-used communications port, baud rate, and
sound options when you execute the hw130.exe program. These
settings are stored in the hw130.ini file.

Programming Quickstart
The following figure outlines the steps required to program a device.

Figure 2-1 Main Screen (Windows and UNIX)

Step 1:
Select the device type
to program. The algorithm is
downloaded at the same time.

Step 2:
Select the design to program
into the device. The file
checksum is displayed after
the file is loaded.

Step 3:
Enter the quantity of devices
to program. The default is 1.

Step 4:
Select this button to initiate the
programming sequence. This
step includes a blank check
and a verification. The device
checksum is updated after
completion of programming.
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Figure 2-2 Main Screen (DOS)

Note: Throughout this section, quick keys are indicated next to the
programmer operations. A summary of all the quick keys and how to
use them is available in the “Keyboard Reference” appendix.

Specifying a Device (Ctrl-D)
To specify a device, use the Select Device command and follow these
instructions.

1. Install the appropriate adapter for the device to be selected and
programmed. Refer to Figure 1-1 for an illustration showing how
to place the adapter on the programmer.

Note: If you have installed the wrong adapter for the selected device,
an error message appears when you begin an operation.

2. Select the Select Device  command from the File menu or click
on the Select Device  toolbar button shown in Figure 2-3.

Step 2:
Select the design to program
into the device. The file
checksum is displayed after
the file is loaded.

Step 1:
Select the device type

Step 3:
Enter the quantity of devices
to program. The default is 1.

Step 4:
Select this button to initiate the
programming sequence. This
step includes a blank check
and a verification. The device
checksum is updated after
completion of programming.

to program. The algorithm is
downloaded at the same time.
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Figure 2-3 Select Device Toolbar Button

After you select the device, the software automatically downloads
the corresponding device algorithm into the memory of the
HW-130 Programmer. The status bar marks the progress of the
download operation.

Figure 2-4 Device Selection Dialog Box

Specifying a Design (Ctrl-F)
Before programming a device, you must specify the design file to
download to the programmer memory.

1. Select a design by selecting the Open File  command from the
File menu or by clicking on the Select Design toolbar button
displayed in Figure 2-5.

Figure 2-5 Select Design Toolbar Button

The Open File dialog box is displayed as shown in Figure 2-6.
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Figure 2-6 Open File Dialog Box

2. Specify the drive, directory, and file name of the design to
download. You can specify one or all of the file formats listed in
Table 2-1 in the List Files of Type box to locate files of the file type
you want.

Table 2-1  Supported File Formats

Note: The HW-130 programmer will automatically give the user the
correct format for the device selected. Some formats listed may not be
applicable for all devices in a particular family. For information on
how to generate these files using the Xilinx tools, refer to the XACT
development system documentation.

3. Click on the OK button to accept the selections.

Format Description

SPROM
MCS Intel MCS-86 format (preferred default)
EXO Motorola EXORmacs format
TEK Tektronix TEKHEX format
EPLD/CPLD
PRG Extended Intel HEX format
JED JEDEC format
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The design file that you specify is downloaded to the memory of
the HW-130 Programmer when you click on the Design File OK
button. The File Checksum field is updated with the checksum of
the downloaded file.

Note: If an XC1700 design does not fit the targeted device, a message
is displayed, informing you that your design file is too large for the
selected device. In this case, you must select a larger device to fit your
design.

Specifying a Profile
Use the Profile command to define information for a programming
session and save it to a file. You can store setup information for a
selected device, such as a specific design file, secure option, or the
Reset Polarity. When you select a profile, it automatically sets up the
programmer to the desired conditions, with no intervention on your
part. Profile is accessible at any time during a programming session
from the File menu or from the toolbar, enabling you to load a preset
profile.

Figure 2-7 Load Profile Toolbar Button

Creating a Profile
To create a profile, follow these instructions:

1. Select Profile ➝ Create  from the File menu.

2. Select a device from the Device List.

3. Select Secure Device(s)  or Reset Polarity Active High,
or Reset Polarity Active Low , depending on the device
selected.

4. Click on OK.

5. Select a design file from the Open File dialog box.

6. Click on OK after choosing the correct file.

7. A dialog box appears, displaying the items that you selected to
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include in your profile. If everything is correct, click on OK. Use
the Change button to modify any incorrect information.

The software prompts you to choose a profile name. Select a file
name and click on OK. All profiles have a .pro extension.

Loading a Profile
To load a profile, follow these instructions:

1. Select Profile ➝ Load  from the File menu.

2. Locate the profile you want.

3. Double-click on the profile you wish to load.

Deleting a Profile
To delete a profile, follow these instructions:

1. Select Profile ➝ Delete from the File menu.

2. Locate the profile you want.

3. Double-click on the profile to delete.

The software prompts you to confirm that this is the file that you
wish to delete. If it is, click on OK. If it is not the correct file, click
on Cancel  and reselect.

Programming the Device (Ctrl-P)
Use the Program Device command to program one or more devices.
This command is available only if you have specified a device. This
procedure also assumes you have specified a design file.

1. Specify the number of devices to program in the Quantity  field
of the HW-130 display.

2. Select the Program Device  command from the Options menu or
click on the Program Device  toolbar button shown in
Figure 2-8.

Figure 2-8 Program Device Toolbar Button
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3. The software prompts you to input the Reset Polarity or to set the
Device Secured field depending on the device selected. Not all
options are available for all devices.

● Select High  or Low active Reset. High is the default.

● Select the desired security.

Depending on the device selected, several security; options
may be available:

1. Select No to disable the security feature (the default).

2. Select Yes  to activate the security feature.

3. Select Secure Only  to secure a previously programmed
device.

Note: For some other devices several other security
alternatives can also be selected:

❏ Read Secure -- This option disables the device from being
read, but still permits it to be erased and reprogrammed.

❏ Write Secure -- This option allows the device to be read, but
disables the ability to erase and reprogram.

❏ Read and Write Secure -- This invokes both types of security
as listed above.

Once secured, only the signature string can be read.

Note: You only need to answer these questions once during
programming, regardless of the quantity selected. If you configure
the programmer by opening a profile, you are not prompted to
answer these questions since these settings are part of the profile.

4. If the specified device quantity is more than 1, the message
“Please Insert Device N of M in the Socket ” is
displayed, where N is the current device and M is the maximum
quantity selected. Place the first device you wish to program in
the socket adapter. To program the next devices, you can also
initiate the program command by pressing the programmer push-
button.

Check the status bar to view the progress of the programming
operation. After programming the device, the software updates
the Pass/Fail and Device Checksum fields on the display.
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5. Repeat the previous step until you have programmed all the
devices.

When you program a device, the software completes the following
operations: Blank Check, Program, Verify, and Checksum calculation.

Loading the Device (Ctrl-L)
Use the Load Master Device command to load the contents of a
master device into the programmer memory.

1. Place the device you wish to load in the socket adapter.

2. After inserting the device in the socket, select the Load Master
Device command from the Options menu or click on the Load
Master toolbar button shown in Figure 2-9.

Figure 2-9 Load Master Toolbar Button

The software reads the device and copies its contents into the
programmer memory. The device checksum field and the device
reset polarity field for certain devices are updated. You can use the
data to program other devices or to verify other programmed
devices against it.

Verifying the Device (Ctrl-V)
Use the Verify Device command to compare a programmed device to
the data pattern that has already been loaded into the programmer
memory.

Figure 2-10 Verify Device Toolbar Button

Comparing a Device to a File
You can compare a programmed device against a file.
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1. After programming a device, select the Verify Device
command from the Options menu or click on the Verify
Device  toolbar button.

The software compares the device to the file that you loaded into
the programmer memory.

Note: If the programmer memory is empty, you are prompted to
select a file to be downloaded into the programmer memory before
the software can verify the device.

If the device matches the file, the software updates the Device
Checksum and Pass display.

If there are differences, an error message is displayed.

2. Repeat the previous step until you have verified all the copies of
the specified device type either by clicking on the Verify
Device  toolbar button or by pressing the programmer push-
button.

Comparing One Device to Another
You can load a device pattern in the programmer memory ready for
the software to compare it to another device. Use the Load Master
toolbar button to do this.

1. After inserting a programmed device in the socket, select Load
Master  to load that device pattern into the programmer memory.

2. Remove the device from the socket and insert the device against
which you want to verify the RAM data.

3. Select the Verify Device  command from the Options menu or
click on the Verify Device  toolbar button shown in Figure 2-
10.

Checking for Blank Device (Ctrl-B)
Use the Blank Check command to ensure that the device in the socket
is blank.

1. After inserting the device in the socket, select the Blank Check
Device command from the Options menu or click on the Blank
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Check toolbar button shown in Figure 2-11.

Figure 2-11 Blank Check Toolbar Button

The software executes the Blank Check command.

If the device is not blank, the message “Failed Blank Check”
is displayed. Otherwise, the software updates the display.

2. Repeat the previous step until you have checked all the devices
either by clicking on the Blank Check toolbar button or by
pressing the programmer push-button.

Calculating the Device Checksum (Ctrl-K)
Use the Device Checksum command to calculate the checksum of the
contents of the device in the socket. The method used to calculate the
checksum ignores non-data bits, such as manufacturer ID, device ID,
and reset polarity.

1. After inserting the device in the socket, select the Device
Checksum  command from the Options menu or click on the
Device Checksum  toolbar button.

Figure 2-12 Device Checksum Toolbar Button

The software executes the Device Checksum command and
updates the display.

2. Repeat the previous step until you have calculated the checksum
of all the devices either by clicking on the Device Checksum
toolbar button or by pressing the programmer push-button.

Viewing the Signature String (Ctrl-S)
Use the Signature String command to retrieve the signature of the
device. The signature string consists of eight alphanumeric characters
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used to identify designs or devices. You can specify this string into
the design file when the file is compiled.

1. After inserting the device in the socket, select the Signature
String  command from the Options menu or click on the
Signature String  toolbar button shown in Figure 2-13.

Figure 2-13 Signature String Toolbar Button

The Device Signature message box is displayed, indicating the
signature of the device.

2. Repeat the previous step until you have read the signatures of all
the devices either by clicking on the Signature String toolbar
button or by pressing the programmer push-button.

Saving the Programmer Memory Contents to a File
(Ctrl-C)

Use the Save RAM to File command to save the programmer memory
contents to an output file.

Note: The DOS command equivalent to this function is the Create a
File button.

1. Select the Save RAM to File  command from the File menu or
click on the Save RAM to File  toolbar button.

Figure 2-14 Save RAM to File Toolbar Button

2. The software displays the Save RAM to File dialog box for you to
specify the file name and location that will store the file.

The format of the output file can be one of the programming file
formats. Ensure you specify a file extension when you enter a file
name.
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Appending Data (Ctrl-A)
Use the Append Data command to create a new file from two existing
files and download the new combined file into the programmer
memory. Thereafter, you can use the file to program a device. The
Append Data button is available only if you have specified a device
with this feature.

1. Select the Append Data  command from the File menu or click on
the Append Data  toolbar button.

Figure 2-15 Append Data Toolbar Button

2. The Original Design File dialog box is displayed for you to specify
the original file to which you will add another file. Specify the
design as explained at the beginning of this chapter.

3. The software then displays the Design to be Appended dialog box
for you to specify the design file to be added to the original design
file.

The software appends the data to the original file and downloads
the combined design file to the programmer memory.

At this point, a dialog box is displayed prompting you to select
one of three options: Program, Save RAM to File, or Cancel.

4. Select the option corresponding to the task you want to perform.
For information on the Program and Save RAM to File options,
refer to the procedures “Programming the Device” and “Saving
the Programmer Memory Contents to a File,” also covered in this
chapter.

The software updates the display with the file checksum of the
new combined design file.
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Chapter 3

Command Reference

This chapter presents the commands available for the HW-130
Programmer. The commands are listed in alphabetical order. When
applicable, the corresponding toolbar button is included in the
command description.

Menus
The HW-130 Programmer has three menus, which are described in
the following sections.

File Menu
The File menu contains commands to select the device type and the
design file. It also includes commands to create files, save the
programmer settings, set the profile, and exit the program.

To access the File menu with the keyboard on a PC, press the letter F,
underlined in the menu name, while holding down the Alt key. Press
the underlined letter corresponding to the menu option you want.
The commands on the File menu are the following:

Select Device Selects a device type.
Open File Opens a design file.
Save RAM to File Saves the contents of the programmer

memory to a file.
Append Data Adds a file to another file.
Save Settings Saves the programmer communications

port and baud rate settings.
and sound options.

Profile Loads an existing profile, creates or
deletes a profile.

Lot Summary Prints lot specific information.



HW-130 Programmer User Guide

3-2 Xilinx Development System

Exit Exits the HW-130 software.

Options Menu
The Options menu includes commands to execute programmer
commands and commands to configure and diagnose the
programmer. To access this menu with the keyboard on a PC, press
the letter O, underlined in the menu name, while holding down the
Alt key. Press the underlined letter corresponding to the menu option
you want.

Program Device Programs the selected device with the
selected design.

Verify Device Compares the programmed device to the
file currently loaded in the programmer
memory.

Load Master Loads the contents of a programmed
device into the programmer memory.

Blank Check Device Checks that the device is blank.
Signature String Retrieves the signature of devices.
Device Checksum Checks the device checksum.
Auto-Calibration Measures the voltage and current for

each power supply.
Diagnostics Provides several diagnostics loops to

check the port, memory, pin drivers,
and supply voltage.

Reset Programmer Resets the programmer.
Autohandler Mode Turns the autohandler mode on or off.
Communications Sets the port and baud rate of the

HW-130 Programmer.
Sound Sets the sound on or off.

Help Menu
The Help menu contains commands that enable you to access online
help for the HW-130 Programmer. To access this menu with the
keyboard on a PC, press the letter H, underlined in the menu name,
while holding down the Alt key. Press the underlined letter
corresponding to the menu option you want.

Contents Lists online help topics.
About HW-130 Displays the program version.
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Alphabetical Listing of Commands
This section lists the menu commands of the HW-130 software
program.

About HW-130 (Help Menu)
Use this command to display the program version, as shown in
Figure 3-1.

Figure 3-1 About HW-130 Dialog Box

Append Data (File Menu)
Use this command to combine two files and download them into the
programmer memory. You can then save the RAM data into a file or
use that data to program devices. This command is available after
you have specified a device type.

Figure 3-2 Append Data Toolbar Button

Auto-Calibration (Options Menu)
Use this command to measure the voltage and current for each power
supply. When you select this command, the Auto-Calibration dialog
box is opened showing the status of the available supplies of the
programmer. You must use the calibration adapter for this operation.
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Autohandler Mode (Options Menu)
Use this command to turn the autohandler mode on or off. When you
turn on the autohandler mode, a Handler Mode field is added to the
bottom right-hand side of the display. If you have not installed an
auto-handler, this command should be set to off.

Figure 3-3 Handler Mode Set to On

Blank Check Device (Options Menu)
Use this command to check that the device is blank. This command is
available after you have specified a device type.

Figure 3-4 Blank Check Toolbar Button

Communications (Options Menu)
Use this command to set the port and baud rate of the HW-130

Handler Mode
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Programmer, if necessary.

Figure 3-5 Communications Dialog Box

Contents (Help Menu)
Use this command to bring up a list of help topics in the online help
window.

Device Checksum (Options Menu)
Use this command to check the device checksum.This command is
available after you have specified a device type.

After calculating the device checksum, the program updates the
appropriate field on the display: Pass if the operation was successful,
and Fail if the operation failed. In addition, the Device Checksum
field on the display reflects the new value.

Figure 3-6 Device Checksum Toolbar Button

The checksum number of a programmed device should match the
checksum of the file that was used to program the device. The
following figure is a partial view of the display that was updated
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with the checksum number of a programmed device.

Figure 3-7 Device Checksum of a Programmed Device

Diagnostics (Options Menu)
Use this command to execute the diagnostics loops and check the
port, memory, pin drivers, and supply voltage of your programmer.
Select a test by clicking on the radio button preceding the test that
you want to execute. Then press the Execute button to start the test.
For more information, refer to the “Diagnostics Procedures”
appendix.

Device Checksum
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Figure 3-8 Diagnostics Dialog Box

Exit (File Menu)
Use this command to exit the HW-130 Programmer window.

Load Master (Options Menu)
Use this command to load the contents of a programmed device into
the programmer memory. You can then use the data to program
another device. This command is available after you have specified a
device type.

Figure 3-9 Load Master Toolbar Button

After loading the master device, the program updates the
appropriate field on the display: Pass if the operation was successful,
or Fail if the operation failed.
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Lot Summary (File Menu)
Use this command to record lot specific information, such as Lot
Number, Operator Name, Operator Number, and any other Lot
Information required. When printed, the software automatically
appends the Time, Date, Operation Performed, Device Type,
Algorithm Version, Profile Name (if applicable), Design File Name,
File Checksum, and Pass and Fail Quantities.

Note: This is only applicable to DOS and Windows.

Open File (File Menu)
Use this command to open the file you will use for programming one
or more devices.

Figure 3-10 Select Design Toolbar Button

When you open a file, you download it into the programmer memory.
This command is available after you have specified a device type.

Profile (File Menu)
A profile consists of a device type, a design file, and the device
polarity or security. Use this command to load an existing profile,
create or delete a profile. Once you have created a profile, you can
invoke it whenever you need to use it. If you load a profile and select
the Program command, you will not be prompted to enter the device
polarity or security feature anymore.

Figure 3-11 Load Profile Toolbar Button

Program Device (Options Menu)
Use this command to program one or more devices with the selected
design. This command is available only if you have selected a device
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type.

Figure 3-12 Program Device Toolbar Button

The program executes the following operations: blank check,
program, verify, and device checksum. You can use this command
after using any one of the following commands that load a design file
into the programmer memory: Open File, Load Profile, Append Data,
and Load Master.

If programming is successful, the program updates the Pass field;
otherwise, it updates the Fail field.

Reset Programmer (Options Menu)
Use this command to reset the programmer. This command is
equivalent to turning the programmer off and on again.

Save RAM to File (File Menu)
Use this command to save the contents of the programmer memory
to a file.

Figure 3-13 Save RAM to File Toolbar Button

You can use this command after using any of the commands that load
data in the programmer memory: Open File, Append Data, and Load
Master.

Specify the name of the file in which the RAM data is to be saved as
well as the file extension. The file extension can be .tek, .mcs, .exo,
.prg or .jed and represents a file format in which to save the file.

Save Settings (File Menu)
Use this command to save the programmer settings, such as the port,
baud rate, and sound options. The data is saved to hw130.ini. If you
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are using the DOS version of the program, you can also save the color
settings that you specified.

Select Device (File Menu)
Use this command to select the type of device you want to program.
When you select a device, the program downloads the device
algorithm into the programmer memory.

Figure 3-14 Select Device Toolbar Button

Signature String (Options Menu)
Use this command to display the signature of EPLD/CPLD devices.

Figure 3-15 Signature String Toolbar Button

Sound (Options Menu)
Use this command to set the sound on or off. When sound is set to on,
the program emits a sound whenever you encounter an error.

Verify Device (Options Menu)
Use this command to compare a programmed device to the file
currently loaded in the programmer memory. This command is
available only if you have selected a device.

Figure 3-16 Verify Device Toolbar Button

You can use this command to verify that your device was successfully
programmed. You can also use this command to compare one device
to another. After programming a device, replace the current device
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with the device that you want to evaluate and click on Verify.

If the verification is successful, the Pass field is updated on the
programmer display; otherwise the program updates the Fail field.
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Appendix A

Keyboard Reference

This appendix summarizes the keyboard commands you can use to
navigate on the programmer display. It also lists all the keyboard
commands you can use to activate programmer commands.

Keyboard Commands
Use the following keyboard commands to navigate and select objects
on the screen.

Table A-1  Summary of Keyboard Commands

Key Action

Tab Traverse objects forward and highlight them.

Shift -Tab Traverse objects backward and highlight
them.

Enter Activate a selection button or a highlighted
item in a list.

Arrow keys Scroll up or down inside selection boxes and
menus. Navigate from one menu to another.

Alt -Character Select a menu on a PC and Workstation
F10 Select a menu on a workstation.
Ctrl- Character Select a programming quick key operation.

Esc Unselect a menu or exit a Help window.
Abort the current operation.
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Quick-Key Reference
To select command buttons, use the Tab key or press the appropriate
quick key from the list displayed in Table A-2. The table lists all the
programmer quick keys you can use as an alternative to the
command buttons.

1. To select a quick key, locate a programmer operation and its
corresponding quick key in Table A-2.

2. Hold down the Ctrl  key while you press the other key indicated.
For example, type Ctrl-P to select the Program Device button.

Table A-2  Programming Quick Keys

Programmer Operation Quick Key

Device Select Ctrl-D
Design File Ctrl-F
Quantity Ctrl-Q
Program Device Ctrl-P
Load Device Ctrl-L
Verify Device Ctrl-V
Blank Check Ctrl-B
Device Checksum Ctrl-K
Signature String Ctrl-S
Create a File Ctrl-C
Append Data Ctrl-A
Cancel ESC
Exit Ctrl-X
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Appendix B

Diagnostics Procedures

This appendix explains how to monitor the calibration of the HW-130
Programmer and how to run the diagnostic tests.

Auto-Calibration
The HW-130 Programmer automatically calibrates itself whenever
you turn on the power or you use the Reset Programmer command.
However, the HW-130 provides the capability to monitor the
operation of the calibration circuitry. The calibration adapter shown
in the following figure is required.

Figure B-1 Calibration Adapter
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To start the auto-calibration, follow these steps after turning on the
power on your programmer:

1. Install the HW-130-CAL calibration adapter, shown in Figure B-1.

The calibration adapter includes test points for measuring the
voltage and current levels of the programmable power supplies.

2. Select Options ➝ Auto-Calibration .

A dialog box is opened showing the status of the available
supplies.

Note: Depending on the version of the hardware, PVsp may or may
not be displayed.

3. To measure the voltage and current for each power supply, use the
provided switches (see Figure B-2).

In the closed position, the switches on the adapter connect load
resistors to their respective power supplies. Open the switch to
measure current that corresponds to the supply being measured.

Figure B-2 Measuring Voltage and Current

4. To measure current, open the switch that corresponds to the
supply being measured and connect the external current
measuring equipment to the adapter, as shown in the preceding
figure. The HW-130 results that are displayed in the Auto-
Calibration dialog box should agree with the value measured by
the current measuring equipment by the following percentages:

● PVcc should be ±1%

● Icc should be ±10%
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● PVpp should be ±1%

● Ipp should be ±10%

● PVsp should be ±1%

● Isp should be ±10%

Note: The results are only as good as the equipment used to measure
the programmer’s results. Ensure that your meters are calibrated and
accurate.

Note: PVsp and Isp may not be available for your version of the
hardware.

5. Click on the Execute  button.

The programmer firmware executes the calibration routines. The
results are displayed in the Auto-Calibration dialog box.

Diagnostics
The diagnostics routines consist of software loops that exercise
various functional blocks within the programmer, allowing you to
verify that the blocks are operating properly.

Use the following guidelines to select and run a test:

1. Select Options ➝ Diagnostics  to display the Diagnostics
dialog box.

2. Select a diagnostic loop to run.

3. Click on the Execute  button to start the test.

4. Check the Diagnostics Status box to view the results of the test.

Note: Once you select and execute a diagnostic loop, the test
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continues to run until you cancel it by clicking on the Cancel  button.

Figure B-3 Diagnostics Dialog Box

RS-232 Serial Communications Test
This test allows you to verify the RS-232 port on the host system at
various baud rates.

1. Select RS-232 Serial Communications  from the Diagnostics
dialog box.

The Communications dialog box is opened.

2. Specify the baud rate and the communications port.

3. Click on OK to close the Communications dialog box and start the
test.

The host and the HW-130 Programmer transmit and receive data
at the set baud rate until you cancel the test.

Each time you complete a test, you are informed whether the test was
successful or not. A message is displayed if a communication error
occurs.
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Memory Test
This test writes a non-repeating data pattern to the HW-130
Programmer data memory to ensure that every bit location can be
accessed and that both a logic “1” and “0” can be written and read.

Each time you complete a test, you are informed whether the test was
successful or not. If the test fails, the Diagnostics Status box also
displays which memory bank failed.

Pin Driver Clock Test
The Pin Driver test exercises every address, data, and clock signal
that connects to the socket adapter interface connector.

1. To use this test, install a socket adapter with no device in the
socket.

2. Select Pin Driver Clock Test from the Options Diagnostics
menu.

3. Click on Execute .

Note: To stop the test, click on Cancel.

The address, data, and clock signals are driven between a CMOS
logic “0” and “1” at approximately 36 kHz. You can view them using
an oscilloscope to probe the appropriate pins of the adapter socket.
Refer to the device data sheet for pin-out information. There are no
Pass/Fail conditions for this test.

Warning: Exercise caution when probing the socket pins to avoid
damaging them.

When you use the calibration adapter shown in Figure B-1, signals
are connected such that the HW-130 Programmer is able to test all the
pins as both input and output signals. The programmer will display
any errors that occur and continuously toggle all the signals at the
approximate rate of 36 KHz.

Programmable Supply Voltage Loop
The HW-130 Programmer has two programmable power supplies
called PVcc and PVpp, which are used to program devices.

1. To use this test, install a socket adapter with no device in the
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socket.

2. Select Programmable Supply Voltage from the Options
Diagnostics menu.

3. Click on Execute .

The loop causes the supplies to step between the four voltage levels
shown in Figure B-4.

You can view the waveforms by using an oscilloscope to probe the
appropriate pins of the adapter socket. Refer to the device data sheet
for pin-out information. There are no Pass/Fail conditions for this
test.

Warning: Exercise caution when probing the socket pins to avoid
damaging them.

Figure B-4 Programmable Supply Test Levels
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Appendix C

Automation

This chapter describes the setup and operation of the HW-130
programmer in conjunction with autohandling equipment.

Selecting the Autohandler Mode
To select the autohandler mode of operation, follow these
instructions.

1. Connect the HW-130 programmer to the autohandler.

Refer to Figure C-1 for the appropriate interface timing and Figure
C-2 for signal locations.

Figure C-1 Handler Timing for HW-130 Programmer

Request assistance from the autohandler manufacturer for proper
connection (both mechanical as well as electrical).
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Figure C-2 HW-130 96-Pin DIN Connector (Top View)

2. Select Options ➝ Autohandler ➝ On.

The main screen now indicates that the autohandler is on.

Programmer Operation
This section summarizes the instructions for using the programmer in
conjunction with an autohandler. Please refer to the “Programming
Operations” chapter for details on the individual procedures.

1. Specify a device by pressing the Device Select  button on the
main screen.

Alternatively, you can select a profile. The profile loads a device
type, its polarity or security feature, and a design into the
programmer memory.

2. Click on the Select Design  toolbar button to open a design.

Note: If you wish to load a master device, do so before selecting the
autohandler mode.

3. Specify the device quantity to program in the Quantity  field.

The quantity only needs to be specified for programming.

4. Select the desired programmer operation, Program Device ,
Verify Device , or Blank Check  by pressing the appropriate
toolbar button on the HW-130 Programmer main screen.

Note: While you are in autohandler mode, only the Program Device,
Verify Device, and Blank Check commands are functional. To use the
other commands, you must not be in autohandler mode.
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The programmer is now in the ready-state, waiting for the Start-of-
Test signal from the autohandler. Follow the instructions from the
autohandler manufacturer to operate the autohandler properly.
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Appendix D

Wiring Conventions

This appendix includes wiring information that you can use for
hardware purposes.

Power Cord
The following illustration indicates the wiring of the HW-130
Programmer power cord. The following illustration shows the
commonly used wiring convention for the U.S.A. power cord. Use
the wire colors as a wiring guide.

Figure D-1 Typical U.S.A. Power Cord
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Serial Connector
The following illustration shows the serial port connections.

Figure D-2 HW-130 Serial Connector
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