Hi Matt,
> Cadence would like to propose the addition of a convenience
> method/function
> to retrieve a pointer to the SceMi object, if it has been successfully
> Init'ed:
>
>
> C++:
>
> static SceMi *
> SceMi::ObjectPointer();
>
> C:
>
> SceMi *
> SceMiObjectPointer();
>
> [...]
>
> Please weigh in with objections to this, to be sure, but also with any
> naming convention that is or is not being followed with this proposed
> addition.
I support this. This is useful especially in layered and modular
environments.
How about changing the names of these to simply SceMi::Pointer() and
SceMiPointer()? Also, we might want to add a SceMiEC argument for
symmetry and to open the door for those implementations that would
want to do some extra sanity checking besides just returning the
pointer.
Per
-- Per Bojsen Email: <bojsen@zaiqtech.com> Zaiq Technologies, Inc. WWW: http://www.zaiqtech.com 78 Dragon Ct. Tel: 781 721 8229 Woburn, MA 01801 Fax: 781 932 7488Received on Fri Nov 5 08:45:59 2004
This archive was generated by hypermail 2.1.8 : Fri Nov 05 2004 - 08:46:01 PST